Click here for important information about

Floppy Disk format error or I/O error

January 6, 2010 at 22:28:41
Specs: Windows XP, i5-750; Corsair 4MB
Ever since installing a new P55A I am not able to format a Floppy Disk.
What I can't do: I cannot format, not copy always successfully, nor read and write successfully.

What I can do: I boot up to a Dos Prompt, and execute Dos commands, read, write, and format.
One can also boot into (F8) Safe mode (both in user & admin) and read, write, copy, and format.
It takes 5 to 7 seconds to format in Safe Mode.

Under Windows XP(SP2) it takes some 5 minutes,
listening to a grinding click/clack instead of the evenly spaced tick, tick as a format should do.
The result warning notice is: "Window is unable to format the disc." or one gets, "Windows cannot copy because of an I/O Device error".

The device information, of both the "Std Floppy Disc Controller" and "Floppy disk drive", in the Device Manager, in regards to (1) Drivers (2) Device ID, ACPI, and (3) Resources are identical in Safe Mode as well as in WinXP and reporting working properly".

We can rule out dust & dirt, cabling, bad device, proper voltage, and the motherboard controller, in that any of those would also affect both the Real-Dos-Prompt and Safe Mode. Hence I am leaning that there is a conflict within Drivers supplied by Gigabyte - since not all Gigabyte drivers load in safe-mode. Removing as many devices as possible and Disabling as many devices as possible then reinstalling them one by one is a tedious task, not a worthy to bestow upon a customer who expects a motherboard to work without being a computer expert.

Therefore I am seeking your help in any clues which would save me the time which I don't have.
Thank you.

See More: Floppy Disk format error or I/O error

January 7, 2010 at 00:20:59
Go to IDE ATA/ATAPI controllers in Device Manager.

Right click on each listed.

Properties > Advanced Settings > Transfer Mode:

Select DMA if avalable & click OK.

Reboot & make sure the settings stuck

How to enable DMA in Windows XP (with pictures)
Problems enabling DMA on IDE drives

Report •

January 7, 2010 at 07:58:20
Thank you Johnw for your response. I checked as you said, and found that those were DMA was a choice, were already so marked. But clicked OK anyways.
But in the Floppy Controller such choices are not available.
The present setting (which one cannot see in the Dev Mgr)
are: IRQ 06 & DMA 02 I/O range 03F0 - 03F5 and 03F7 - 03F7

I also loaded on a clean formatted drive a new XP(SP2), just now.
Added a new Floppy cable and a 4th different Floppy Drive.
No Changes made, No programs loaded. Simply opened CMD to format. The format failed. Would that now point to the Motherboard as being defective or is there another solution ?

Report •

January 7, 2010 at 08:51:02
Did you install the motherboard chipset drivers from Gigabyte.

Check device manager to see if there is a resource conflict with the floppy using IRQ6.

Report •

Related Solutions

January 7, 2010 at 15:42:51
Don't know if it is XP pro or Home, or if SP3 is installed, here is the correct procedure to use the same HD with a new MB.

May be easier/quicker to format!

Upgrading A Motherboard Without Reinstalling
Changing a Motherboard or Moving a Hard Drive with XP Installed
Repair Install to SET XP to New Motherboard

Report •

January 7, 2010 at 16:03:47

Did you re-install or repair WinXP as johnw notes, after changing motherboards?

Report •

January 8, 2010 at 01:44:38
You fellows are fantastic, thanks for all your advice.

Yes, I installed XP(SP2) clean on a formatted drive after I
installed the P55. And loaded Windows only after all new hardware. All hardware is also new except the Hard drives.

I also ran repair after I found out that the Floppy Controller caused error. "That was a waste of time." But hallauya I finally fixed the problem by removing "all" hardware except the mobby & Floppy and started fresh. One piece at a time and checked the Floppy Drive with each piece of addition. I think the culprit was a Siig PCI Ultra ATA133 controller card.
[I replaced the card but I can't prove it because I didn't want to reinstall to find out and mess up a good thing.] It was just my senses.
In addition I took another clean formatted drive and loaded XP.
I had the same error. That was my affirmation that some piece of hardware was the cause.
There was definitely a conflict of an address but not an IRQ conflict because I checked each IRQ in the system. Both device mgr and System Info. and Dr.Hardware showed no errors nor conflict. Very strange. The problem disappeared with the removal of an IDE controller.

Well whatever caused it the nightmare is over and I thank everyone. Just so happy I didn't have to RMA a motherboard.

Report •

January 8, 2010 at 03:18:38
Could have been reserved memory as well.

If you have a need to use the controller card again then install it in a different slot and there may be no problem.

Report •

January 8, 2010 at 10:33:57
Thank You OtheHill.

Only 2 PCI slots on a Gigabyte P55A - both taken with
controller cards. I just bought 2 different brand cards, which solved the problem.

No programs loaded other than XP Pro(SP2) and 4 GB memory
which XP can't use. XP (X86) only will allow up to 3.46 GB (the rest is wasted unless one installs (X64) . Of that 3.46, XP will only reserve less than 1 GB for resources. 4 GB is really an overkill unless one is a gamer, or graphic designer or into CAD.

The lesson here I've learned when installing a new system is "never" to install all the Hardware and then load the OS. Only install the basics (vid, sound, and drives) then install the add-ons cards after the OS and drivers run smooth. Was a bitter pill.

Report •

January 8, 2010 at 16:08:51
Why do you need two controller cards, if you don't mind my asking?

Report •

January 10, 2010 at 03:34:06
No I don't mind, OtheHill
I run 8ea. 250 & 300 GB ATA drives (of course 1 of those is a Burner). I wasn't planning on buiding new PC with Sata drives,
but may be forced anyway because I'm running out of storage space. Most likely tomorrow I will pick-up 2ea 1 TB drives to replace 2 ATA's. Their on sale right now for $69.99 ea.

Glad you ask that question which allows to pick your brain a bit further. The P55 has 2ea. SATA 3_6 connectors. They are meant for SATA 6. The other Sata connector are they for Sata_2 only then ??
The manual isn't to clear on that. And I presume I can connect a Sata_3 on the 2 ea. Sata3_6 ??? (I realize they are backward compatible but I am wondering at speed the drives will run on those other 6ea. Sata_2 connectors. (Hope I wasn't too confusing)
Thank you all again.

Report •

January 10, 2010 at 08:16:04
I don't even know if any SATA III drives are available. That said, I wouldn't be concerned about it.

The only warning I can give is this. Some of the high performance SATA II drives MAY not be backward compatible. Most BIOSes do automatically configure the drive correctly and for those that don't there is a throttling jumper on most SATA II drives. Not on the high performance drives though. I don't know what the SATA III drives will do when available.

SATA II drives don't run at 3Gb anyway. Those numbers are burst speeds. Many users end up configuring the BIOS to use the SATA as an IDE so the thruput is 133Mb anyway.

IMO if the SATA III drives are substantially more expensive I wouldn't bite.

When using WinXP you must supply the SATA controller drivers at the start of the installation in order to get the maximum benefit of the faster controllers.

Best method if you don't have a floppy drive is to slipstream the drivers.

One other thing, Intel chipsets like the BIOS settings to be set to RAID even when RAID in not used. You will need to be cautious not to place two drives on the same controller or you may actually set up a RAID array. FYI, SATA controllers generally serve TWO SATA ports. Like 1 & 2 may be on the same controller. That is how the newer SATA III controllers will probably work too. Both are still Masters though. Some boards have SATA ports that don't support bootable devices.

Report •

January 20, 2010 at 00:06:59
CORRECTION on: Floppy Disk format error or I/O error
Sorry I jumped the gun. Thought I had it corrected when "Properties" reported the correct KB for the floppy disc.

SORRY I still have the same error, irregardless what I try to fix with.
As a note for everyone interested.
(1) For a Floppy Disk Controller there are "NO" services associated. Windows has "no" say so other than to offer the DOS commands - format, copy, paste, etc.
(2) There are "NO" components interests (such as other drivers, hardware, etc) with this component that can conflict. The Floppy disc drive is a stand alone product - the same as if you ran memtest86 to check your memory. Both are DOS programs and have no interaction with an OS. The program to run a Floppy Drive is as ancient as the 1st Main Frame computer (late 1969 - 1970) and the program has never been updated nor amended. Back in those days multi-media, multi-programming did "not" exist. Every program stood on it own feet. So the only components that effect a Floppy drive are,
the Floppy Controller located on the motherboard. The driver in windows is the only communication, and the BIOS pretty much ignores how a Floppy drive behaves. The chipset that controls a Floppy is the Southbridge or the Q57 Chipset as Intel calls it.

Floppy Disk are so ancient by design & very complicated but rarely have issues. I have never seen an issue when a PC has only (1) one controller, but the Gigabyte P55A-UD3 has two (controller) rather than only one. (namely on Intel P55 Express Chipset LPC Interface). Maybe I'm only suppose to have One (1). But uninstalling 1 of 2 did not help. So after deeply studying the issue, I can only imagine the Floppy Drive is confused which controller it is talking to OR Both controller are talking to the Drive at the same time. Such is impossible for an ancient 40 year written executing instruction. It is not able to absorb two instructions at same.

Will let you know if I ever fix this issue. !!!
Gigabyte Tech has been no help. The tech is out in left field as far computer knowledge goes. Three weeks of questions and I have never received one(1)single suggestion or advice.
And the answers are atrocious, such as for example: I can't get my car started. Reply: Did you put air in your tires ?

Just Kills me.

Report •

January 20, 2010 at 05:43:05
How is the floppy drive identified in the BIOS screens? As the A drive and a 1.44MB?

What IRQ is assigned to the floppy controller? Anything else using that IRQ?

What drivers are in use for the floppy controller? Look at driver details.

"The chipset that controls a Floppy is the Southbridge or the Q57 Chipset as Intel calls it".

So is an Intel identification in the drivers or just Microsoft?

Report •

January 21, 2010 at 12:17:27
The FD in BIOS is identified as 1.44MB, assigns the drive letter A correctly.
IRQ 6 ; DMA 2 ; I/O 03F0-03F5 and I/O 03F7-03F7
The driver is fdc.sys Microsoft 2001 (it is actually almost an identical copy of the Toshiba fdc.sys driver, It was made by Toshiba and gave Microsoft the rights to use it. Microsoft added the WHQL certification and replaced Toshiba name with "Standard Floppy Disk Controller" - that's what it appears to me. The Driver is as it belongs in Sys..32\drivers
[I tried both - both did not improve anything.]

The Controller is on the mother board, an Intel chipset. "Floppy disk Controller on Intel(R) P55 Express Chipset LPC Interface-3B02" (There is no reference whether this chipset has a driver or not, I would presume it is included within the package of drivers on the CD that came with the board. "THIS IS THE I/O" otherwise there be no OB-Sound, & other devices which require an I/O.)

I'm about to give up. For 4th time I loaded XP on formatted drive. Only Video, CDRom, FloppyDrive, & HD. Had the same identical problems. Was up to 3 AM in the morning.

Nuts: (1) DOS prompt - No problems.
(2) Safe-Mode - No problems
(3) In WinXP - Both Properties, and Tools(Error Checking) of a good Floppy - No problems.
BUT corrupts in Copy & Paste, formats only partial, destroys the file system on the floppy. (A few steps forward are good clicks, then it can't read/write, then a few more good clicks, then it can't read/write. Takes over 10 minutes to format (sometimes it will only format 30% wipes out the rest of the file system, sometimes it wipes out the complete file system.) That is an I/O problem indication
The only device which interacts with a Floppy. The whole key in a nutshell.

The 1st Gigabyte tech knows less than my mother about computers. I think he has a chart and copies and pastes.
Now another Tech will look at the problem. I will post if we find a solution. Thank You.

Report •

January 21, 2010 at 14:18:40
When looking at disk resources are there any conflicts listed there?

I looked at a WinXP rig I have running and all the resources in use are the same as you list.

Those memory addresses must be in use by something else when in Windows standard mode.

If the hardware was defective it wouldn't write in safe mode.

Have you run a memory test on your RAM? Perhaps there are some bad chips somewhere that are only in use when other items are loaded in RAM while in Windows standard mode.

Report •

January 21, 2010 at 21:36:12
Thanks for comparing OtheHill.
Besides the DevManager, msinfo32 is wonderful in giving a comprehensive look of all hardware, incl. software. It reports No Errors [all OK].
Dr.Hardware {a 3rd party program} also shows no errors.
One of the first things I do is to run Memtest86, not single error after 4 runs.
But like you say - a memory address could well be the cause.
I will review the addresses again. Thank You.

Report •

January 27, 2010 at 22:46:49
Problem Finally Cured !!
On Jan 15th, 2010 Gigabyte came out with a new BIOS F5c (released date ?) for the GA-P55A-UD3 motherboard.

After flashing the new BIOS (today 1-27-10) all problems disappeared instantly. I can now not only Format but also copy & paste without corruption in the Window environment.

Report •

January 28, 2010 at 02:33:19
Whew, that was tricky demax. You have done the right thing posting the result, now anyone googling, has a chance of seeing the fix.

Report •

January 28, 2010 at 04:39:52
Thanks for getting back to us with a solution. Although, most users probably won't experience your issues. Newer computer users do not see the value in a floppy drive and don't configure new systems with one. That is unfortunate.

Now to just get YOU to see the value in partitioning. Check out the link below.

Report •

Ask Question