Firewire connection to Epson Printe

January 6, 2009 at 09:08:10
Specs: Windows XP SP3, Athlon 2400+
I have recently installed a new HD and re-installed OS and apps. Before the re-build I was able to print to my Epson R800 via firewire - after the re-build there is no 1394 port available - Epson can't help. If I put back the old HD then all is OK again so it's not a hardware problem. (New HD was installed to get rid of persistent virus and spyware infections)

See More: Firewire connection to Epson Printe

Report •

January 6, 2009 at 09:17:35
You may need to install the drivers for the 1394 port. Those should be available from the motherboard manufacturer.

Look in device Manager and you may find other hardware not working properly either.

If you have a motherboard CD run the setup.exe on it to install all the drivers.

Otherwise download them from the manufacturer's site.

If you don't know the motherboard model then download SIW.exe to find out. Get SIW at the link below.

Report •

January 6, 2009 at 09:28:36
Thanks for that - the firewire port is a generic PCI card and I am not aware of any drivers for it. The card is working OK as I am able to attach an external hard drive and it looks OK in device manager, however under IEEE 1394 and SCSI Printers in the Device Manager I have a yellow ? and a message which says 'This device cannot start (Code 10)

Report •

January 6, 2009 at 10:01:03
Have you tried to reinstall the printer after removing it first?

Not sure of the procedure for a 1394 printer connection. However, when using USB connections you normally at least need to install the printer drivers prior to connecting the printer. If you have an installation CD I suggest you follow the installation prompts provided there.

Sometimes it become necessary to run a registry cleaner to remove remnants of the old install.

Try the registry cleaner module in CCleaner. Google for CCleaner. It is a free download and the cleaner module is one of the best around. I suggest you remove the printer and reboot. Then run both the cleaner and registry modules. If you wish you can backup any changes made to the registry for restoration if needed. I haven't ever had to restore though.

Report •

Related Solutions

January 7, 2009 at 01:17:09
Hi and thanks for that. I have removed the printer driver, run
CCleaner and then tried to reinstall from original CD. The
installation procedure is the same as for USB ie install the
software, turn on the printer when prompted. It searched for
the printer then times out. The Device Manager is as before
ie This device cannot start (Code 10)

Report •

January 7, 2009 at 06:04:06
Have you seen this MSKB? Look at code 10.

Report •

Ask Question