Click here for important information about

failed to query TCP/IP settings of th….erro

Microsoft Windows 7 professional 32-bit
August 31, 2010 at 16:52:42
Specs: Windows xp SP2, P3 - 4GB
Hello Everyone,
I recently reinstalled Windows XP SP 2 as my PC was very sluggish and I don't recall ever doing a reinstall since I bought this PC six years ago! I ran the File and Settings Transfer Wizard prior to my reinstall. The install went smoothly and I transferred my original setting back to my PC after the install. However, since the reinstall I'm unable to connect to the Internet and I'm also having problems connecting my wireless printer. I connect to the Internet through a cable modem. I also have a NETGEAR wireless router which connects my laptop and my Canon Pixma MX860. I can still connect to the Internet with my laptop and can access the web as well as the mail server. I ran the new connection Wizard selecting "connect to the Internet" then "set up my connection manually" then "connect using a broadband connection that is always on". The next screen read "completing the new connection Wizard, your broadband connection should already be configured and ready to use…". However, when I use Internet explorer to try to access the web I get an error message that reads "the page cannot be displayed, the page you are looking for is currently unavailable…". This same error message also recommends checking the option to "automatically detect settings" which I already had checked.

I've also done the following but still cannot connect:

- I right clicked the 1394 network connection and clicked "repair" and got the following error "failed to query TCP/IP settings of the connection".

- I looked at my bios settings to ensure that the integrated NIC card was set to "ON".

- Per a user that was having a similar problem, I renamed my TCPIP.sys files to TCPIP.sys.old and rebooted and retried the new connection but still had the same problem. I did notice that new TCPIP.sys files were created.

- I deleted the 1394 net adapter in the settings under system/device manager and reinstalled it by right clicking "network adapters" and selected "scan for hardware changes".

- I noticed there are all yellow question marks next to "other devices" and all the devices listed under that including ethernet controller, multimedia audio controller, multimedia controller, PCI modem, and video controller.

- Unplugged and then plugged in my cable modem to reset it.

I noticed when I right-clicked Network Connections/1394 communication 3 properties/Internet protocol (TCP/IP) there is a button to "install" as well as "properties" but the "uninstall" button is grayed out, does that mean that TCP/IP is not installed on this PC? When I click "properties" the option to "obtain an IP address automatically" was checked off. Does this mean that TCP/IP is in fact installed on this PC? The Uninstall button being grayed out leads me to believe TCP/IP is not installed on the PC. Does all this have anything to do with why I can't get my wireless printer to connect wirelessly? The only other thing I can try is to reinstall the operating system but I'm trying to avoid that as it takes so long. Regarding the reinstall, I was doing it from an Dell OEM disk which had an option to install other Windows components and IIS was one of those components. I don't recall the exact description however it had something to do with Internet connections and TCP/IP. However, when I tried to install it I was prompted for a second Windows install disk but my PC only came with the one install disk. Is that IIS software something I can download from Microsoft and will that fix my problem?

Thanks in advance for any info you can provide!

Dan G. in CT

See More: failed to query TCP/IP settings of th….erro

September 1, 2010 at 01:55:41
You have to rename every instance of

failed to query TCP/IP settings of the connection

Finally I did a file search for tcpip.sys and renamed every instance to "tcpip.sys_old" - essentially disabling it... Windows XP message came up immediately saying it needed to repair itself but I waited and proceeded to rename all instances of tcpip.sys found and then followed the instruction window and inserted my Windows XP disk and let it have its way with my computer... rebooted and wow! CONNECTION RE-ESTABLISHED all on its own. That is all I did.. no expert believe me, I have no clue why it worked, just used my imagination. ;-)

Report •
Related Solutions

Ask Question