Extra CD/DVD drives icons and not responding

Amd sympron / Not sure.
June 29, 2009 at 19:07:58
Specs: Windows XP, 1.80GHz 512MB Ram
I recently restarted my computer and for some reason I now have 4 CD drive icons in my computer. There is saposed to be just 1 CD Drive and 1 DVD Drive.

Now when I try to put disks into my drives nothing happends. And when I try to burn disks the program can't find any drives to use.

I'm not sure what could could be causeing this. I haven't done anything to the computer on either physically or in software. All I can guess is that I somehow picked up some spyware or virus that has screwed it up.

Any idea's how to fix this?

See More: Extra CD/DVD drives icons and not responding

Report •

June 29, 2009 at 19:10:46
Go into Device manager and remove ALL the optical drives and reboot.

Report •

June 29, 2009 at 20:06:45
Tried that. Didn't work. I uninstalled the drives in device manager. When I restarted it reinstalled the drive automatically, but when I opened My Computer it still showed 4 CD Drives and I still nothing happened when I put a disk into either drive.

Report •

June 29, 2009 at 20:08:18
I even tried using restore point, but there was no restore point available to use. I know I made a restore point recently. So whatever did this also seems to delete any restore point info you might have.

Report •

Related Solutions

June 29, 2009 at 21:51:30
see what you are showing in disc management

my computer > manage > disc management

Report •

June 29, 2009 at 22:06:21
Do you mean in Computer Manager window under: Computer Management (Local)\System Tools\Storage\Removable Storage\Disk Management ?

when I click on Disk Managment it is blank in the feilds to the right.

Report •

July 20, 2009 at 16:32:49
Has this issue been fixed yet?

I have the same problem, except I have 1 extra drive (Drive E). My restore points are all gone except for the last 2 days. I know I had several for this year, an average of 1 every 4 days. I also can't open my CD/DVD ROM drive (Drive D) by right-clicking on its icon in My Computer and choosing Eject, but it will open when I press the eject button on the drive.

BTW, when I go to Disk Management, I don't see any disks or volumes. There's nothing in either pane, top or bottom.

Report •

July 20, 2009 at 18:37:52
Both of you should scan for viruses or other nasties.

Report •

July 21, 2009 at 14:43:27
Thanks for your reply, OtheHill.

I think I know what my issue is, sort of. I saw this on another forum, but it's similar to Response Number 4 above:

"On your desktop, right-click My Computer and choose Manage.

Double-click Disk Management.

Maximize the page.

In the menu bar at the top, (left click "Disk Management" then) choose the Action tab and then click Rescan.

Now, in the lower-right pane, you'll see the hard disks and the cd/dvd drives that the computer sees. One HDD will be marked "system." That's your windows drive."

My problem is, I don't see any disks or volumes listed when I do this. Nothing happens when I select "Refresh", and when I select "Rescan Disks" a dialog box titled "Rescanning Disks" flashes for about 1 second, with the words "Disk rescan in progress, please wait..." in it. Nothing happens.

So far, my only problems (as far as I know) are as follows:

1 - I have an extra drive (Drive E:) in My Computer.
2 - I can't right-click my 'normal' CD/DVD drive (Drive D:) to eject a disk. But I can do it when a disk is already inside. Otherwise, I have to physically press the eject button on the CD/DVD drive to open it.
3 - System Restore doesn't work. That is, no SR dates are found except for July 20 and 21, but the PC won't let me restore either one (my system simply does nothing when I press the Next button at the Confirm Restore Point Selection page), nor will the PC let me add a restore point ("System Restore is not able to create a retore point.
Please restart the computer, and then run System Restore again.").

I'm lucky that I can do anything, but does it look like my Master Boot Record (MBR) is screwed up? It was suggested as a possible answer to another poor soul here:


If mentioning other forums is a problem, I'll remove the link.

I also followed all 5 suggestions listed here:
Troubleshooting steps for issues when you try to use the System Restore tool in Windows XP

My mouth dropped when I tried Method 4 and saw I had no more "sr" or "srservice" events, even though every method indicates System Restore is still working for drive C.

I'm grateful that I have an external drive (300GB) and did a full backup of my C: drive in December 2008. Last night, I moved all my personal files to the external drive.

Weird thing is, I just did full AdAware, Avast, and MS Malicious Software Removal Tool scans 2 days ago, right before I noticed the extra drive. Soon after, when it occurred to me to do a System Restore, that's when I found my SR function was gone, save the 2 dates I can't restore.

I just got home from work, so I'll run a few more tests (HijackThis, CCleaner and those listed above). Until then, any suggestions?

Report •

July 21, 2009 at 15:01:21
All the signs of a virtual cd program.

This is a program that allows to copy a cd to your hard drive and mount it as if it were playing in the cdrom. I use clonecd for playing games for example. Runs much faster from the hd than the cd.

Have you installed any new software lately?

Report •

July 21, 2009 at 18:54:53
Ummm, yeah. A cracked version of a software program (Atomic Alarm Clock).

I know, I know, but I got it from an otherwise reliable source. And I immediately deleted it and ran the scans listed above with no alarms going off. I'm not even sure it was the problem, I just noticed the problem a few hours after the download/uninstall/scanning. I even checked the site I got it from and no one else reported any problems with it, so the jury's still out.

As for the Virtual CD idea, I'm not sure. I've never used it before, but I can't save any files to that drive. In fact, when I insert a CD into my 'normal' drive (Drive D:), the CD label (ie "progrockmusic") appears on Drive E, but of course I can't access the files. It looks like my PC doesn't acknowledge Drive C (the main disk) for System Restore, and Drive E is mirroring Drive D.

I've dealt with problems before and never encountered anything like this. I'm sure I could clear up the System Restore issue if I cleared up the extra drive problem first.

Report •

July 22, 2009 at 21:52:41

No, I didn't think my way out of it. I forgot I did a full system backup to my external hard drive in Dec 2008. I have to update some software, but otherwise the system looks familiar. Thanks for your help anyway.

Report •

Ask Question