External hard drive not being recognized

Wd Western digital 120gb wd1200bb ata-10...
July 29, 2009 at 10:52:32
Specs: Windows XP
Hi there...

I have a Western Digital (WD1200BB) external hard drive that I have been using with my PC for quite a while, and recently Windows (XP) stopped recognizing it. In My Computer, it is now showing up as Local Disk J under Hard Disk Drives, it used to be shown as WD1200 under Devices with Removable Storage. It shows up under Safely Remove Hardware as a USB Mass Storage Device, but it used to show up there as WD1200 as well...

I tried it on my laptop, where it has worked before, and had the same problem. Tried using my thumb drive on the same USB port, and it worked fine...

I checked on all the drivers, and they all seem to be fine, Western Digital won't even let me download a driver to Windows XP.

Everything seems to be fine when I check in Device Manager, except that the Volumes tab has no information. Under Disk Management, it shows up as drive J (a "basic"... why not removable?). Also, it shows File System as being "FAT32" instead of NTFS, but when I go to format it, NTFS is the only option. I am hesitant to go thru with the format option because I get a warning that "formatting will erase all data on this volume"...

What else can I do?

See More: External hard drive not being recognized

Report •

July 29, 2009 at 14:20:00
How old is the drive?

They are not permanent and you can only write to Flash Drives so many times before they quit working. If it is a new drive then you may want to return it to the store you got it from. Just an FYI, flash drives can not use NTFS yet. They are working on it so if you are trying to format it use FAT32.

Report •

July 29, 2009 at 14:26:17
The drive he is talking about is not a flash drive, it's a regular hard drive.

The reason Windows only shows the NTFS option is because on a drive that large, you get lots of wasted space if you used a FAT32 partition. You can use third party partitioning software if you really want to reformat it with a FAT partition. However, it sounds like the drive has given up the ghost.

Report •

July 29, 2009 at 14:44:46
Also, it could be a mapping problem. Did you try going into the Computer Management and setting a different drive letter to the drive?

- Right Click My Computer
- Select Manage
- Click on Disk Management
- Right Click the Drive and Select Change Drive letter/Path

One last trick is to remove the USB hub for the drive and let the computer redetect it as new hardware.

- Go to Control Panel
- Select System
- Got to Hardware Tab on top.
- Select Device Manager.
- Expand the USB Controllers tree.
- Right Click and Remove the USB Root Hub

I do not recommend this because the roothubs do not identify which device they go to and if you do not have all of your drivers handy you may remove a printer or some device that requires the driver cd to reinstall. You may be able to look at the properties of each root hub until you find the one with the driver for your you drive or it may be simply called USB Mass Storage Device.

Report •

Related Solutions

July 30, 2009 at 09:44:39
Thanks for the advice. Sorry it took me so long to reply, I have a ridiculously busy schedule at the moment.

Professional Dick (hahaha, btw) -
I want to change it to a NTFS partition to see if that fixes the problem, but I am afraid that I'll lose all my data if I try... will I? Is it worth trying, or should I give up and go to a data recovery program?

ace omega -
I have changed the drive letter, several times, it doesn't change anything except... well, the drive letter. I still can't access anything in the external. I also tried your suggestion of deleting the USB root hub (actually, I just disabled and then re-enabled it, since there was no "remove" option). Thought this would work for a second, but then it just detected it exactly as it had been before. That made me very sad.

Again, thanks for the help, I really appreciate it as I do NOT want to lose all my data. Are there any other suggestions?

Report •

July 30, 2009 at 10:07:20
A new perspective...

I downloaded a "Data Lifeguard Diagnostic" program for the external from Western Digital, and it failed before it even started checking the drive. It gave a test error code 11 which reads "Cable Test::Read diagnostics sector error!"

What the hell does this mean? The USB cable has to be good, because the drive still shows up, it's just that I can't access it and it's not in the right place...

Report •

July 30, 2009 at 10:52:07
1. How come you have not answered ace_omega question (asked in post 1) How old is the drive??

2. The HDD in question is Western Digital Caviar WD1200BB 120 GB ATA-100 Hard Drive. What kind of external USB enclosure are you using?

3. You wrote ... It gave a test error code 11 which reads "Cable Test::Read diagnostics sector error!" What the hell does this mean? Have you looked up the diagnostic utility user manual at the link below for the error code?



Report •

July 31, 2009 at 10:11:15
XpUser -

I did not answer ace omega because his question was referring to a flash drive, not an external. The answer is, it's fairly old, probably 4 or 5 years, but I don't think that it failed, because the data is still on there according to volume used/available, I just can't access it.

I am using the original enclosure from WD, it looks exactly like the picture that comes up on their website.

Thanks for the link to the user manual, I had not found that. All it says is "Unkown Test Status", though...

Report •

Ask Question