Disk error - press any key

November 27, 2009 at 05:46:51
Specs: Windows XP Home SP-2
Windows XP Home SP-2
3072M Memory
1.80 gigahertz AMD Athlon 64

First start in the morning, XP won't boot. Disk Error - press any key...

If I persist by hitting the reset button often enough it will eventually boot. As far as I can tell, using the Seagate/Maxtor diagnostics, the disc is in good shape. The BIOS tells me:

IDE prim master - ZIP (H:)
IDE prim slave - none
IDE sec master - DVD-2 (G:)
IDE sec slave - none
IDE third master - Maxtor 6V250 0F0 (C:)
IDE fourth master - none
IDE fifth master - WDC WD2500KS-00MJ (D:)
IDE sixth master - DVD1 (F:)
Floppy (A:)

3rd to 6th are SATA, not IDE.
However the one called fifth master is a PATA (IDE) device (!!)

There's no dual boot and both hard drives are NTFS all one partition.

It all worked up until I installed a large batch of XP updates. Rebooting after that it failed and has taken a lot of work to get it to boot since then.

Any ideas?



See More: Disk error - press any key

Report •

November 27, 2009 at 06:07:08
If "the one called fifth master is a PATA (IDE) device", then how is it SATA ? You could try running the recovery console if you have an XP CD-then do fixmbr and fixboot.

Report •

November 27, 2009 at 08:57:00
There are only two PATA controllers, therefore I was puzzled as to why D: was listed as fifth master amongst the SATA drives.

I have run the recovery console, but end up at the command prompt in C:\Windows with no instructions as to what to do next. Only > DIR and >EXIT seem to be recognised there.

Seatools for Windows passes both drives on all the tests.

I didn't mention that yesterday, after I finally got it to boot, I reinstalled the system from an Acronis image, but this made no difference as it failed again first thing this morning with

Disk error - press any key
Boot from CD
Boot from CD
Disk error - press any key



Report •

November 27, 2009 at 09:08:41
Try re-seating or replacing the data cable.

If, in fact, the drive is a SATA type, then check that there are no sharp folds in the data cable.

Report •

Related Solutions

November 28, 2009 at 02:22:55

The stupid computer was trying to boot from the ZIP disc which is at the top of the queue in the BIOS. It seems that I have some re-jumpering to do.

Although it always worked before the MS update, I can only assume that one of the upgrades altered something in the system regarding boot priorities. The same upgrades were applied to another XP Home computer, but it didn't suffer from this problem - but then it doesn't have a ZIP-disc and it doesn't have mixed PATA and SATA drives.

Thanks for your response.



Report •

Ask Question