dell latitude D820 won't boot up, lights stay on for 3 sec,

March 1, 2014 at 17:23:46
Specs: Windows XP
DELL LATITUDE D820 won't boot, lights, no sound or display. Battery charged, adaptor plugged in, but when power button is pushed, power light, and other startup lights come on , after about 3 seconds they all go out. No sound, no screen display at all. Not sure how it was shut down last time used, it is not mine. tried replacing cmos battery, no change. took out and replaced memory card, still no change. any suggestions

See More: dell latitude D820 wont boot up, lights stay on for 3 sec,

Report •


#1
March 1, 2014 at 18:54:46
When's the last time you blew the dust out of the cooling vents?

Report •

#2
March 1, 2014 at 20:25:37
I checked the vents and they are clear

Report •

#3
March 2, 2014 at 05:19:05
https://www.google.com/#q=dell+lati...

take out the battery and try an external monitor

larry


Report •

Related Solutions

#4
March 2, 2014 at 06:34:24
"I checked the vents and they are clear"

Does that mean you simply looked at them or that you blasted them out with compressed air?


Report •

#5
March 2, 2014 at 14:49:56
Probably won't help but quick to try:
Disconnect from domestic power, remove laptop battery, then hold the power button in for 20 seconds. See if it is any better when assembled and re-tried.

If you never see anything at all on the display it is almost definitely a hardware fault (the above resets the mobo)..

Always pop back and let us know the outcome - thanks


Report •

Ask Question