Solved Deleting/fixing boot sector on XP

Lenovo Thinkpad x31 notebook computer
April 26, 2012 at 09:43:55
Specs: Windows XP, Pentium M 1.7ghz
I had a version of Linux installed on a different partition of my hard drive, which I later deleted (both Linux and the partition), but was left with the Grub loader on my boot sector.

To get rid of this I tried choosing the Repair option on the XP recovery console (booted from a USB drive as I don't have a CD-ROM on my notepad) then using the commands FIXMBR, FIXBOOT and BOOTCFG /rebuild. However, none of these made any difference.

I read that it's possible to use the FDISK /mbr command from a WIN 98 start up disk to solve my problem, so I got hold of one of these, put it onto a bootable USB drive, set my bios to boot from USB, but from the command prompt I just got the USB drive as C: rather than my notepad's hard drive, so I can't use this FDISK method either to renew my boot sector.

Does anyone know how I can fix this?

PS. Windows works fine btw, just that I have to choose it from the Grub loader every time the laptop starts, and I just want the normal Windows boot loader back.

See More: Deleting/fixing boot sector on XP

Report •

April 26, 2012 at 12:37:11
When you were in your recovery console was your windows mounted under the D:?

Anyway try

FIXBOOT C: if it is C:

or what ever drive letter it was mounted on.

You may also want to check your boot.ini file to make sure that is correct.

Report •

April 26, 2012 at 12:48:35
Thanks for the reply, but Windows was mounted on C: in the recovery console and neither fixboot or fixmbr had any effect :/.

Report •

April 26, 2012 at 12:57:58
✔ Best Answer
If it is a netbook, go into your BIOS and turn off any quick boot or turbo functions or boot protection, and try again. Also while you are in your BIOS, check the SATA mode, try this in AHCI and compatible.

As for repairing the MBR you are doing the proper procedure, so something else is wrong.

Don't think you need the BOOTGFG command though. Just FIXMBR then FIXBOOT In that order.

Report •

Related Solutions

April 26, 2012 at 18:11:13
Hi, I don't have any of those functions available in my BIOS, but I reverted back to the default settings, tried the fixmbr, fixboot commands again via the recovery console, but unfortunately with no change.

I read somewhere that Thinkpads have a special boot record or something, so perhaps this could be the problem?

Report •

April 26, 2012 at 19:22:55
There is a special boot loader, when you hit that purple button, it launches a different utilities partition. I'm not sure if there is repair tool for that. Is there anything in the BIOS about the think recovery?

Report •

April 27, 2012 at 21:30:23
Nope, there's nothing like that in the BIOS.

Report •

April 28, 2012 at 08:29:20
I've finally managed to fix it :). I booted from a Linux (Puppy distro) live disk on a USB drive, exited to the command prompt, then just entered this line of code (found on a Linux forum):

ms-sys --mbr --write /dev/sda

It said something like "your Windows MBR is now restored" and when I rebooted Grub was gone and it was back to the original Windows bootloader.

Hope this might be of use to someone else who has a similar problem.

Cheers for the help.

Report •

Ask Question