Cursor stops registering

February 27, 2009 at 14:46:12
Specs: Windows XP Pro SP3
When I start Windows, I can click on anything on my desktop and
open it, but once I double click any icon, I can't click anything else
unless I open up task manager (or Process Explorer in my case). I
can't click anything on the taskbar like the Start button or quick
launch icons, even before I open a desktop item, but everything
works fine after I open task manager. When I hover over an icon on
the quick launch or taskbar, it doesn't even highlight the object like it
normally does.
This started when I went to use my PC, touched my mouse, and
shocked it. I blew one of the USB ports on the motherboard and the
back button on my mouse and randomly I get a balloon from the
system tray saying a USB device is unrecognized.
I've seen another post about this from 2007, but no proper answer
(and the guy didn't shock his mouse).
Any insight into what the problem might be would be appreciated.

See More: Cursor stops registering

Report •

February 27, 2009 at 15:18:53
Have you tried to disable the corrupt USB port in the system BIOS?

Please send a reply, if you solved the problem !!!

Report •

February 27, 2009 at 19:42:30
"...touched my mouse, and
shocked it."

If you mean you subjected it to a static electricity discharge, whatever damage that did is NOT fixable.

Your mouse is probably damaged - try it in on another computer - if it doesn't work on another computer it IS damaged. If it's a corded USB mouse, wires inside the cord could be broken as well.

Try another USB mouse, in all your USB ports.

If that doesn't help, you may have to disable all the USB controllers in your bios Setup and use a PCI USB 2.0 controller card instead if this is a desktop, or if this is a laptop, use a PCMCIA (PC CARD) USB 2.0 controller card or an ExpressCard USB 2.0 controller card, but, if this is a desktop, you may lose the ability to wake up the computer by moving a USB mouse and a USB keyboard may not work in the bios Setup.

If that doesn't help, you will have to replace the mboard if you want to use USB.

Report •

Related Solutions

Ask Question