Copy of Files in Folder invisible to explorer

September 11, 2010 at 20:53:32
Specs: Windows XP SP2 32 bit, Core2Duo /4gig
a backup folder copied to an external hard drive, under properties shows 400 files and 2.5gig data, Explorer and command prompt (DIR) show no files present. If copied the files are shown while being copied and all have a $ sign in front of them. What's going on? Can this issue be solved?

See More: Copy of Files in Folder invisible to explorer

Report •

September 11, 2010 at 22:33:40
As with [DIR}, Explorer has to be instructed to show all files.

DIR /? or, alternatively, DIR /help will show all the switches available to that command -- which include options which are not set as default.

However, the $ sign is of some concern -- (although you did not exactly state that the files being copied did NOT have the $ sign, but that the file names being copied TO did -- that was not made clear from your post). What were the properties of the individual files in the original location (Hidden? System? Original location is Fat32? NTFS? -- that too was not specified in your post), and details regarding the nature (format -- FAT32 or NTFS--, hard-drive, flash drive, format, etc.) of this external drive were omitted, even though one might expect this could be relevant.

Are you Administrator? User? Guest? Is this local or a network? Did you copy the files from the folder, or the folder itself? Can you describe a 'typical' file-naming concept used on these files?

Okay, I'll stop with the questions for now... but you get the picture? Information!

Perhaps the easiest would be to boot up to a Live Linux CD.

Report •

September 12, 2010 at 00:11:08
many thanks for your prompt reply

the exact sequence of events is as follows:

I have been a computer tech for more years than I care to remember.
A client brought a Dell XPS 1330 which would only boot to the cursor after the Vista (Home Premium) logon screen then hung. He has important files which were not backed up. surprise. It would not boot in safe mode or last known good config
I used recovery console to CHKDSK, which found errors in the index files and 'fixed' therm.
still hung
ran recovery console and FIXBOOT, the FIXMBR
still hung
Spinrite reported errors including bad sectors and 'recovered' them.
successful boot.
I located his files and using explorer drag and dropped them into a single folder on an attached USB external drive. Checked that the copied folder had the same number and size of files on the external drive as the original still on the XPS. I did not check individual files - there were hundreds of them. perhaps I should, but I didn't.

Dismantled the XPS, sorted out its issues reloaded Vista onto a new drive and copied the folder containing the recovered files back onto the XPS. During the copying process using Explorer copy I noticed that the files being copied all had a $ sign in front of them. Explorer of course in the copying process only shows the name of the file being copied. If it is to an empty directory it is safe to assume that the name will be the same as the source.
Double click on the copied directory and Explorer states the folder is empty.
CLick on explore and same result
Click on properties and it reports 400 files and 2.5 gig
Command prompt when in the dodgy folder on DIR reports no files
ATTRIB same deal
booted to a linux CD, showed all other files, but that folder returns on the 'ls' command - no file found.

So to deal with your questions in order:
I cannot access the original files so their attributes are unknown
original external and and final destination are all NTFS
logged on as administrator in all cases
all operations were performed locally
I selected the files from the original drive and copied them to a single folder on the external drive. Then copied the folder back to the XPS. both the folder on the external drive and the XPS have the same problem
I plugged the external drive into two other machines, one Win7, other WinXP, same result.
Only clue I have is that windows seems to create a placeholder when a file is in use withe a $ sign in front of it followed by the file name. Clearly these missing files are not in use as explorer cannot find them.

Any help will be greatly appreciated.

Report •

September 12, 2010 at 02:16:54
Only clue I have is that windows seems to create a placeholder when a file is in use withe a $ sign in front of it followed by the file name. Clearly these missing files are not in use as explorer cannot find them

These files are fragmented. Files with a dollar sign prefix ($) are usually hidden from the Windows API (Application Programming Interface) which explain why Windows Explorer don't show them ... unless you have enabled Show Hidden Files in the Folder View option.

You will have to re-copy these files again from the original source.


Report •

Related Solutions

September 12, 2010 at 04:14:41
thanks for that - unhappily the drive from which the files were recovered has irrecoverable errors and the files could only be recovered by bit mapping in a clean room - this is not feasible in the circunstances.

Report •

Ask Question