connected, not visible, ad-hoc xp

January 7, 2009 at 04:07:43
Specs: Windows XP, 3200amd athalon64 512mb ram
Hello, searched around a couple hours so i hopefully this isn't the most common issue..

summary i've setup a WEP secured ad-hoc network between two laptops. they both are showing connected status to the wireless network. i have folders on both machines which are set to 'shared' status, however neither machine is showing the other machine in 'my network places'

i have unique ips for each, and can ping the other machine from here.

machine a:


machine b:


both have a subnet mask of

machine a connects using
Broadcom 802.11b/g WLAN

machine b connects using
linksys instant wireless network pc card v3

machine b IS
dell inspiron 1100 w 2.4gig processor 256mb ram running on XP home v2002

both machines have sp2

i did get machine b to show up in the workgroup on machine a but only for a minute and when i clicked on it it gave an error related to permissions.

thanks in advance for your time

file sharing is turned on in the wireless network properties spot.

See More: connected, not visible, ad-hoc xp

Report •

January 7, 2009 at 06:07:06
It sounds like you did everything right but there is one more thing to check and that's the Windows Firewall settings. Disable the firewalls for testing and set the exceptions later.

Report •

January 7, 2009 at 09:27:58
Your IP Addressing is wrong:

Report •

January 7, 2009 at 09:40:17
There is nothing wrong with the ip addressing. Don't confuse using auto ip as in 169.254.x.x as a requirement for ad-hoc wireless. It isn't.

Report •

Related Solutions

January 7, 2009 at 18:51:55
the exceptions ar set, i'll try with the firewalls all the way off.

Report •

January 7, 2009 at 18:56:00
On click start, run, type \\ and press enter. All the shares should appear. If not try \\\c$

Do the same on the other machine.

Report •

January 9, 2009 at 07:11:53
excellent help.

i deleted the whole network (settings) and made a new one, first without encryption and without any firewall. file sharing worked (did set the ips to, and ...3)

two things

as soon as i turn windows firewall back on the permissions error returned. they are both set to the exception for fileandprint sharing.

the checkbox for 'share this internet connection' is checked but that connection is not available to machine b regardless of firewall on or off. when i select that box for the ad-hoc it becomes unselected for the internet connection as seen on the network connections. and vise versa.

Report •

January 9, 2009 at 16:47:45
Go back to the exceptions in Windows Firewall, click add port.
Port 654

Report •

January 9, 2009 at 19:14:18
can't see the other at all now..

still no internet connection.

Report •

January 10, 2009 at 03:25:44
I don't know why adding that port would make the connection worse. What if you add remote desktop to the exceptions?

Report •

Ask Question