cd rom not listed in device manager

March 7, 2009 at 17:11:59
Specs: Microsoft Windows XP Home Edition, 2.6 GHz / 511 MB
i recently bought a new dvd burner and hooked it up, now both my burner and original cd rom drive (that i left hooked up) are not working. I went to the device manager and the dvd-rom/cd-rom tab is not listed. i have power to both drives. i tried switching the IDE cable, but still inop. ive read a few threads and saw to delete data out of the registry, but i do not see a upper and lower filter, is that the exact name in regedit? Please help!!

See More: cd rom not listed in device manager

Report •

March 7, 2009 at 17:26:55
You probably don't have the drives cabled or jumpered correctly.

Watch the POST screens at start up. If the drives aren't properly identified there then you have something wrong as mentioned or the Controller may not be enabled in the BIOS.

Messing around removing filters is not in order at this time.

Report •

March 8, 2009 at 17:08:40
I forgot to mention when I first hooked them up, i accidentaly put them both on master. Now with them hooked up correctly they still dont work. I hooked up another known working drive and still inop. Could having them both on master have messed something up internally in the computer??

Report •

March 8, 2009 at 17:45:23
It is doubtful jumpering wrong damaged anything. You may have loosened something while in the case. I do hope you had the computer unplugged when working inside the case.

Check in Device manager to see if anything is listed there for optical drives (CD). If so, remove all the entries and then reboot. You could have damaged the cable. They are kind of fragile. Are you using an 80 wire 40 pin cable? They have a colored MBoard end. Normally blue, with grey in the center and black on the end. Did you connect the cable to the same port as before?

Report •

Related Solutions

March 9, 2009 at 15:34:53
yes i did have the computer unplugged while in the case. I have looked for loose cables but do not see anything. I am using a 40 pin connector, which i tried switching with another one and it only goes in one way, so i know its hooked up right. In the device manager, there is nothing that has CD/DVD rom or optical drives. The only thing in there is for disk drive, which I uninstalled and rebooted just to see if it work, but it didnt either.

Report •

March 9, 2009 at 16:20:51
Are both the optical drive connected to the same cable? Is that cable still connected to the same port as it originally was?

Report •

March 9, 2009 at 16:51:42
All desktop IDE data cable connectors have 40, or 39 (one position may be blocked) pin holes, but the cable can have 40 or 80 wires - it it has 80 wires there are up to and inc. 40 more connections to wires in the middle of the the back of the connector.

All modern IDE headers have 39 pins.

The blue connector on one end of an 80 wire data cable must go to the mboard or the controller card header.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

Report •

March 10, 2009 at 14:20:45
I'm assuming, of couse, that the connection the CD drive is connected to is enabled in your bios Setup settings. If it isn't the bios can't see it, and the operating system can't see it.
E.g.set to Auto detection, by the method Auto.
However, it should still pass those tests that don't require a working data cable connection

Report •

March 10, 2009 at 21:31:15
yes both drives are hooked to the same cable and plugged into the same port that it orginally was. the IDE cable is a 40 wire cable. and the bios setting is on auto. and as mentioned before i have tried another IDE cable.

Report •

March 11, 2009 at 06:17:31
Are the drives properly identified in the POST screens at start up?

Report •

March 12, 2009 at 14:07:23
on start up, the primary master is my hard drive and then all the others are blank and set to auto

Report •

March 12, 2009 at 14:38:49
The POST screens will not show that type of information. I asked if the drive models are displayed on the screens at startup? That is the POST.

If you don't SEE any POST screens they may be concealed by a logo screen. If so, boot into the BIOS screens and disable fast start, if that option exists and disable all logo screens. The POST screens should then show.

The clarify something, the POST screens show BEFORE the Windows XP screen appears.

Report •

March 12, 2009 at 15:30:07
ok i disabled the quick start and i dont see any drives identified.

Report •

March 12, 2009 at 15:54:50
Then you have something cabled or jumpered wrong. Or the IDE controller may be disabled. If you can't discover what is wrong then try connecting only one drive at a time to the cable. Check the POST screens then and if a drive shows then try switching the cable to the other and try. That will determine that both drives are operable.

If that works you must be placing the jumper on the back of the drive in the wrong location. Look at the link below.

Report •

March 12, 2009 at 16:08:45
"the IDE cable is a 40 wire cable"

As I have already pointed out, all desktop IDE connectors have 40 or 39 pin holes, but the cable can have 40 or 80 wires.

If it has a blue connector on one end, it's an 80 wire cable!

You should NOT use a 40 wire cable if your DVD drive is a DVD combo drive capable of DVD-R and DVD+R 16X or greater, because it requires an 80 wire cable because it is capable of UMDA 66 burst speeds. The drives would still be recognized, but such a DVD drive would be unable to run any faster than UDMA 33 burst speeds when connected to a 40 wire cable - your burning software may not recognize it properly, and it certainly won't be able to burn at the drive's faster speeds without producing a lot of data errors.
A 40 wire cable is fine for all older slower optical drives - if the CDrom is by itself on a data cable, it will work fine.

If there's nothing wrong with the IDE cable, the bios settings, you have had the computer unplugged at all times when you were fiddling with the drive's connections, and you have the power connectors connected to the optical drives, the most likely thing is you STILL don't have the jumpers on them right, OR the new DVD drive is defective (if one is defective sometimes both drives on the same data cable are not recognized).
Different models or different makes don't necessarly have the jumpers in the same positions - check that again - or set them both to cable select. On optical drives there are often letters above the pin positions but they may be inscribed into black plastic and hard to make out unless you use good lighting. e.g. MA, SL (slave) , CS (cable select, that's not slave)

If that doesn't help, connect one drive at a time, as master, or as cable select on the end connector opposite the blue connector end (the blue connector must plug into the mboard) or on the end connector if it IS a 40 wire cable.

If you really do have a 40 wire cable (it doesn't have a blue connector on end end unless all of them are blue) it doesn't matter which end connector plugs into the mboard, but one end is farther from the middle connector and that's the one that should go to the mboard if the drives are fairly close together.


"I've read a few threads and saw to delete data out of the registry, but i do not see a upper and lower filter, ..."

In that case you DO see the drive in Device Manager, but it's flagged as not working properly - a yellow ? or a red circle with an black X in it.

Report •

Ask Question