Can't update windows 2000

Microsoft Windows 2000 professional
November 27, 2009 at 14:46:29
Specs: WIndows 2000, Athlon2000
I have an old PC which has been running windows 2000 quite happily for the past 6 years. As it is going to be moved into a test bed roll I decided to give it a fresh install, so I formated the disk and re-installed Win2000 with the PC's recovery disk. I had to download and install network drivers, as the windows did not setup the network card driver. Once installed I connected to Windows updates and ran the update, but it fails with the very first update (which is updating the update mechanism) with the following error 0X800703E3.

After a bit of googling I downloaded SP4 (recovery disk was upto sp3) and installed that which went ok but when I try and run the updates it fails in the error.

Thinking there maybe a problem with the recovery disk I then tried reinstalling with a proper windows 2000 install CD (includes sp2). I installed the network drivers again, but when it goes to the update page it tells me it needs to be SP3 or greater so I download SP4 (froma MS download page) and install it but get the same error.

Further googling seem to suggest that the error is a bit of a generic error message.

Anybody got an suggestions??


See More: Cant update windows 2000

Report •

November 27, 2009 at 15:26:09
This is the XP Forum. The link to 2000 is on the right of this page.

Home Page

Report •

November 27, 2009 at 16:18:16
Try the following:

1. click Start / Run and type in CMD, then click ok.
2. on the command prompt type
regsrv32 MSXML3.dll /s
net stop wuauserv
cd /d %windir%\SoftwareDistribution
rd /s /q DataStore
net start wuauserv

Now try to update your Windows 2000 again.

Report •

November 28, 2009 at 09:37:46
Thanks for the suggestion paulsep, unfortunately when I tried it came back telling me that regsrv32 was not an internal command. I have since found further information which allowed me to get a bit further in the updating, I had to install;


One is an rollup to service pack 4 and the other is a security update.

Unfortunately, while it got past that phase of updates and downloaded the new update mechcanism, it complains that there is now an error with the web page and it does not display the updates.

I have set the auto update to run so I am hoping that it will download some updates which may let me move on a bit further. In the mean time I am off to hunt down IE 5.5


Report •

Related Solutions

November 28, 2009 at 10:06:00
Oh sorry there was a mistype in that line.
This line:
regsrv32 MSXML3.dll /s

must be
regsvr32 MSXML3.dll /s

All the other lines are ok.

Report •

November 28, 2009 at 12:06:32

Cheer paul, I must say It took me several minutes to see what had changed!!

But I think I may have cracked it, downloaded and installed IE5.5 allowed me to get the update page working (setting updates to auto and downloading 78 updates failed to get the page working). Just installed IE6 as an updates and going back to download more as I speak.


Report •

November 28, 2009 at 12:58:17
That sounds great.
I'm glad that it helped!

Report •

Ask Question