can't read, write, or format USB flash drive

July 5, 2011 at 14:24:45
Specs: Windows XP Professional, Pentium 4 2.8ghz 0.5G RAM
I have a Toshiba laptop running Windows XP Professional. My flash drive is a standard 2GB generic one. When I plug it into any of the USB ports on my computer, it becomes a 'Generic USB Flash Disk USB Device' (shown in My Computer as Removable Disk). I can't open it, nor can I write files to it, nor can I even format it. This problem has occurred on several other computers in my house.

Now I am a bit confused. I tried searching the web, but I couldn't get any information. None of the methods I tried, including changing the drive letter, removing the other drives (where there were any), and reinstalling the driver countless times, but it still persists. Could anyone give me some idea on how to install the flash drive properly? This has never occurred with the other flash drives I have.

See More: cant read, write, or format USB flash drive

July 5, 2011 at 18:02:02
If it doesn't work on any computer then do you think the cheap thing could be defective and it time to throw away and buy a new one for like $4?

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.

Report •

July 5, 2011 at 22:50:05

Report •
Related Solutions

Ask Question