Can't delete a folder EXPERTS ONLY

March 12, 2009 at 11:02:46
Specs: WIn XP SP2, 2 Go
Judging by the title it may seem very easy to solve for some of you but please read:

Don't ask me why but i now have 2 folders on my EXTERNAL hard drive that i just can't remove.

The 2 folders are:

Each of them contain another folder named "update".

I always get an "access denied" message when trying to enter the "update" folder.

I tried:

- Safe Mode
- killbox
- Unlocker
- Delete FXP files

And there are no virus, or malwares of any kind on my computer.

I also could not rename any of the folders.

The name of the folders could suggest a "residue" left by a windows update but even with that, the methods above should have been succesful in removing the folder.

I have administrative rights and i am the only one on the computer. Anyway, since it's an EXTERNAL drive, i also tried to hook it on another computer with the same results

As you can see, I'm out of options here.

See More: Cant delete a folder EXPERTS ONLY

Report •

March 12, 2009 at 11:10:03
You might try running chkdsk on the drive. I've had a similar problem (but with files) on a corrupt external drive.

As a last resort, you could always move your important files off the drive, format it, and then copy your important files back.

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

March 12, 2009 at 11:13:04
Did that external drive come with pre-installed backup software?

Report •

March 12, 2009 at 11:16:28
Have you taken ownership of the folders?

Do so and you should be able to delete them

Report •

Related Solutions

March 12, 2009 at 11:29:16
How to take ownership of a file or folder in Windows XP

Report •

March 12, 2009 at 12:00:34
That was fast.

Ok, here's what i did.

To get access to the security tab, i turned off simple file sharing.

Then, yes i took ownership of the folder. In fact the folder was owned by 5a64025f7596588362a636 which is the name of the folder. I gave myself "Administrators" full control.

But it didn't work.

I will try a chkdsk and keep you posted.


Report •

March 12, 2009 at 12:03:25
I assume you checked the attributes of the file and modified them accordingly?

Report •

March 12, 2009 at 12:17:29
I tried that earlier, but not after taking ownership of the folder.

Anyway, in XP, it's not a problem since, as an administrator, i never had a problem deleting a "read only" file or folder.

Report •

March 12, 2009 at 13:13:25

After taking ownership of the folder, i was able to rename it.

But, I was NOT able to take ownership of the subfolder called "update".

So, the result is the same, i can't delete the folders...grrrr....This drives me nut.

Report •

March 12, 2009 at 13:22:51

I don't know how or why, but when i got back into the advanced button, i was able to remove the ownership to whatever thing took it and re-give it to me. It wasn't working before

Maybe it was because i rebooted after the chkdsk, i don't know. Anyway, i am happy now.

Thanks for everyone's input, it's very appreciated.

Report •

March 12, 2009 at 13:23:15
Nice work!

Report •

March 12, 2009 at 13:56:49
We're glad to hear you solved your problem.

"Maybe it was because i rebooted after the chkdsk"

Sometimes it isn't made clear that you have to reboot to have settings take effect.
If in doubt, try rebooting.

I actually had the following composed earlier but my computer froze before I could post it, and I hadn't gotten back to this topic till just now:

"You may have to reboot the computer as well.

If the folder is a subfolder of a folder or a drive letter that you are still not allowed to access, you also have to take ownership of the "parent" folder or drive letter."

I can usually save a notepad file when IE has frozen - that's what I did. 1:40:45 pm Mountain Daylight Time, so 12:40:45 pm Pacific Daylight Time

Report •

March 12, 2009 at 15:31:40
I did the chkdsk in safe mode, that's why i had to reboot.

Report •

Ask Question