Cannot run Defrag

July 16, 2009 at 04:08:16
Specs: Windows XP
Hello, When Itry to run Defrag on XP SP2 I get the message MMC cannot open the file C:\Windows|system32\dfrg.msc. It further tells me that "This may be because the does not exist, is not an MMC console, or was created by a leter version of MMC. This may also be because you do not have sufficient access rights to the file." I am the Administrator, I can find the file using the Search command and it was created 23 Sept 2004 and modified and accessed on 16 July 2009. I have run a SFC /SCANNOW and a CHKDSK /F but still have the same result.

Can anyone provide an answer for this.

Thanks, Graeme G

See More: Cannot run Defrag

Report •

July 16, 2009 at 08:14:55
Here's a site with several potential fixes:

Let us know if it helps...

-- kptech

Report •

July 16, 2009 at 08:14:59
Your results are when you start it from the shortcut under system tools?

what happens when you go to a cmd prompt, browse to the system32 folder and type in dfrg.msc and hit enter? Does it start?

If so then you need to look at your environmental settings. An installed program messed up the path and system32 isn't in the path anymore.

Report •

July 16, 2009 at 13:49:38
Go to command prompt

Type in defrag

does it work?

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

Related Solutions

July 19, 2009 at 18:38:23
Hello to all, Thanks for all your answers. I got impatient waiting for replies and ended up going to Major Geeks site and downloading the O & O 2000 freeware version. This has worked fine and gave me an expedient solution.

Sorry if I caused anyone an inconvenience.

Kind regards and thanks for all your help.

Report •

Ask Question