Click here for important information about

Cannot read ANY usb flash drives

September 14, 2011 at 17:44:43
Specs: Windows XP, Core 2 Duo T8300 / 2.0 GB memory
Recently, I get the error message "The disk in drive _ is not formatted. Would you like to format it now?" any time I try to open any usb flash drive. Also, when I try to format the drive, I get the "Windows was unable to complete the format" error message. I know the drives are all good and have tried formatting them to both FAT and NTFS using other computers.

For troubleshooting I have only tried to open the drive is safe mode...which I get the same results. I am pretty much stuck from here, any help is greatly appreciated!

See More: Cannot read ANY usb flash drives

September 14, 2011 at 18:20:27
What USB port(s) are you plugging these drives into ?

If you're plugging them into the front ports on a desktop case, or into the ports in an externally connected hub, or into an internally connected hub that's not built into the mboard, they may NOT be recognized properly.

If you have unplugged any of the drives while Windows was running WITHOUT using Safely Remove Hardwaqre to STOP accessing them, you may have damaged the data on the drive. You need to use a program that can fix the data damage BEFORE you attempt to re-format them. Windows allows you to reformat the flash drive, but it does not allow you to delete the partition on the flash drive and make a new one, so if the data for the partitioning itself is damaged, you must use a program that can fix that data damage.

Troubleshooting USB device problems including for flash drives, external drives, memory cards.
See Response 1:

Report •

September 14, 2011 at 19:31:37
In addition to what Tubesandwires stated above, I've run into the situation where Windows no longer sees a particular USB device. The answer I found had something to do with the way Windows enumerates devices. The solution involved removing a certain registry key and rebooting. It was one of those rare events that few had ever encountered, and the solution was found on a website dealing with a USB printer device (of which I can't recall the make/model). Perhaps a Google search using "Windows XP registry - enumeration" as the search parameter will give a clue as to which key/s to look at.

Caution: always backup the registry before removing entries/keys.

Please let us know if you found someone's advice to be helpful.

Report •

September 14, 2011 at 21:00:45
What I was trying to explain is that the problem is isolated to the computer itself. I have maybe 8-9 USB drives, all of which do not work on this particular computer. They all work perfectly on any other computer. I have tried all USB ports and all result in the same issue. The USB ports themselves seem to be ok as well...printers, cameras, mice, etc all work without issue. The issue is most definitely a software issue related to not recognizing the files/file systems on USB storage media. (IDE/SATA drives are fine btw if that is useful info)

Really appreciate the quick response! Any further info would be fantastic!

Report •

Related Solutions

September 14, 2011 at 21:04:28
Thanks for the info!

I have deleted all registry keys related to enumeration and that did not seem to have any effect. (I have a gut feeling that the problem is registry related however.)

I will continue to research possible registry problems that could be causing the problem. Will post up if I find anything.

Report •

September 17, 2011 at 08:37:05
" I have maybe 8-9 USB drives, all of which do not work on this particular computer. They all work perfectly on any other computer. I have tried all USB ports and all result in the same issue. The USB ports themselves seem to be ok as well...printers, cameras, mice, etc all work without issue. "

If this is a desktop computer, there is onlly one thing I can think of where some USB devices work or are recognized fine yet other USB devices that work fine with other computers do not.
You may have an IRQ sharing problem you need to fix,,,,
See response 3 in this:

"I have deleted all registry keys related to enumeration and that did not seem to have any effect. (I have a gut feeling that the problem is registry related however.)

I will continue to research possible registry problems that could be causing the problem."

You DO NOT need to take the risk of doing anything in the registry !

You can easily and safely do steps to re-load the USB stack if NONE of your USB deviices work (see the info at the above link), but you said some USB devices work fine !

Report •

October 17, 2011 at 12:43:39
I'm having exactly the same problem - did you manage to fix it rhinohuey?

Report •

October 18, 2011 at 08:04:48

See response 1 and the info at the link in response 1
If you have a desktop computer, see the info at the link in response 5

If that doesn't help your USB controllers may be damaged.

Report •

October 27, 2011 at 03:04:03
Did anyone ever get to the bottom of this? I have exactly the same problem on one Dell laptop. USB port works fine on anything except USB flash drives formatted with FAT.

The FAT formatted flash drives work fine in any other PC, so do NOT need formatting.

In Windows Explorer this laptop thinks they are an unformatted 'Removable Disk' and promts you to format the drive (which it is unable to do).
The Flash USB sticks are detected in device manager and disk management (format RAW, though they are in fact FAT (FAT32 and I think I tried a FAT16 drive too).

NTFS disks in external USB housings are fine. All USB ports on the laptop do the same.

I am looking at a probable wipe and re-install of Windows as can't find an answer anywhere to this specific problem.

Edit. Definitely a problem with FAT format. The same stick (formatted in another machine) is seen fine when formatted as NTFS and fine in any other machine as FAT32.

Report •

October 27, 2011 at 08:36:38

"The FAT formatted flash drives work fine in any other PC,"

Obviously the reason you can't detect their data properly is because of some other reason other than they're using FAT partitioning.

See the extensive info info at the link I supplied in response 1.

- you're more likely to have problem with detecting a flash drive properly when it is NOT plugged into a USB port built into the computer's mboard
- in some cases, much more common for laptops and netbooks, if you have both a external hard drive or external optical drive - which requires the full USB max spec 500ma - and another device plugged into USB ports that connect to the same USB hub for the same USB controller segment interally inside the computer, one of the two devices, or both devices, will not be detected properly because there is 500ma available for both ports combined, NOT 500ma for each port as there should be. . In that case if you uplug the external hard drive or optical drive, the other device vthat does not require the full 500ma should be detected fine.

I haven't encountered or heard of what Sci-Guy mentioned in response 2, but that's a possibility.

For desktop computers particularly, you can have problems with Windiows detecting any USB device if there is an IRQ sharing problem - see response 5 - but's that's not likely for a latop or notbook. Typically Windows recognizes some USB devices fine but doesn'r recognize at least one other one even when every other factor is right for detecting it properly and there's nothing wrong with the device. .

All partitions an operating syastem recognizes must be both software partitioned using some methid the operating system recognizes natively - for Windows 2000 and up that's by using any FAT method or the NTFS method - and then formatted - they're two separate things. When you make a new partition in 2000 and up, for hard drives and external hard drives, both of those two things are done in one step - most of the messages you see are about formatting so people often assume they're just formatting the partition,.
For removable devices you can store data on other than external hard drives - flash drives and memory cards - they come new with a partition that is already software partitioned and formatted - usually they use the FAT method of software partitioning, unless they are specifically made for use in certain devices such as cameras that aren't using that. .
Windows by default does not allow you to delete the partition and make a new one on removable drives - you can see that when you try to do that in Drive Management - flash drives and memory cards - but you can re-format the partition, one of the two things required, if Windows is seeing the software partitioning type properly.
If a camera uses memory cards, you can choose to Format or similar (e.g. Initialize) the memory card in the camera's own settings, when it's in the camera - it is actually doing both things - using a software partitioning method and formatting it. Some cameras use a software partitioning method other than a FAT or NTFS one - the contents of the memory card cannot be read directly by Windows - but if you connect the camera to the computer and have the software installed for the camera, you can see the data that's on the card in Windows, via it being in the camera.

When Windows is not detecting the software partitiong type that it should detect properly for whatever reason, despite the fact it was properly software partitioned and formatted previously so the operating system was recognizing it - the partition does not show up in Windows in My Computer (or Computer in Vista or Windows 7) , or in Windows Explorer, but if nothing else is wrong it shows up in Disk Management as RAW - un-allocated - as if it were blank of data.
When that happens with a flash drive or memory card, you can't re-format it because Windows isn't seeing the software partitioning properly, and you can't delete the partition and make a new one even if you don't care about losing data already on the flash drive or memory card, due to Windows defaults.

Report •

October 27, 2011 at 10:42:05
Tubesandwires, thanks for the response.

I disagree with your reply about FAT. The same USB flash drives works fine in the laptop if formatted with NTFS. Format them as FAT (in another PC), the format is detected as RAW in the problem laptop and prompts to reformat (which doesn't work). Have tried multiple USB flash drives - all behave the same as described.

I've read (and tried where relevant) all the responses in this thread.

It's not a power issue - as mentioned, the USB sticks work fine formatted NTFS in any USB port (with or without additional USB powered devices attached).

The USB enumeration registry entries route doesn't appear to be relevant.

That rather long response at the end iterates my problem - I'm looking for a fix though :)

I support about 1000 servers, laptops and PCs but have not come across this specific issue before.

My next step will probably be to either uninstall and re-install all the USB controllers (I doubt this will help) or more likely get the user to backup and then re-image the laptop - Windows XP pro SP3 btw.

Report •

October 27, 2011 at 14:02:15
There is obviously something wrong on that one laptop in Windows.

You can try checking for IRQ sharing problems and un-installlng the Windows USB stack as I pointed to in response 5.

USB controlers don't need specific drivers - Windows uses generic drivers for them.
However, if you install Windows from scratch you must install the main chipset drivers for your mboard after Setup has finished in order for the USB 2.0 support to be installed for your mboard if it supports it, and XP must have SP1 or later updates installed, or 2000 must have SP4 or later updates installed, in order for it to have the built in USB 2.0 suppport.

Your could try un-installing the generic USB drivers in Device Manager, Restarting the computer, and Windows will install them again automatically. (Un-installing the USB stack does that too).

However, I suspect you have some other oddball sitiuation going on with that laptop, and finding what is causing it is a puzzle you may not be able to solve in a reasonable amount of time.

If it has XP on it, you could try running a Repair installtion of Windows procedure, which will not delete the personal data and personal settings from the partition Windows was installed on - that takes less than an hour to try - but doing that can't fix all problems.

See response 10:

Scroll down to:

"- If that doesn't help, you can try running a Repair installation of Windows"

If that doesn't help, you probably need to install windows from scratch, or use a Recovery procedure (by usung data from a Recovery partition or a Recovery disk set) to re-load your original software installtion on C, after having copied all the personal data you don't want to lose to elsewhere, but that's only the first step of many you'll need to do.

Report •

December 24, 2011 at 13:42:23

same issue, dell netbook. the problem began when i plugged a brand new usb jumpdrive into the machine. got a weird error , and was instructed to restart ....

anyway, now no fat32 formatted disks plugged in can be read or formatted....please advise!

would GREATLY appreciate an email, because this is really messing up my chrismas plans....


Report •

December 31, 2011 at 14:31:37

It's NOT a good idea to leave your email address in a post anywhere on the web - there are malicious people and malicious programs that are constantly looking for email address to abuse. You should delete it.
You can Edit any of your own posts on this web site, for a limited time, by clicking on the the Edit this message link at the bottom of your own posts.

See response 1 and the info at the link in response 1

See response 8, 9, 10, and 11

Report •

Ask Question