Black screen, safe mode no go

Compaq / Presario sr1000
April 21, 2009 at 11:55:37
Specs: Windows XP Media Center Edition 2005, AMD 64 3800+/3GB
I apologize if this problem or a similar problem has been answered elsewhere, but I've tried quite a few things and nothing seems to work. And this will be a lengthy post, but I want to give you all as much to work with as possible.

After the Windows splash screen, my computer loads to a black screen with the cursor in the middle. Safe mode does not work and I do not have a Windows XP disc for I was never given one. What should I do/try to get Windows working again?

Detailed Explanation:
I left my computer on one night to finish downloading a large file, roughly 2 GB, using Opera as my browser. When I woke up the next morning, my system was incredibly laggy and buggy, so I ran a virus scan and cleaned it up.

I reset my computer, and after the splash screen, it would reset itself. Safe mode wouldn't work either. So I enabled "Disable automatic restart upon system failure" to see what was causing the problem. It was user32.dll. I copied a backup file from elsewhere on the hard drive to replace it, and Windows finally loaded.

Then an error popped up saying that lsass.exe had a fatal error, and a shutdown timer started. This time around, Safe mode actually worked, so I copied lsass.exe from my girlfriend's computer in hopes that that would fix it. I backed up my copy of the file beforehand.

Now Windows loads to a black screen with the cursor in the middle. Safe mode brings up a blue screen that says:
Stop: c000021a {Fatal System Error}
The session manager initialization system process terminated unexpectedly with a status of 0xc0000005. The system has been shut down.

I don't have a Windows XP disc, as I was never given one with my computer. So I can't do a system repair that way. So my question is: what else should I try to get my computer back up and running?

Thank you in advance!

See More: Black screen, safe mode no go

Report •

April 21, 2009 at 12:18:39
"an error popped up saying that lsass.exe had a fatal error, and a shutdown timer started"

Your system appears to be infected with the Sasser worm.

"An indication of the worm's infection of a given PC is the existence of the file C:\WIN.LOG or C:\WIN2.LOG on the PCs hard disk, as well as seemingly random crashes of LSASS.EXE caused by faulty code used in the worm. The most common characteristic of the worm is the shutdown timer that appears due to the worm crashing LSASS.exe."

Report •

April 21, 2009 at 12:21:28
sounds like you got the sasser virus, a timer pops up then shuts down the puter. if you go here you can read about it and it has the fix....

Hope this helps.

Report •

April 21, 2009 at 23:29:11
Thank you both for the quick replies, but sadly I already tried running Symantec's W32.Sasser Removal Tool and it said my computer was not infected with the Sasser virus. And if it still is, I don't know how I would be able to repair it without logging in to Windows.

The link that THANATOS provided does have a detailed explanation of the virus, though, so I'll read through it more thoroughly and see what else I can think of. In the meantime any other suggestions are greatly appreciated, since I don't want to have to reinstall Windows or reformat my drive if at all possible.

Report •

Related Solutions

April 23, 2009 at 11:26:19
I managed to download BartPE onto my girlfriend's computer and added some system files to the ISO image it created. After booting BartPE and replacing the old system files with the others, I got Safe Mode working again and Windows runs bare-boned normally. I've run virus, spyware, adware and registry scans and cleaned it up more. So it's to the point now where I'll try backing up all my information and formatting, so thank you again for your prompt replies!

I copied lsass.exe, user32.dll, winlogon.exe and csrss.exe over to my computer to get it working again.

Report •

Ask Question