avi's won't open on double click

July 13, 2009 at 19:51:03
Specs: Windows XP
okay, just recently I've been having an odd error/glitch where when I double click on an avi or wmv file they go to the 'open with' screen rather than simply opening in Windows Media Player.

I have got the Combined Community Codec pack installed and all other file types seem to open fine (.mkv .flv .ogm etc).

I try selecting Widows Media Player and checking the 'always use the selected program to open this kind of file' option, but it doesn't seem to take.

I've also checked the file type associations within WMP itself, and they are set correctly. I've even tried refreshing them by deselecting, applying, then reselecting them...

I'm using WMP 10, with the codec pack I mentioned above. Any ideas on how to fix this would be appreciated :)

Thanks in advance.

See More: avis wont open on double click

Report •

July 14, 2009 at 02:14:49
o0reno0o, found anything that'll open them? Find first THEN tic 'always use'. I've found that Irfanview (free @ http://www.irfanview.com ) will open most graphics.
Ed in Texas.

Report •

July 14, 2009 at 03:25:26
Heh, thanks for the reply Ed, but I -do-actually want them opening in Media Player (that is installed and is opening other video files types just fine)... I'd just like it to be opening straight away rather than going to the 'open with' screen when I double click.

So yes, just in case I was unclear about exactly what's happening at the moment, when I double click on an avi or wmv file (both video formats), rather than just playing in Windows Media Player it goes to the 'open with' screen. In that screen it has Windows Media Player selected by default, so I just click 'ok' and it loads fine.

I just want to not have the 'open with' screen come up in between, and as I said in my original post, ticking the 'always use' doesn't seem to be acting as it should as each time I open an avi I tick it and the next time I have to do it all again.

It's really only a single extra click, so it's more of an inconvenience than anything else, but I'm curious as to what the cause might be. And why the 'always use' button seems to have broken.

Report •

July 14, 2009 at 06:15:32
o0reno0o, It won't hurt to try this:

Click Start>Run then copy & paste or type in:

regsvr32 /i shell32

Click OK

Note that the spacing is important.


Report •

Related Solutions

July 14, 2009 at 13:00:58
thanks again for the suggestion, but sadly still no change.

Another odd part of the situation is that when I use the 'always open' button for any other program (still opening avi or wmv) it does preserve the association. So if I tell it to always open with firefox or notepad (yes I know they're not media players :P) it does work as it should in that it remembers the program and opens it directly on a double click.

It's rather frustrating that the only program that will refuse to do it is Media Player... I'm just going to uninstall/rollback the codec pack and the player itself to see if that fixes things. I'll report back in a little.

Report •

July 14, 2009 at 13:07:12
well, that seems to have fixed it... still would have loved to know exactly what happened to make that error occur.

Thanks for all the suggestions :) I really appreciate those who took the time to read this and even more so to those that replied.

~ Reno

Report •

Ask Question