Solved Anyone tried cloning WinXP into a dual-boot harddisk

May 20, 2013 at 16:12:05
Specs: Windows XP Pro, 1.5GHz / 1GB

I'm trying to make my WinXP Pro Laptop a dual-boot system which will have Linux in addition to my existing WinXP Pro installation.

To do that, I partition a spare harddisk as MBR schemed to have 3 partitions:

First 2 partitions for the Linux (First for the '/' , the second for the SWAP)
3rd partition for the WinXP

If I install WinXP from scratch into the 3rd partition and then install Linux into the first 2, no problem, the Linux's GRUB recognizes WinXP installation and when I select WinXP in GRUB it boots perfectly.

But when I copied a clone of my existing WinXp installation into the 3rd partition, and then installed Linux onto the first 2 partitions, the GRUB recognized WinXP but when I selected the WinXP, it failed to boot (with empty black screen containing nothin but an underline cursor on topper left) The app I used for cloning WinXP was Carbon Copy Cloner (available only on Mac OS, and I used it on a Mac anyway, which is capable of read/writing on NTFS filesystem) I couldn't use Acronis because it was unable to restore the cloned WinXP onto the selected partition (the 3rd partition in my case)

I hear people use Easeus and Macrium Reflect to clone WinXP in several places, in this post for instance. But it's not clear if they managed to clone their existing WinXP installation onto a partition of dual-boot harddisk, which uses Linux' GRUB as the boot manager.

Any advice is appreciated, thanks.

See More: Anyone tried cloning WinXP into a dual-boot harddisk

Report •

May 20, 2013 at 17:03:48
✔ Best Answer
The problem is, that the clone image was made from the first hard drive and first partition.
So after you restored the image to the 3rd partition, GRUB starts WinXP, but WinXP boot information directs to the first hard drive and the first partition, where your Linux lives, which ends up in a black screen and the hardware cursor on the upper left on screen.

Try booting from the WinXP installation CD, boot into repair console and try to repair the your XP installation with the commands FIXBOOT and/or FIXMBR.

Report •

May 20, 2013 at 17:16:35
Wouldn't it just be easier to do a clean install? Windows on C: then install Linux from inside Windows using WUBI? No need for numerous partitions or GRUB.

Report •

May 21, 2013 at 16:07:17
Hello paulsep

it's a good answer because it adds insight onto the problem: Yes it might be really caused by the cloned winxp image being at the first partition and trying to make it boot from 3rd partition. It looks as if, if I put the cloned image onto the 1st partition, winxp would boot properly but before I do that, I will tinker with the FIXMBR and post the results.

Report •

Related Solutions

May 21, 2013 at 16:12:13
Hello riider

It might be easier to do a clean install but then it would make no sense having clone image of winxp. remember, the winxp image contains lots of things done after the installation of a simple winxp, such as installing numerous applications, configuring them, and even the History records of Firefox are there, that's why I prefer transferring the clone image onto a suitable partition.

Report •

May 21, 2013 at 18:01:44
WinXP also has a boot.ini, where the disk and partition is set like this:

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Changing the settings here might also work, but that is, what fixboot does.

Report •

May 21, 2013 at 21:33:56
This sounds like the most probable solution to what is going on to me.

Report •

May 22, 2013 at 07:42:31
I've tried changin the partition number in boot.ini from 1 to 4 nothing's changed. I tried 3 and 5 and they didn't work either. I guess it's got more to do with the GRUB. I think I should edit GRUB's config or whatever file necessary for setting Windows XP properly, because at GRUB's menu, " on /dev/sda5" is displayed next to Windows XP entry.

/dev/sda5 seems to be a nonexistent partition.

To compare to another dual-boot system on which Windows is working with GRUB, the Windows is shown as "/dev/sda4" In this working system, however, I have installed Windows from scratch and then installed Linux (w. GRUB of course) on top of it.

I guess I should edit GRUB configuration in this case Here it's explained how to edit but my version of GRUB is 1.98 and I couldn't find a way to edit it that way.

Report •

May 23, 2013 at 14:28:54
You also have to change the hdd drve number in boot.ini or, as mentioned above, boot from xp installatin cd into recovery console and use fixboot.

Report •

Ask Question