640gb Seagate Freeagent Go can't be formatted

August 21, 2011 at 04:40:40
Specs: Windows XP
I have a 640gb Seagate Freeagent Go that cannot be formatted as normal which they called the full format, it was 6-7 hours after an error message pop up, says that the disk format cannot be completed. But when i tried to quick format, it was formatted successfully. I want to full format the disk because there are several bad sectors detected on the disk. As what I've read that: "Full format will truly scrub through the hard drive from scratch, rebuild all of its file structures, and scans the drive to make sure that everything is on a satisfactory level. On the other hand, what a Quick format does is lay down a blank FAT and directory table without checking for bad sectors."
Can someone please help me? Thanks a lot.

See More: 640gb Seagate Freeagent Go cant be formatted

August 21, 2011 at 05:50:28
If you have "several" bad sectors you should not depend on that drive any longer. The condition will just continue to get worse. Before you were even aware of any bad sectors the drive had already substituted sectors from a pool of spare sectors. So you have more than you thought.

While I have your attention, if you are using that external to save important files be sure to keep at least TWO copies of any data you need. Save them to different media. All data is subject to loss, corruption, theft, fire, etc.

Have you run Seatools on the drive? If not, I suggest you do. Get it at the link below.


Report •

August 22, 2011 at 08:46:42
Yeah your right, I already saved my important files to my other HD. But some of them cannot be copied it will give me an error, which is the Cyclic Redundancy Check.

Thank you for your reply sir, I'll try that Seatools now.

Report •

August 22, 2011 at 12:02:13
CRC errors may be caused by trying to write a file larger than 4GB to a FAT32 partition. Is that your case?

Report •

Related Solutions

August 22, 2011 at 21:46:30
Nope, my partition is NTFS. I already tried the Seatools a while ago and got this result after the Long Generic Test:
Bad LBA: 9611380 Repaired
Bad LBA: 9611381 Repaired
Bad LBA: 9611382 Repaired
Bad LBA: 9644383 Unable to repair

then I run the test again and the result was:
Long Generic - Started 8/22/2011 9:53:35 AM
Bad LBA: 0 Not Repaired
Bad LBA: 1 Not Repaired
Bad LBA: 2 Not Repaired
Bad LBA: 3 Not Repaired
Bad LBA: 4 Not Repaired
Bad LBA: 5 Not Repaired
Bad LBA: 6 Not Repaired
Bad LBA: 7 Not Repaired
Bad LBA: 8 Not Repaired
Bad LBA: 9 Not Repaired
Bad LBA: 10 Not Repaired
Bad LBA: 11 Not Repaired
Bad LBA: 12 Not Repaired
Bad LBA: 13 Not Repaired

Report •

August 22, 2011 at 23:32:18
So it would appear the drive is not servicable.

Report •

Ask Question