Vista SP2 install fails with 0xc0190005 error

February 5, 2012 at 08:41:38
Specs: Windows Vista 32bit
Solution for 0xc0190005 \Registry\machine\Schema\wcm://Microsoft..

Like a lot of others (having searched the net!) I recently encountered the above error when trying to install Vista SP2 via Windows Update.

The concensus seemed to be that you were 'screwed' and you had to re-install Vista and rebuild the machine from scratch. There were lots of similarities between myself and others with the problem - the laptop did once have Norton installed, and did once have AVG installed on it (both had been removed).

I followed quite a few suggestions - remove Norton completely using the Symantec utility, ditto for AVG, run sfc scannow, restore the laptop to an earlier working point, don't connect wirelessly to a router (use an ethernet cable), run chkdsk, try Startup repair, etc....nothing fixed it.

The system startup was ok, the system seemed to run ok, no viruses were detected by anti-virus software and registry cleaners failed to fix the problem.

A lot of the web postings suggested 'solutions' which boiled down to 'buy my company's registry cleaner'...but I'd already proven that a registry cleaner wouldn't fix the problem.

I eventually accepted that I would have to re-install Vista and spend a day re-installing drivers, applications, etc., so I inserted the O/S disk in the CD and kicked off the install.

I decided to try the 'Upgrade' option first (instead of the new install / reformat disk option) - it picked up that Windows Powershell needed to be uninstalled first (?).

Instead of uninstalling (I don't think I was able to?), I disabled Windows Powershell via 'Turn windows features on or off'.

This then enabled me to run the Upgrade option, which took a few hours but completed successfully. I was then able to run Windows Update (approx 180 packages) and one of the upgrades was SP2 - which this time worked!

Problem solved, wihout losing any of my settings or applications.

After SP2 there were another 40 packages to install and in total it took about half a day to get back to a working system with Windows Update now working again.

If anyone has a similar problem, it might be worth first trying to disable Windows Powershell and
then re-install SP2 (before you reach for the Vista O/S disk)?

(Perhaps a Windows Powershell upgrade had failed and caused the registry corruption?)

See More: Vista SP2 install fails with 0xc0190005 error

February 5, 2012 at 11:33:40
Try running the fix it tool from microsoft on this issue....sometimes they are magic...sometimes not, but they have not hurt anything I have tried them on...they are Microsoft.

Report •

February 5, 2012 at 12:21:06
Yes, I did try the Fix It tool, but it was unsuccessful.

The problem is now fixed - I was just posting how I managed to do it (in case anyone has the same issue in the future).

I suspect ( but can't prove) that a previous Windows PowerShell update was the cause of the file/registry corruption that caused the SP2 update to continuously fail.

Report •

February 6, 2012 at 14:54:26
As an aside, Fix it tools from MS don't "always" work. I had one that made things worse and I had to restore the registry then find a better solution. After that experience I would now use the manual fix - at least I would know how to undo it.

Thanks for the heads up - it might help someone.

Always pop back and let us know the outcome - thanks

Report •

Related Solutions

February 7, 2012 at 02:47:33
You may try this solution from Microsoft.

I remind you, the error code is different, though.


Report •

Ask Question