Vista not recognizing digital camera

July 13, 2010 at 14:20:29
Specs: Windows Vista
Suddenly windows vista is no longer recognizing our Fujifilm FinePix S1500 camera when we plug it into the USB port. I tried the 'Add Device' option under scanners and cameras, but couldn't add it because I don't have a disc with any drivers on it. Is there a service I might need to turn back on to get this to work again?

Thanks Greg M.

See More: Vista not recognizing digital camera

Report •

July 13, 2010 at 15:22:53
does the camera work on a different pc?
other usb devices detected on this pc using the same port?

Report •

July 13, 2010 at 15:38:48
Not sure about other computers, but I can plug the printer into that port and it works just fine.

Report •

July 13, 2010 at 15:45:51
That means the computers usb port is working.

You get no popup concerning discovery of a new usb device when you plug into your computer?
You get no additional drive in My Computer when the camera is plugged in?

next you will want to try that camera on a different pc which also has known working usb ports. If still no go the problem is with the camera.

You should need no disk or drivers. Usb is usb and should work.

Report •

Related Solutions

July 14, 2010 at 03:44:30
If your are wanting to transfer pictures from camera to PC, a much easier method is to buy a card-reader which you leave permanently attached to the PC via USB.

Remove the memory card from the camera and pop it into the card-reader. Windows will detect it and a window will open containing the contents of the card.

The reader needs no external drivers as Windows takes care of that. Much simpler than messing about to connect your camera to the PC.

Report •

July 14, 2010 at 07:35:00
I'm sure it's something I did. It's actually my wife's computer and she downloads all kinds of worthless stuff and then complains that the computer is too slow. After I uninstalled a few things the camera stopped working.. I'm just not sure how uninstalling anything has messed up the cameral connection.

Report •

July 14, 2010 at 08:47:21
try going to a restore point before you had this issue.

Report •

Ask Question