Click here for important information about

Vista Clipboard copy/paste function vanished!

Lenovo / 0768a53
November 14, 2011 at 23:50:13
Specs: Windows Vista, 1.6 GHz / 2037 MB
Okay, this is now a repeat problem. All functionality of copy/cut - paste is essentially gone. It will occasionally hit-and-miss with a proper copy-paste, but not normally.

I'm trying this through both the standard right-click mouse command and they keyboard commands as well, to the same effect. Drag-and-drop capability remains functional and unaffected.

The last time I had this problem (a few weeks ago), I was on another forum that had no suggestions on how to fix it, so I just did a brute-force System Restore. That fixed it. Now? It's back again. I'm using Windows Vista and Firefox 8.0 (but the problem works with any type of copy issue on any program).

Both this time and the last time, all spyware, malware and antivirus programs gave my system a clean bill of health. I wish that I could correlate it to something happening, but I can't. Additionally, my hardware seems to be in complete working order as evidence by the fact that the System Restore solved the problem. I just need to know what's happening with some kind of software glitch.

I used AVG Anti-Virus, MalwareBytes AntiMalware, Kaspersky Rootkit kiler, IOBit Malware fighter (pro), and all says that everything is good.

The best thing that I can say is that it happens while I'm using Firefox. I don't know what I'm doing... but it happens then, because it's not until I'm done and go to do something that I discover the malfunction.

See More: Vista Clipboard copy/paste function vanished!

November 18, 2011 at 18:48:33
Without researching this, my first move would be to do a sfc /scannow in an elevated cmd window, to see if there are any corrupted system files.

Start menu, type in CMD.
on the CMD entry, right click and click on Run as administrator.
type in the above command and let it run.
reboot and test.

Report •

November 19, 2011 at 17:53:31
Hello Paul1149, thanks for answering with a place to start.

I did exactly as indicated. Twice, actually. Once right as it stood, one immediately after a reboot. Both times the cmd sfc /scannow resulted in the same message:

"Windows Resource Protection found corrupt files but was unable to fix some of them.
Details are included in the CBS.log windir\Logs\CBS\CBS.log For example

So, despite the fact that I really have no idea what I'm looking at, I opened up the CBS.log (had to make a copy of it to open, actually).

If I am reading it correctly where "cannot repair" indicates bad files, the following have something wrong with them:


(yes, both the msiexec files)

So, if that's broken and Windows cannot fix itself, how can I go about fixing them? Vista came preinstalled on my laptop and I thus have no installation or repair discs - what I have are some full system backups in case of horrific computer crash. I'd prefer not to followup with those. Ideas?

Thanks very much.

Report •

November 19, 2011 at 18:47:21
Autochk tells vista to run chkdsk on reboot, and frequently is a problem in vista. Over at vistax64, Brink has an excellent tutorial on how to fix that problem.

The other two are installers. Good to fix, but I don’t see what they would do to the Copy function, which I believe is run by explorer.exe.

I take it your Copy problem persists? You could try replacing explorer.exe. that would have to be done from a live CD I think.

But see HERE for a Vista recovery disk that may solve several problems at once.

Report •

Related Solutions

November 20, 2011 at 08:12:55
Another possibility is malware. I would run a good scan with MBAM or SAS. SFC should have picked up on a corrupt explorer.exe, so if it is malware it's probably intercepting the hotkeys, which is reversible.

Report •

November 21, 2011 at 17:52:41
Hi, I'm actually unsure as to whether or not the problem is back, as it is unfortunately not 100% predictable.

Now, unless there's some incredibly devious piece of malware on here, my computer is clean. AVG, IOBit MBAM, SAS all say it's clean. I've tried Brink's fix for autochk.exe, but unfortunately no matter what kind of permissions I give myself as administrator, can't copy into System32. But, that's to fix the autochk.exe and I can poke around that area.

Your mention of explorer.exe possibly being busted made me think, and yes, a few months back I began to get notices that explorer had to be stopped and restarted. For some reason... I didn't bother do deal with it then. Don't ask me why, I guess it didn't bother me. This might well be the problem/source of the copy/paste issue, even though the CMD scan that you had me do didn't report it, and there's no malware lingering around.

Is it possible that doing the sfc /scannow would have fixed a corrupt explorer.exe? I have no idea how to read the log to guess if it was repaired or not.

I'll continue to leave this open and see if the copy/paste comes back again. Thank you again for the assistance.

Report •

Ask Question