Sys. Event Notification Service err

April 2, 2009 at 16:43:18
Specs: Windows Vista Bus. SP1, P4 - 4GB

Hello everyone,
I began having a problem with my Dell Inspiron 1525 last weekend when I brought it outside my apartment to try to connect to my ISPs wi-fi. I'm running Vista Business. As I'd expected the signal was too weak but there was one open network with a strong signal that I was able to log on to. However, once I connected and Firefox began to load my homepage, my Kaspersky AV software popped up warning me that the connection was trying to make changes to my registry. I quickly hit "deny" for the first two or three messages that popped up but for the last three I took time to read them and save them to a file, the text of these is printed below. I quickly logged off their network and the 1525 seemed fine afterwards. However later on when I booted the system up the initial Windows Vista Business welcome screen was displayed for what seemed like over a minute, MUCH slower than usual. Once the welcome page disappeared a blank blue screen appeared and it too stayed that way for a little over a minute. After that, Vista began to load normally except for the following message "Failed to connect to a Windows service. Windows could not connect to the system event service. This problem prevents limited users from logging on to the system. As an administrative user, you can review the system event log for details about why the service didn't respond."

Aside from that error message, I noticed the clock and CPU meter were missing from my sidebar. The gray sidebar displays however those two things are not. I googled this error message and while quite a few people have experienced it I could not find any fixes. Several people felt Windows Defender was the problem but I believe I have mine disabled. At least one other person had suggested killing the trustedInstaller.exe however I could not even find that running on my system under computer management/system tools. Also, the System Event Notification Service is always listed as "starting" but never changes to "started".

One other thing, when I first tried logging on after getting the error message from Kaspersky I got a message that the local networks could not be found and sure enough I cannot connect to my own wireless router. I tried resetting it but this was no help.

I've been trying to fix all this for a while now and any help you can provide is greatly, greatly appreciated!


Dan G. in CT

See More: Sys. Event Notification Service err

Report •

April 2, 2009 at 20:07:12
I connect to networks all the time & I've never seen that before. I wonder if the owner had a script ready for people who connected to his router instead of just blocking it.

Download, update and run anti malware from

If that doesn't help, run Hijack This & post the log.

You can always try a restore point if you think that's easier.

Report •

April 8, 2009 at 22:01:27
My housemate had this problem on her laptop running Vista.
I finally found this solution which worked the first time.

Step One: Open "elevated command prompt"
Hit Windows key
type "cmd" at the prompt
Press Ctrl-Shift-Enter
Click confirm

(thanks to:

Step Two: Reset Winsock:

(thanks to:

That did it for her computer--restarted, and it was up and
running again!

Report •

Related Solutions

Ask Question