Homebuilt / Homebuilt
Mike January 24, 2009 at 16:29:00
Specs: Windows Vista SP1, P4/4GB
Today I discovered my Vista machine is inexplicably hosed. On startup, Vista takes an incredibly long time at the Welcome screen, and after finally logging in I was greeted by a blank screen with only a cursor. Eventually Explorer appears or I can force it by running it from the Task Manager. I believe I've narrowed down the problem to the DHCP and SENS services, which refuse to start. Their status shows as "Starting" in the services console and never changes. Windows gives this error once Explorer starts:
"Failed to connect to a Windows Service. Windows could not connect to the System Event Notification Service service. This problem prevents limited users from logging on to the system. As an administrative user, you can review the system event log for details about why the service didn't respond."

Actually, no, I can't, because the Event Viewer says:
"Event Log service is unavailable. Verify that the service is running."

Okay, sure thing. I go to services and try to start the Windows Event Log service:
"Windows could not start the Windows Event Log service on Local Computer.
Error 1747: The authentication service is unknown."

This is looking good already. I've Googled the hell out of this and found no solution that works. Everything seems to be running me in circles.

There are four potential culprits recently introduced to the system:
-QuickTime, which now comes with a ton of crap. I removed all of it after installation, leaving just QuickTime.
-Realtek Audio drivers. This appeared to solve a recurring problem with ATI's drivers which would cause a TDR BSOD on a daily basis.
-Drivers for an HP Photosmart C3180.
-Koutech PCI USB 2.0 expansion card.

All four have been removed completely, no effect.

The newest Windows Updates are over ten days old.

I've tried disabling all startup processes, non-Microsoft services and drivers. I've tried disabling Windows Defender. I've tried uninstalling all programs installed in the last several days. I've tried uninstalling my third party firewall. I've tried changing the Start value for SENS in the registry.

I've tried resetting the Winsock catalog with "netsh winsock reset" in an elevated command prompt, where I received the error:
"Initialization Function InitHelperDll in NSHHTTP.DLL failed to start with error code 11003"
followed by
"Successfully reset the Winsock Catalog. You must restart the computer in order to complete the reset."
Which is confusing to say the least. I have to wonder whether anything is happening here at all. Are there any third party applications to do this task like there was back on XP?

Startup repair off the Vista disc said no problems were found and did nothing. There are no system restore points available.

A reinstall of Vista is an option I would like to avoid at this point. There is a licensed copy of Photoshop CS4 on this installation. Normally I could deactivate it for this but the very problem I can't solve prevents me from accessing the internet to do so.

I'm open to ideas.

See More: SENS & DHCP Stuck

Report •

January 26, 2009 at 11:47:35
have you tried running sfc /scannow to
verify your system files???

Report •

January 26, 2009 at 19:27:19
Yeah, no luck there either.

At this point I have another install of Vista up and running on another partition. I called Adobe earlier today and they made a note on my account that I was unable to deactivate Photoshop, in case I ran into trouble. So far I haven't, Photoshop is activated and running fine on the new install. It's looking like I'll give up on the other install now and format it away.

What bothers me is there's absolutely no indication what caused this, and what might cause it again. I suspect the HP driver at this point because I'm running all the other suspects again with no trouble, and HP's drivers have given me trouble in the past (The XP version of this printer's driver, for example, ties up all USB storage devices).

Report •

Related Solutions

Ask Question