Replaced hard drive, now no internet

July 2, 2011 at 19:27:36
Specs: Windows Vista Premium , ?
So something fried my hard drive and DELL had a tech come out to swap. Now this new HD wont recognize my internet hardware. Installed the drivers and apps on the discs that were shipped with the computer originally. Tech popped in the OS disc after replacing HD. If everything is the "same" as original system, why would some drivers/apps not install successfully? Also, I get a messege (after updating the broadcom device driver) that everything installed correctly but something is wrong with the device. I am no computer whiz, but not completely clueless, either. I can usually figure things out on my own, but I have tried everything that I can think of. It may sound "spoiled" but spending hours on the phone with DELL isnt exactly on my to-do list. With 3 kids and a deployed husband, the level of insanity is ... well ... insane. Any pointers that can help avoid making it more insane by calling DELL and basically having my kids run wild would be appreciated.

See More: Replaced hard drive, now no internet

Report •

July 3, 2011 at 08:49:32
Dell service stinks huh? I never got them to help me except one single time.

Well, what you said has no information that we need.

The very best place to start may be to look at your isp's help pages. There you'd find out a number of things that we'd need to know.

How do you connect? DSL or what?

Do you have a router? Is the router the point of connection?

Do you have a network interface card? Can you see it in hardware manager?
What was the old nic set to? Static or dhcp.

Did you put in your isp's dns ip addresses?

What is output of ipconfig /all?

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.

Report •

July 3, 2011 at 13:47:22
Alright, here's most of the answers:
I have cable internet (through Time Warner Cable) and a cable modem (motorola Surfboard - SB5101).

I have a wireless router (Netgear RangeMax -WNR834B v2).
--This previously worked for wired and wireless connections as the computer has built in wireless.

The modem is connected to cable & to router (using an ethernet cable to connect router). Several peripherals were also connected to the router. Our Xbox 360s were connecting wirelessly, as well. <-- this is the curious part. Because the Xbox 360s have continued to be able to use the signal without fail.

Okay, there is a wireless network adapter (Broadcom 802.11n) and this is what is apparently having issues.

There is (in Device Manager list) an "ethernet controller" but I see nothing other than that that has obvious labelling. It has no driver from what I can tell. I have tried getting my old computer online, but its like the router is stuck on this computer as it's host.

Unless the wireless adapter is the NIC, I dont see one. There is one unknown device listed and 3 "base system devices" listed.

I didnt mean to not give pertinent information. But the tech that came out to swap the drives said that the tornadoes that caused a big power outage here may have started a short. The power fluctuated about 2 weeks ago and seemingly thats what finished off my hard drive. That was my only other track of reasoning: maybe this Broadcom wireless device was damaged as well. I hate having to get help. But beleive me it is much appreciated. My only internet access now is from my iPhone. It lacks functionality, suffice to say.



Report •

July 3, 2011 at 14:03:14
I assume that you are trying to connect wireless. The 1525 has both a NIC the wired adapter and the Broadcom the wireless adapter. You have to enable the wireless connection.

Report •

Related Solutions

July 3, 2011 at 19:31:20
Wired or wireless would make a difference. If you have wireless you may need to know the passphrase or key.

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.

Report •

July 11, 2011 at 11:02:08
Hey, I figured it out. It was a wrong driver. Windows repeatedly confirmed it was correct and updated. However, the wrong driver was being used. I had yo hint down which driver was the one I needed and locate it on my HD. Afterward, it worked fine. If it helps anyone else who may run into this problem: I found it in the "Dell" folder, not "Windows". Then, of course, inn "Drivers".

Thanks for your time and efforts.

Report •

Ask Question