Solved Recovering for ACER doesn't work

October 19, 2012 at 12:13:04
Specs: Vista, Pentium Dual Core 1.60Ghz / 3 GB
Neither ALT-F10 or CTRL-F10 work to recover ACER 5720. When using Ubuntu Live CD I can see the harddrive listed, however, when trying to install another version of Windows, it errors with no harddrive found.

See More: Recovering for ACER doesnt work

October 19, 2012 at 12:40:00
✔ Best Answer
The hard drive may have failed even though it's listed in Ubuntu. To confirm if it's failed you need to test it with the drive manufacturer's diagnostic software for DOS which runs from a bootable CD.

Regardless of the drive brand, you can test it with SeaTools for DOS from the "Downloads" link on this page:

Then, on a working PC, download & install IMGBurn from here:

Use IMGBurn to create a CD from the SeaTools for DOS ISO file, then boot your faulty Acer 5720 from that CD (you may need to go into BIOS Setup and set CD/DVD as the first boot device).

When you boot from the CD, SeaTools will eventually start, allowing you to test the hard drive.

Report •

October 19, 2012 at 12:40:57
thanks, will try this this weekend and let you know what happens :)

Report •

October 19, 2012 at 14:11:51
I just couldn't wait, and tried it today. It seems the drive has broken down :( So, need to get a new one, and then install everything again.

Thanks for your quick reply.

Report •
Related Solutions

Ask Question