Nonresponsive 80 gb Maxtor 5000LE

Hewlett-packard / HP PAVILION
April 26, 2009 at 14:02:07
Specs: Windows Vista, 2.0 gb

I have Windows Vista and a nearly 6-year-old 80 gb Maxtor 5000LE that is not responding. I recently unloaded all of its contents onto another external hard drive, leaving no files on the drive. After I did that, I took the time to "safely remove hard drive" (an option for USB drives I forgo 99% of the time) and unplugged it after being given the safe notice. Before that, after opening up the Format menu on the drive in Computer, I decided not to reformat the drive and closed the window.

That was a couple days ago. I plugged that drive back in today with the aim to fill back up the blank drive only for it to not really detect. The sound alert for a newly detected drive is signaled, and I can see a drive with a default icon in Computer, but Computer stalls and takes several minutes to load/refresh itself when I try to left or right click on the 80 gb drive. It ultimately won't let me do anything, as it "is not accessible because of an I/O device error."

I have tried all three different USB ports, and it works properly in none of them as of today. It is fully plugged in. Putting my ear to it, I can hear it "thinking" or working, it just doesn't operate.

I did download Maxtor's PowerMax program and ran it, but it said something about not detecting a diskette or drive, so I closed and deleted it.

Obviously, with it being a blank drive, I'm not losing any files, but I still want what I paid for to operate, and I have a purpose for the drive, so I would like some assistance. Thank you very much.

See More: Nonresponsive 80 gb Maxtor 5000LE

Report •

April 26, 2009 at 18:23:27
Nevermind, problem solved. Please ignore or delete thread.

Report •
Related Solutions

Ask Question