computing
  • 0

No More Available Com Ports

  • 0

Hello
I am facing this problem. I am trying to set up a TM-T88IV Epson Thermal Printer under Windows Vista SP1. I have downloaded most updates, even those which are only recommended but not important.

When I try to install the driver I downloaded from epson website, I get to a screen in which I have to choose among the possible connections (USB, COM, Ethernet,…). Since this thermal printer is linked to the computer through the COM port, I select COM as connection.

The problem comes up after selecting COM because the installer program shows up a window with a message like “No more available COM ports…”

After some research I thought this might have to do with COM ports being busy by other devices. Nonetheless I do not use a serial (COM) mouse but a USB one.
Apparently, there are only two external COM ports on the back of this HP desktop computer and just one of them is used with this printer, the other is free. Anyways, I read somewhere that serial COM ports sometimes should be freed up by disabling them at BIOS level. I looked this COM port in all the BIOS options, the advance tab included and there is no COM port option at the bios displayed for this computer. Well, this might be because new computers do not show their COM ports in the BIOS.

The problem is that this printer was working so far but something happened to windows Vista which did not let it boot anymore. Therefore I had to restore windows vista with the typical HP restore software.

After doing that the printer does not work.
If I go to control panel->printers then I do not even see the printer because I could not finish the installation process, as I told you, I got stuck with the step of choosing the connection (COM).

Other approach I tried was buying a USB to serial cable and trying to set usb as connection type in the corresponding step of the install software. It seems that this did install the printer because control panel->printers showed the printer. However, it showed it as no connected even when it is plugged.

Eventually, I tried one more thing with this USB to serial converting cable: installing the special software that epson put in their website to make this TM-T88IV thermal printer work under a USB interface. But, this did not work either because the printer shows up in controlpanel->printers as no connected.

Moreover, hopefully the printer is not damaged since it has been protected from high currents with one of this typical multiple outlet extension cord specifically designed for this purpose.

For the time being, I cannot think of any other idea to make this printer work.

I greatly appreciate any kind of suggestions to solve this problem which is driving me nuts.

Thanks a lot in advance.

Share

1 Answer

  1. Your problem may be an IRQ problem. It may be conflicting with another device. Can you go to your Device Manager and check First, that you have COM drivers for your Windows and Second are they reporting to work properly or if they say they have an IRQ conflict?

    http://www.helpwithpcs.com/upgradin…

    • 0