My computer won't load and shows something about Stealth 3D

January 7, 2016 at 23:16:54
Specs: Dell, XPS 410
When I turn on my computer it sounds like it's turning on but the screen shows nothing but something about Stealth 3D 2000 Version......2 MB installed. I Tried to press enter or something but nor the mouse or keyboard respond?

message edited by Ka


See More: My computer wont load and shows something about Stealth 3D

Report •

#1
January 8, 2016 at 00:10:06
The stealth 3d 2000 is a really old video card. That's just its logo flashing on the top of the screen prior to the normal computer logo or posting screen. Are you sure that's a vista machine (you're in the windows vista forum)?

Give it a minute or two before you decide to shut it off or reboot. Sometimes it takes a bit before an error comes up, especially if it's related to the hard drive.

To get into bios setup for a Dell xps 410 start tapping F2 as soon as you start it up.

Did anything happen to the computer or did you make any changes to it between the last time it worked OK and the first time it didn't?


Report •

#2
January 8, 2016 at 22:22:26
Okay yeah it's a dell and it originally is Windows vista. I have left it on for a while and it still won't do anything. I also don't get why the keyboard or mouse don't work. The mouse doesn't turn its light on and the keyboard lights don't turn on either so I know it's not working. I'll try the F2.

Report •

#3
January 8, 2016 at 23:14:57
It's odd it's got a 20 year old video card in it. Someone must have been fiddling around inside the case. That's why I was wondering what may have happened to it between the last time it worked OK and the first time it didn't. Sometimes people will add or change the video card because they think that's where the problem is when nothing shows on the screen.

Report •
Related Solutions


Ask Question