Hard Drive Error Reinstall Vista

April 7, 2012 at 05:35:33
Specs: Windows Vista, Pentium R 2.6 GHZ/3 gigs
My computer stopped working, got a disk read error. Took it to have the drive replaced (feel silly now) and the store said it couldn't do, first drive they replaced was going bad, second didn't work. Gave me back the whole system software and all.
Well, now I'm trying to reinstall Vista from the recovery disk and I keep getting the same error
"Windows could not format a partition on disk 0. The error occured while preparing the partition selected for installation. Error code 0x80070057"
I've tried changing the SATA plug location, I've tried deleting and setting up new partitions, nothing I do seems to get it past this spot. Any ideas?

See More: Hard Drive Error Reinstall Vista

Report •


#1
April 7, 2012 at 18:19:14
What is the make and manufacture of your disk and computer?

Some things that could cause this error is, bad SATA controller, bad SATA controller BIOS, The advanced format of large disks, corrupt MBR. Incompatible windows SATA drivers.

To rule out some of this stuff, boot into the BIOS and change your SATA controller from AHCI or RAID to IDE or Legacy. Now try to install Vista.

If that failed. Go to the manufacturer of your hard drive and download what ever bootable vision of their disk software that they have. Boot to that and test your drive, if it passes, format your drive with that software. If you have a big disk pay attention to the advanced format options.

Now try to reinstall Vista. Preferably with AHCI set in the BIOS.

If that fails, hunt down the boot SATA drivers from your computer, or mainboard manufacturer and when installing Vista at the hard drive select windows, add new drivers there.

Let me know how it goes.


Report •

#2
April 8, 2012 at 08:06:19
It's a Western Digital 250 gig and a Dell Vostro 220s. I'll try the BIOS and see what happens. Thanks

Report •

#3
April 8, 2012 at 09:14:20
Tried changing to RAID (didn't have a Legacy or IDE setting available) can get to set up but all space is unallocated and when I tried to repartition came up with error 0x80042453, which appears to be a motherboard error. But, when I put in the WD boot disk, it finds no hard drive. BIOS still sees it, Vista installer sees it, but cannot write to it. Beginning to have a bit more sympathy for Staples but then I am a veritable newbie to all this and they supposedly know what they are doing.

Report •

Related Solutions

#4
April 8, 2012 at 14:44:56
It's a Dell, okay this is good information.

Go into your BIOS and set defaults then save.

Turn on the computer and tap f12 and select diagnostics,

now test the drive there.


Report •

#5
April 10, 2012 at 03:47:16
It didn't get past the quick test, came back with an IRQ not responding error. I have noticed though that in spite of all the free space listed, when I can get properties on the drive it says no space available. Not that I can get it to clear or reformat.

Report •

#6
April 10, 2012 at 04:20:31
If the test failed it should have given you an error code. That would be helpful, Thanks

Although I am starting to think that there is a mainboard problem.

Just for a test, could you remove the SATA cable form your optical drive and use that on your hard drive and do the test again?


Report •

#7
April 10, 2012 at 16:47:32
This time running the pre-boot diagnostics, it never even passed the DST short test. I was going to try a new SATA cable but wasn't able to get one today, that might be tomorrow's project. Almost afraid to take it from the optical drive, but then in boot it is running off the system board anyway, right? I can always connect it back up the other way and start again.

Report •

#8
April 10, 2012 at 23:49:41
Yes, it will be fine to take the sata cable from the optical, but I think your hard drive is gone and it will have to be replaced if it didn't pass the DST. Sorry

Report •

#9
April 12, 2012 at 15:32:50
Thanks for all the help, I do really appreciate it. Changed out the cable and am re-running the test but like you I have a feeling the drive is gone. Ended up ordering a reworked system for about the same as a new motherboard anyway... but I learned a lot in the meantime.

Report •

#10
April 14, 2012 at 04:30:59
Gretti - if you are still around. I got a hard disk converter to plug the original one up in. Plugged in it shows on the system devices of another computer but all as unallocated and I can't seem to access it do anything with it. Would that seem to agree with the fact that both the disk and the board are gone?

Report •

#11
April 14, 2012 at 14:28:44
This is the disk that failed the DST on your Dell? It is showing as unallocated most likely because you have bad blocks on the front of the drive. So most likely your MBR is corrupted.

Are you trying to recover data from the original drive?

Anyway, you should be able to just buy a new drive and put it into your Dell and reload windows. I don't think that your mainboard is bad, it has to be the drive because it was the only thing that failed your tests. But you have just replaced the system already right?


Report •

#12
April 14, 2012 at 19:38:47
I think you are right about the front end of the disk, I finally got it formatted (gave up the idea of the data a long time ago unfortunately) and when I did a reformat of the 239000 some odd unallocated space, 71000 still shows as used but cannot be accessed. I hadn't bought a new disk because Staples supposedly put two in and neither worked. Not to mention I am having a hard time getting it to start up, lose power perhaps? haven't been able to figure out which connection is not working there. It just seems like if I could finally reformat it as a removable drive, I should have been able to reformat in its original machine, shouldn't I? And yes, I have replaced it, but I hate giving up before I find an answer anyway.

Report •

Ask Question