Does CD-RW drive allow burning in safe mode?

March 10, 2011 at 11:59:47
Specs: Windows Vista
I have an Inspiron 1720 with Vista 32 bit Home Premium.
Laptop freezes with app crash .. corrupted profile .. in normal mode and check disk appears frequently on startup.
But I have got it to work in safe mode + networking.
I have created extra user profiles with admin rights.
I have no restore point to fall back to so I have to attempt to repair using Vista OS .. or worst case scenario to do clean reinstall.

I am backing up important files to USB drive.

My problem is I cannot read or format any CD when in Vista safe mode to create a recovery disk.
Is this normal in Vista safe mode?
I have a Vista OS CD at hand.
But I cannot get the CR-RW drive to burn disks or read disks when booting up..

I can see CD-ROM in Device Manager

Device Manager >> DVD/CD-ROM drives

Update Driver Software

"The best driver software for your device is already installed.
Windows has determined the driver software for your device is up to date".

How can I further test the CD-RW drive in Vista safe mode so that I can burn disks?

See More: Does CD-RW drive allow burning in safe mode?

March 10, 2011 at 15:18:13
I have a long shot for you. I had to install a program on a PC but the CD Drive was no good, so I shared the CD Drive from another PC & did the install that way.

See if that works for burning. As I said it's a long shot but worth a try.

How do you know when a politician is lying? His mouth is moving.

Report •

March 11, 2011 at 12:47:54
Thanks for the suggestion but I don't have another working laptop.

So I took the step of buying a new CD-RW drive to connect via USB port.

I installed cdburner from

and I could see both CD-RD drives the external drive being seen as ..


Note: I had to edit the manufacturer's name because it was censored as S*** !

However I could still not burn an iso file on the new external drive.

I tried to add Vista_Recovery_Disc.iso onto a brand new maxell cd-rw 80 700 MB disk
compatible 1x 2x and 4x

The message came up.

Required: Writable disc
Present: Not writable - no disk

So neither of my cd-rw drives can recognise an inserted brand new unformatted CD disk.

Nor do I see any format option in the CD drive.


I did find a tip to hack the registry to allow CD burning in safe mode so it does appear that burning is disabled in safe mode.


value name: NoCDBurning
Value data: 0


value name: NoCDBurning
Value data: 0

but this does not work for me.


I also read this thread .. booting from USB ..

but then I read that this only works with Retail version of Vista .. not Home Premium.


My next approach will be to try to put the Vista recovery image on an external bootable disk via USB.

Report •

March 11, 2011 at 15:41:25
What a horror! You shouldn't have to go through all that. Does the new drive see any CD at all? Try another brand CD. I've seen that happen before.

How do you know when a politician is lying? His mouth is moving.

Report •

Related Solutions

March 12, 2011 at 02:01:55
Neither of the CD drives (internal or new external drive) see any disks inserted. I've just tried putting in an old disk and the contents are not seen.

I can format a USB drive and access files from there.

I do know that my registry is really screwed up since I've tried RegistryBooster and it shows hundreds of errors so I have to get into a position to repair all this.

But I can't burn a recovery disk or use system restore.

It seems that my only hope now to try to reinstall Vista Home Premium on a fresh internal disk and attach my corrupted disk as external device to recover data.

Report •

March 12, 2011 at 06:19:35
There maybe a recovery partition F10 or F11, I forget which, if worse comes to worst.

How do you know when a politician is lying? His mouth is moving.

Report •

March 12, 2011 at 07:56:50

Report •

March 13, 2011 at 14:36:02
F10 shows these System Recovery Options.

> Startup Repair - says that there is nothing wrong

> System Restore - but I have no Restore Point (a hard lesson learned)

> System Restore - but I have no backup image (another lesson learned)

> Windows Complete System Restore

> Windows Memory Diagnostic Tool

> Command Prompt

> Dell Factory Image Restore - which would wipe all my data but at least start with a fresh image


None of these options was appropriate so I took the plunge and installed Ubuntu windows installer which writes into c:\Ubuntu.

I launched Ubuntu but noticed that if I didn't press Esc quickly enough (6 seconds timeout) into a menu a full installation starts. I stopped it quickly by turning off power but not soon enough to see that I could no longer boot in safe mode.

It seems (from Ubuntu forums) that this is a problem dual booting with Ubuntu 10.10. on a shared partition since the MBR is overwritten.

However the good news is that if I quickly press Esc at the Ubuntu boot (two boots are shown, Vista and Ubuntu) I can select Ubuntu Demo mode get access to the file structure and the Internet. I'm sending this in Ubuntu mode.

I'm currently using Ubuntu to tidy up and back up my files onto a USB drive and then I'll progress to having dual boot, Ubuntu and Vista, in separate partitions rather than shared partition (as now).

If I shut down and try to logon to Vista in safe mode I get to the point where drivers are being loaded and then a blank screen shows. I'm hoping that the few seconds I had Ubuntu installing before I shut it down will not have caused too much harm.

So run in Demo mode before the full installation !!

Here is the Ubuntu world .. I'm new at using Linux but learning.

Report •

March 13, 2011 at 14:51:52
There is really no such thing as c:\ubuntu. If Ubuntu writes to C:, windows system files would be overwritten. If you can still see some of your personal files, Ubuntu is running as a Live CD, which is fine.

To have a true dual boot, the drive has to be partitioned first using Gparted or something similar. I don't bother with dual boot anymore. I prefer to have separate machines for each OS.

How do you know when a politician is lying? His mouth is moving.

Report •

March 14, 2011 at 03:55:39
Just to clarify .. since in Vista I could not get any media to be recognised in either my internal or (new) external CD-RW drive .. in a moment when I did have Vista working in safe mode + networking I downloaded and installed ...

I could not burn any Ubuntu Live CD so this was installed on the fly in Windows safe mode while I had the chance.

On starting up Ubuntu (in demo mode to avoid full installation of Ubuntu and a fear of wiping my entire partition) I could inspect File System

/usr/isodevice/ contains all of my original c:\ files.

And in c:\Ubuntu (size 17.3 GB) is

folder disks
folder install
folder winboot

So I take it this is the virtual disk for Ubunto within Vista.

This setup is temporary until I can get Vista recovered. Then I will have Ubuntu on a bootable external drive and Vista in bootable internal drive. I don't have several laptops. It seems a useful option however to be able to switch between Vista and Ubuntu and aim to have shared file system in another partition.

Report •

March 14, 2011 at 05:34:37
If Ubuntu can see your files in Vista, copy them to a USB flash drive (it should see that too) & do a clean install. I think that's your last chance.

How do you know when a politician is lying? His mouth is moving.

Report •

March 17, 2011 at 03:54:28

I can report that I've got my external (USB port) CD-RW drive to work and .. in Ubuntu .. to burn a Vista_Recovery_Disk.iso.

I read that these devices are very sensitive to power supply and I was trying to use this brand new device through two ports in a USB port expander with other USB ports in use. In that mode the drive could be seen by Ubuntu but any inserted disk was not recognised.

I unplugged from the USB port expander and plugged directly into two USB ports (two are required for this device, one for data the other for power) and I booted up Ubuntu again (dual boot mode). My CD disk was now seen and I could burn the recovery disk .. which I have yet to try.

Returning to the crashed Vista my internal CD drive still refuses to recognise inserted disks. I have an alert message that my battery life has reached its limit and I'm wondering if my internal CD-RW drive is equally sensitive to power supply. I'll experiment with another power supply and perhaps remove the battery to see if I can get the internal device to work.

Meanwhile I'll try to recover Vista now that I have a recovery disk.

This message is sent from Ubuntu.

Report •

Ask Question