delete '' file from desktop

Dell / Inspiron 1720 laptop
August 12, 2009 at 13:58:33
Specs: 64-bit Vista Ultimate , 2.5 ghz/ 4 GB
Ok ... I have a solved this problem under XP 32-bit, but am stuck as far as XP/Vista 64-bit is concerned, since I dual-boot with XP 32-bit and Vista Ultimate 64-bit

Solution under XP 32-bit >>> Download and install a utility called 'Unlocker' (latest version 1.8.7) from

Select the problem files on the desktop, right-click and select 'unlocker' option from the menu. You will be asked what action you want to take; just select 'delete' and OK. Problem solved!

Unfortunately, the same can't be done under 64-bit, 'cos 'Unlocker' does not come in a 64 bit version. There is another utility called 'LockHunter' which is available in both 32-bit and 64-bit versions. Using LockHunter in Vista 64-bit (as far as this particular problem is concerned), all I can do is right-click and select "What is locking this file?" to see the obvious. There are further options under this, but in this case they are grayed out with a message that says "there are no processes locking this file or folders" ... so I can't take any action to get rid of the files.

These problem files only come when getting torrent files (trackers), which I think originate from site.

Btw, using the command prompt (even booting in Safe Mode or administrator mode) as I have seen someone suggest does not work ... it's the first action I tried by myself without any reference whatsoever (as I have intermediate knowledge of PCs, commands and processes; you can say I'm IT-savvy) when the problem first cropped up

Does any one have a solution to this under 64-bit?
Any help much appreciated.

10x in advance.

See More: delete file from desktop

Report •

August 12, 2009 at 14:52:01
64 bit or 32 it matters not to command prompt as instructions must follow dos command , file length , file name max 8 characters , file type 3 . Try this
When you try to delete or rename a file/folder, you may receive a window that says:
"Item not found. Could not find this item. This is no longer located in [folder]. Verify the item's location and try again."

To solve, follow these steps:
1. Open up a command prompt (run cmd.exe from the Start Menu).
2. Navigate to the folder that the object resides in.
3. Run "dir /a /x /p" to display the contents of the folder, including hidden files (/a) and 8.3 filenames (/x).
4. Find the 8.3 filename of the object to the left of the regular, long filename.
5. Run "ren <8.3 name>" to rename the object, "del <8.3 name>" to delete it if it's a file and "rd /s <8.3 name>" to delete it if it's a folder.
Note: If renaming to a long filename, make sure to enclose the long filename in quotations. If that fails, temporarily rename it to an 8.3 name and then rename it to what you want outside of the command prompt.

Report •

August 12, 2009 at 15:23:40
Woohooo! It worked .... 10x again.

Report •

August 12, 2009 at 17:33:03
Pleased to hear it , Thank for getting back , it does help others .

Report •

Related Solutions

August 30, 2009 at 17:59:56

I have been at the same site.

I don´t understand what I´m doing wrong, when trying this commando?

I get the error " wrong commando syntax ".

I´m using Vista home premium, x64.

I tryed use "del", but it says it can´t find it..

Report •

September 1, 2009 at 01:06:06
hi wedajm .. you should have some basic knowledge of DOS commands ... no matter. Try this...
In Vista,

Start > Run > type 'cmd' and hit 'Enter'

It should open the command prompt window showing the directory you are currently in, usually (drive):\Documents and settings\(Your Username)>

At the command prompt, type 'cd desktop' and hit Enter

Next type 'del *.tor' and hit Enter

If there were any problem files, they will get deleted permanently. You can then type 'exit' to get out of the command prompt window and back to the Vista desktop.

If this does not work, then as JackFrost46 said, you will need to check if the problem files have 'read only / hidden / system attributes' AND/OR 'do not conform to DOSes 8.3 format', in which case, you can follow those instructions to check/remove the attributes and rename the files to conform to 8.3 format. Then follow the steps in this post to delete them.

To check for 8.3 format, type 'dir /a /x /p'. Locate the file and use 'del' command to delete the file using it's listed corresponding 8.3 filename.

To remove read only/ system /hidden attributes, use 'attrib -a -s -h (entire filename with extension)'

To rename file type 'ren (include entire filename with extension here) (include new filename here)

Note : new filename must be in 8.3 format, i.e. for example ... original filename --> somethingsomethingsomething.something

rename to ---> newname1.tor

You will have to do this for each prblem file and then 'del newname1.tor' OR 'del *.tor' for multiple files.

In case of files, it is usually sufficient to use 'del *.tor' (as long as they have a listed 8.3 format name) as they don't have any attributes that need to be removed.


Report •

September 1, 2009 at 03:34:05
" To remove read only/ system /hidden attributes, use 'attrib -a -s -h (entire filename with extension)' "



Report •

October 6, 2009 at 22:41:48
Hey guys, someone finally solved this annoyance.

In the command prompt, from the directory that the "undeleteable" file is stuck in, try this command:

del [insert start of filename here]* <---wildcard

The trick was that the file ends with a space which makes it hard for windows to deal with for some reason. Try this, it definitely works. I was stuck with one of those [] files and...

del []*

...worked for me!!!

Report •

Ask Question