Cant delete folder which contain another one

November 6, 2010 at 11:04:13
Specs: Windows Vista, core2duo 2gb ram
heres a strange problem. i having windows vista. problem i m facing is sometimes there are folders on my drive wich i cant delete. it is completely random wich folder dont get deleted. but the common thing between those folders is that ther contain atleast one more folder inside them. I keep getting the error msg "you need permission to delete this folder (with try again and cancel buttons)". i am the only user of computer and administrator.

what i do then is, i keep going inside the folders until i reach a folder that does not contain any other folder (it may contain files). i can delete that folder. it gets deleted. then i move one level up. then delete the parent folder and it gets deleted. and i carry on till i reach the top most folder which i wanted to delete .. and now it gets deleted easily ... what is this problem ?? its making me go crazy beacuse sometime a folder contain upto 7 level deep folders and i cant delete them. its too time consuming to delte one folder at a time in hierarchy... please help guys...

See More: Cant delete folder which contain another one

Report •

November 7, 2010 at 04:05:29
... try, with full admin rights by right-clicking on the folder and choosing
"Run as Administrator". ... then delete folder.

... Or download


... to launch an elevated "command prompt":

[press] the "Win" (flag) <key> (type) cmd

[press] <Ctrl>+<shift>+[Enter]

then hit <Alt>+<C> <keys> to confirm the elevation prompt.

... deletes all files and subfolders removes an entire folder tree (in addition to the folder itself):
rd /s /q C:\folderpath here [press enter]


... Posting is provided "AS IS" with no warranties

Report •

November 7, 2010 at 10:04:39
it does not work with "take ownership" thing. i did that already. forgot to mention. havent tried the DOS method. But is there anything wrong ? why does it happen ? and it happens randomly on any folder. it can be a folder i just created moments ago or a folder created ages ago. and ya tried "unlocker" and everything, but any file or folder inside the parent folder is not being used by any application. I want to find the root cause of this problem.
One more thing, moving shortcuts inside start meny takes a lot of time. Progress bar keeps progressing for moving just a shortcut which is 2 or 3 KB in size. I have seen that everything related to the user folders are slow in processing..

Report •
Related Solutions

Ask Question