at startup, error, then black screen

Dell Inspiron 1545 notebook
February 23, 2010 at 14:49:25
Specs: Vista 32 bit, AMD 3200+ / 2GB
After vista loading screen I get two errors:
1) WerFault - Application Error, and 2) LogonUI - Application Error.

Both have the same message that the instruction at 0x[address] referenced at 0x00000000 (error 2 has it as 0x00000001) memory could not be written.

Then Blank Black screen with cursor....

My attempt at fixing:
Tested RAM - no issues.
Vista repair startup - cannot find problems!
System restore - any earlier restore point didn't help.

I'd greatly appreciate any advise. Thank you!!

See More: at startup, error, then black screen

Report •

February 23, 2010 at 15:16:46
Test the hard drive that Windows is installed on, using the disk
maker's own diagnostic tool freely available from the websites of
all the major disk makers.

Report •

February 23, 2010 at 16:03:04
Thanks for replying.

I forgot to mention that I can access the hard drive by connecting it with a sata to usb adapter to another computer. I did that to backup the necessities. So it seems the HDD itself is working fine.

As a last resort I will restore to factory settings, but I'm hoping that someone can help me fix the issue...

Report •

February 23, 2010 at 16:54:20

I'd like to report how I fixed it in case anyone else runs into the same (or similar) issue. Problem is, I don't know which of my experiments actually fixed it, so I'll write everything I tried.

After system restore and startup repair didn't help, I did this: In Vista repair I ran the command prompt.

Type cd c:\
Type c:

Type Notepad. File> Open. Navigate to C:\Windows\System32\winevt, rename Logs to Logs_bad. Right-click> New folder. Name it Logs.

You can insert a USB stick and copy the Logs_bad folder to be analyzed on another computer (which I did but found nothing relevant).

Eventually I restarted the comp and came to a screen saying it needs to run Startup repair, so I let it run again. But unlike other times when it took a second and told me it couldn't find any problems, this time it took some time then showed "attempting repairs", took about 5-7 minutes... restarted and it just WORKED!


Other things to try:
1. Press Ctrl+alt+del or Ctrl+alt+esc, and if Task Manager comes up try to run Explorer.exe

2. Press shift 5 times, and if the sticky keys dialogue comes up, click on the link and see if you can get to explorer somehow.

3. see here for more suggestions.

Report •
Related Solutions

Ask Question