Solved asrock Motherboard not working

April 8, 2013 at 06:29:14
Specs: Windows Vista
Asrock Mo Bo P43DE was working with 2gig ram, since adding extra 2 x 512 gig ram i only got 3 Beeps and no display on screen, fans etc are working, i have taken out the extra ram and checked all connections still no display, although not getting beeps.

See More: asrock Motherboard not working

Report •

April 8, 2013 at 12:10:26
3 beeps was caused by bad or incompatible RAM, as you probably already guessed.

The display problem: If the graphics chip was faulty you would get a beep error code, so it's not that.

Since you aren't getting a beep error code, my guess is either the monitor VGA cable or the monitor itself is faulty, neither of which would trigger a beep error code because they are external components which the BIOS does not monitor.

One last thought - check that power is actually getting to the monitor. The fuse may have blown in the plug on the power supply cable.

Report •

April 8, 2013 at 15:38:26
✔ Best Answer
If your computer was working fine before you installed the ram, I would make sure that the original ram is seated correctly. So don't use any of the new ram, just the old ram. Take out the ram, make sure that the slots are clean and clear of dust, and install just one stick at a time.

Also, if the new ram caused an error, you may have to clear the BIOS to get the board to recognize your old ram.

Report •

April 15, 2013 at 23:52:56
i have decided that this would be the best time to upgrade my system but thanks for the suggestion.

Report •

Related Solutions

April 15, 2013 at 23:57:17
i decided that this would be the best time to upgrade my system,thanks for the suggestion

Report •

Ask Question