Solved Unreadable Files: Two Different Windows OS's

June 12, 2012 at 00:04:53
Specs: Windows XP, 1.8 CPU/ 512 RAM
I was running W98. I put 20 Gigs of information on the hard drive. I copied some of these files to a disk. I deleted W98, and completely removed the Windows folder and did not do an "upgrade" install with another operating system. Then I did a fresh install of ME. Immediately after the install, all of the 20 Gigs on the hd showed up as, "DF*GHU@J%@#!@FG". Would switching OS's cause this to happen? That is pretty inconvenient if it does.

If I am running ME and I insert the W98 info disk, can it be read? If I am running XP, can it be read?

The main question is: can information from one Windows OS be able to be read by another Windows OS, via by disk or by being on the same hd?

Captain Kirk
USS Enterprise

See More: Unreadable Files: Two Different Windows OSs

✔ Best Answer
June 16, 2012 at 04:07:24
Files are not NTFS or FAT32 there are just data, and they are stored on a storage medium as Binary.

The file system is NTFS or FAT32.

Windows XP can read NTFS, FAT32, FAT16 (4GB) and FAT12 file systems

Windows 9x/ME can read FAT32, FAT16 (2GB) and FAT12 file systems

Googling is quicker than waiting for an answer....

June 12, 2012 at 13:20:57
"I deleted W98, and completely removed the Windows folder"

I'm not sure what that means? To go from Win98 to WinME, you either need to perform an in place upgrade or wipe Win98 & install WinME from scratch.

Report •

June 12, 2012 at 21:13:48
Hello riider,

yep, that's what I did, I installed ME from scratch.

Anyways, got any ideas about the question?

Captain Kirk
USS Enterprise

Report •

June 12, 2012 at 21:50:41
Where did you copy the files to--the OS hard drive, a different hard drive or somewhere else?

What size hard drive(s) are you using? How were they partitioned?

Report •

Related Solutions

June 13, 2012 at 09:23:09
"yep, that's what I did, I installed ME from scratch"

OK, just to clarify - that means you booted off the WinME disk, deleted partitions, created new partitions, formatted using FAT32, then installed WinME. Next step would be to install all the necessary drivers & security software, then run Windows Update. Would that be right? That will give you a fully updated fresh installation which you can then tweak before installing any additional software. The biggest tweak you can do is to disable System Restore & NEVER enable it again! Black Viper is the go-to guy when it comes to Windows tweaks - the only one I disagree with is #4. I suggest you leave the paging file alone & just let Windows handle it:

As for your problems reading the 20GB of files, we need to know where they are - external HDD, separate internal HDD, or a separate partition on the primary HDD? If it's an external HDD, it would have to have been formatted using FAT32 for Win9x/ME to be able to read it. Win9x/ME cannot read NTFS. However, XP is able to read both FAT32 & NTFS. If you're getting funky characters in the file names, it's either infected or the data is corrupt.

Report •

June 14, 2012 at 22:36:42
Hey DAVE IN CAPS, good to see you, or rather, in this case, good to hear from you!!
Hello Riider,

Riider, I just reread your last reply and that's not what I meant. But it would've slipped past me if DAVE IN CAPS hadn't noticed it. To clarify, what I meant was I "reinstalled" from scratch, but did not 'format' that hd. I left the partition the way that it was. I did not add any parititions. There is one partition. I am using a desktop with an internal hd. Before I put the 20 Gigs on info on the hd, I formated the hd with FAT32, then I installed W98 and added 20 Gigs of info. The 20 Gigs of info was on the hd "before" and "after" the deleting of W98 and the installing of ME. Just after I installed ME, it gave me some message about, "do you want to convert it?," and I said "no" because I didn't think that I needed to, as I had never encountered that sort of strange thing before. And now I don't know "how" to convert it -- if it is possible.

But its possible the problem may stem from FAT32 versus NTFS file format issue. There "is" a possibility that I didn't in fact actually 'delete' the entire windows folder, and that I did do an upgrade, which required me to use the NTFS file format system when the original hd was set up as FAT32. But you don't think that if you were to an a hd, so that you had two hd's one with FAT32, and the other with NTFS, that this would cause that sort of problem do you?

DAVE IN CAPS, I didn't "copy" the files to anywhere, they stayed on the hd. The files were always in the same spot -- only the OS changed! There is only 1 partition. It is a 60 Gig hd.

Captain Kirk
USS Enterprise

Report •

June 15, 2012 at 00:10:50
NTFS wouldn't be a factor since neither 98 or ME can use it.

The only conversion I can think of that may apply is when scandisk asks if you want to convert lost chains to files. But scandisk usually will run prior to the OS installation and you said the conversion question came after the install. But if that was it then the files are pretty much gone. Lost chains are just pieces of files that the OS doesn't know how to put back together

I don't know, maybe there's some other 'conversion' that ME might do with files written under 98 but I can't think of any. What kind of files were they--what file extensions? Do the file names show correctly and their contents are gibberish or are their names wrong too, or not even there?

Did the drive have a bios/drive overlay on it or did you change the way it was identified in cmos/bios setup?

Occasionally I've had stuff on a hard drive and then installed an OS but never had any problems like that. It should have gone OK unless there was a problem with the FAT resulting in lost chains or cross linked files.

Edit Run scandisk and see if it finds any problems. If it asks about converting lost chains to files answer NO. If recovery is possible (and I doubt it) then it's probably best not to convert them to files.

Report •

June 16, 2012 at 00:38:12
One hd was W98. What if I had added a second hd, and THEN installed XP on it under the NTFS file format: would that cause the 20 Gigs of scrambled effect? The files were just normal files, like the sort of files that you'd expect after installing about 20 video games plus a couple of other programs. All the names of the files were scrambled, and I could not open ANY files, as it wouldn't recognize any files. I got the impression that it was a FAT32 and NTFS issue, but I'm not sure. The bios/drive overlay and cmos/bios setup did not change -- it stayed the same; I did not go into the bios and change anything and I did not take out the CMOS battery.

By the way, what would happen if you were running XP NTFS and you copied files to the hard drive from a second hd that was a FAT32, meaning that the files were FAT32 files? Would XP be able to read the FAT32 files?

Captain Kirk
USS Enterprise

Report •

June 16, 2012 at 04:07:24
✔ Best Answer
Files are not NTFS or FAT32 there are just data, and they are stored on a storage medium as Binary.

The file system is NTFS or FAT32.

Windows XP can read NTFS, FAT32, FAT16 (4GB) and FAT12 file systems

Windows 9x/ME can read FAT32, FAT16 (2GB) and FAT12 file systems

Googling is quicker than waiting for an answer....

Report •

June 16, 2012 at 15:04:03
Yeah, XP on a separate drive wouldn't affect them either.

It seems most likely the files were corrupted, cross-linked or lost due to a problem with the drives file allocation tables (FAT) during the upgrade or possibly before. If you copied the files and didn't access them prior to installing ME you wouldn't have known if the problem happened before or after the install.

Report •

June 16, 2012 at 22:58:21
"It seems most likely the files were corrupted..."

It seems like it is damaged, so I tried to fix it and formatted my hard drive. But now when I boot the computer, I get a, "A Disk Read Error Has Occurred. Press CTRL + ALT + Del to Restart" along with a black screen. I have put XP in the drive and booted. I have put Knoppix in the drive and booted. And I have booted 12 times. Every time that I boot, I get the same message.

When I get the error message, colored dots with letters that don't appear on the keyboard in the middle of the dots appears. There are two diagonal lines on the screen. Every time that I boot, there is always the same two rows pattern of dots.
One time, everytime that I booted, there were three green dots, 2 blue dots, and 1 gray dot. The symbols in the middle of the colored dots were, 1) a 90 degree "L", 2) an o with a ` above it, 3) an e with a ` above it, 4) a circle with an arrow out of the top, 5) a ".", 6) and a upside down h. There are a total of 7 dots. 5 dots are blinking.

Then I unplugged the power cord, pressed the power button for 10 seconds, waited 30 seconds, plugged the power cord back in and rebooted. Now this time when I rebooted, I got seven dots in two rows that were all in green, and that had the 90 degree angle "L" symbol in the middle of them. 5 dots were blinking. Now, everytime that I rebooted, I got this same color of 7 dots and all the same symbols in the middle of them.

What do I do? I'm drastically stuck here!!!!!!!!!!!!!!!!!!!

Captain Kirk

Report •

June 17, 2012 at 00:18:17
The weird figures might be a problem with the video adapter or perhaps a corrupted bios but I think most likely the video adapter. If it's a video card remove it and reinstall it, making sure it's completely in the slot. (Do that with the power cord removed.) If that doesn't help try another card. It doesn't have to be anything fancy for testing purposes. If it's an on-board adapter try adding a card and see if the weirdness goes away.

The read error usually means corrupted system files and/or bad spots on the hard drive where the system files are located. But if it's been formatted and is now blank I'd expect an 'operating system not found' message or something similar if it's attempting to boot from the hard drive. If you're actually booting from a cd and getting that message then there may be a problem with the cdrom. Check that its data cable is tightly connected and in good condition. Make sure the cdrom is the first device in the boot order in cmos/bios setup.

How did you get it formatted if you're having problems booting from a cd? Did you use a floppy bootdisk?

Report •

June 17, 2012 at 11:00:59
"To clarify, what I meant was I "reinstalled" from scratch, but did not 'format' that hd"

If you didn't format, you didn't reinstall from scratch. I don't know why you did what you did, but you made a complete mess of things.

What you need to do now is get that 20GB of data off the HDD & onto an external drive, that way you can completely wipe the HDD, create 2 partitions (one for the OS & the other for storage), then install WinME from scratch. Do NOT install Win98 1st - even if you have the WinME Upgrade disc - it's totally unnecessary. Since you have a 60GB HDD, I recommend 20GB for the OS & the remainder for storage. Use the WinME boot floppy to run FDISK to partition & format the HDD. If you have the WinME Upgrade disc, boot off it & begin the install, at some point along the way, you will be prompted to insert the Win98 disc as proof of ownership. The setup program will confirm that you have the 98 disc & will then prompt you to re-insert the WinME disc - the installation will then continue.

There is no easy way out of this mess. If you attempt to keep your system as it is, you will continue to have nothing but problems. Wipe the slate clean & start over. You MUST delete the partitions, create new partitions, format them, & rebuild the master boot record (run FDISK /MBR from the DOS prompt). And after WinME is installed, make sure to follow the Black Viper tweaks I linked to in an earlier response.

EDIT: I didn't read all the responses. It looks like you have other problems now - corrupt BIOS or bad graphics. Temporarily unplug both the power & data cables from the HDD & concentrate on those problems. You don't need a HDD to troubleshoot BIOS or graphics issues.

Report •

June 18, 2012 at 00:49:20
Is there any way that I can get an "upgraded" bios version, one that will actually help or possibly be beneficial. This Bios seems "extremely" limited, in fact maybe even "the" most limited bios that I have ever seen. Is there a bios that is better and that may actually help me?

It is a laptop with an onboard video chip that is built into the mboard, so there is no PCI, PCI Express, or AGP slot to plug it into. Not to mention, since it is a laptop there are no "slots" to plug stuff into. This is a slight set back for laptops, I know, which I don't even like myself: I'd rather have a desktop like I used to have before, but what I'm stuck with is a laptop!!! Therefore I can't test another card. But if my 2.4 Gig desktop hadn't gotten a power surge and been "fried", maybe those power strips that say that they are "surge protectors" are a good thing -- I'm just now starting to realize this...then I might have had the extra hardware in parts laying around to test it.

In the bios, I set it to boot order 1: boot from CD. I pulled the hd out, put it into an external drive case and hooked it to a second computer. I did not use a floppy 5.2 boot disk like a "startup disk" or a CD, though I'm starting to realize that I should have done so with XP CD. I would have gone a whole lot easoer. I think XP is better than W98 or ME. I formatted in the DOS prompt. I'm still trying to figure out what's better, to format in the Dos Prompt, or to right click on the drive itself inside of windows and select the "format" option?

riider, the 20 gigs of info is gone. I completely formatted the hd in the DOS prompt inside of windows because I don't know how to do it with the laptop: with the desktop, I can't get to the dos prompt from a "fresh boot". If you know enough about computers, you will "know" what that means -- a "fresh boot". Do you know how to do this with a laptop? But if you have a laptop, you may not have heard that, or if your only familiar with the newer systems? I have 1 partition, although I was seriously considering creating two just in case this sort of thing happened again. riider, If I've already formatted the hd do you think that I should still Fdisk it -- would it make a difference or do anything? I also have the XP disk and plan on installed it instead so that I don't get the errors of W98 or ME. If I format, will I recreate the MBR?

p.s. riider, it is an onboard video chip that is built into the mboard. You say that it might be a Bios error. I pressed F10 and was successfully was "able" to go into the bios. Does that mean anything. But your right riider, it does sound like it might have something to do with the video chip part...

Captain Kirk

Report •

June 18, 2012 at 03:11:27
If you want to install XP all retail CD's are bootable and during install it will allow the partitioning & formatting of the hard drive, no MS-DOS required or needed, as XP has no MS-DOS........

Googling is quicker than waiting for an answer....

Report •

June 18, 2012 at 10:23:00
"It is a laptop"

You waited until the 13th response to tell us your problems are with a laptop? And didn't even bother to list the make/model or specs? Nice.

"if you have a laptop, you may not have heard that, or if your only familiar with the newer systems?"

I've been around the block a few times. I've been working with computers since the waning days of Windows 3.1. All you needed to do was create a bootable CD to partition & format your HDD. I'm sure the HDD manufacturer has software available or you could have created an UBCD. If you had explained more clearly from the start, we wouldn't have wasted our time trying to explain things that don't apply to your situation.

Report •

June 18, 2012 at 19:06:03
Manufacturer: Compaq Evo
Notebook Model: N610c
Processor Type: Mobile Intel Pentium 4-M CPU 2

I didn't know that it made a difference between having a laptop or desktop, or I would have told you. But I do know that a desktop is a lot easier to use and that you can get to the DOS prompt from a fresh boot. Do you know how to get to the DOS prompt from a "Fresh Boot" on a laptop? If so, it would really help me to fix this!!!

I don't see how telling you make and model that this can help anything. You only need to know these things if your going to get drivers...

riider, I have the UBCD, but as of yet, I still have NOT been able to use it. And now I also have the new UBCD 5.1, which I haven't looked at yet. I want to figure out how to use the clone program on it. But at this point, just being able to use ANY of them is good. If the "software" that you are referring to by the manufacturer is the "Utility Disk", then I have heard of them, but do not have once or have ever used one. A "Utility Disk", among other things, seems to be an upgraded version of a scan disk or something.

How do I create a bootable CD, and what does this contain -- is it a program, or a certain kind of software, or is it made from the computer or OS somehow? Why would I want to partition my hd. I only have one partition. I might create a second partition to install two OS's on the same hd so that I don't run into this problem again. Now I just have to figure out HOW to do that AND in what order. I have already formatted my hd, so I don't need to do that again. That process is completed. Now on to the next step.

You can get to the DOS prompt "inside" of windows. This is how you do it:
1) Start button at bottom of screen
2) All programs
3) Accessories
4) Command Prompt

Jolicloud, you are right that I would be ABLE to fix the problem if I simply put the XP CD in the drive. If only it was that easy!!! This is what is happening:
When I boot the computer with the XP CD in the CD tray, this is the error message that I get on the screen -- "A Disk Read Error has Occurred. Press CTRL+ALT+DEL to restart", along with 7 colored dots arranged in the same order and design every time, in two diagonal lines, and the dots have letters and symbols that don't appear on the keyboard inside of the dots; and five of the dots are blinking. Summary: I cannot boot with the CD.

Captain Kirk

Report •

June 18, 2012 at 21:11:29
You shouldn't have been able to format the OS drive while the OS was running on it. But I guess you did.

You mentioned you were getting the read error with several different bootable cds, indicating the problem is likely with the cdrom, not the cd. But I guess it was working (maybe not booting) when you installed ME so you might want to try other bootable cds.

If there is a bios upgrade it will be on the support site for your model. But even if there is one, how will you run it if you can't boot from the cd--or do you have a floppy drive too?

Report •

June 19, 2012 at 10:35:45
"I didn't know that it made a difference between having a laptop or desktop"

It makes a huge difference. Laptop specs:

"I have the UBCD, but as of yet, I still have NOT been able to use it"

Why not? UBCD has dozens of programs on it. Partition Management software, Special FDISK or Extended FDISK, HDD installation software, etc. Any one of them could have been used to properly partition & format your drive. You're taking what should have been a simple task & making it WAY too difficult.

Report •

June 19, 2012 at 19:10:45
You CAN'T format the OS that is running "on" the hd you are trying to format; however, I took out the hd and put it into an external drive case and USB'd it another computer: there are two laptops. You might be right about the CD drive, though it WAS running just fine before I used the "create a virtual drive" program. After using this program, I was not able to use the CD drive, so, as you see, there was MORE than one reason to format the hd. But, I have formatted the hd, so it seems like this virtual drive program would not still be in effect. And, like you said, previously, I was ABLE to install the OS. So far the disks that I have put into the drive are Puppy, Fedorra, Knoppex, and XP; but there is still no response.

I am seriously considering getting the upgraded Bios version of this model because this Bios that I have is crap (very very limited); in fact, it is one of the most limited Bios's that I have ever seen in my entire life. However, at this point, I don't want to screw anything up, and the matter with the Bios program is a VERY sensitive matter. Besides, I have NEVER installed a new Bios before and so I am very cautious and hesitant. But the timing "could" be better to install such a delicate program: if the program fails, them my entire drive is ruined: the Bios is the last defense against all screw ups. I do not have a floppy drive, so it would have to be with a USB. Are you sure this is a good idea at such a crucial moment of black screenness?

What is the difference between a netbook, a notebook, and a laptop?
I just viewed the UBCD 5.1 for the first time and I have to admit, it "is" a lot easier to use than the previous version that I had. I found that I was able to run a few programs, but still could not run the vast majority of what is offered on the disk. It may sound simple to use the UBCD programs, but here is the sticking point for me, and why I can't run most of the programs: I encounter this menu. Whenever I run into the "menu", this means that I am not ABLE to run the program successfully. The "menu" is composed of the following list:
0> Boot Clean
1> Boot UMBPCI (Silent)
2> Boot UMBPCI (Optimal)
3> Boot UMBPCI (Semi Defensive)
4> Boot Emm386 (Optimal)
5> Boot Emm386 (Semi Defensive)
6> Boot no UMB (Defensive)
7> Boot no UMB (Ultra Defensive)

**No matter which one that I choose, the program doesn't run. Which one do I pick, or if I get to this point, does mean that the program won't work? Or that I have to run this program 7 times, rebooting with each try as a "trial and error" EVERY time that I want to use this program? Is this how Linux operates -- you have to guess or something, or is it one of their "handy" security features making it once again, a pain in the butt every time that you want to take a single step when your trying to walk?

Report •

June 19, 2012 at 22:40:36
A bios upgrade usually doesn't add anything significant. Often the manufacturer will tell you what issues are addressed by the upgrade. Check that and then decide if an upgrade is worthwhile. I doubt the bios is the reason the cds aren't booting but I guess it's possible in the unlikely event the bios is corrupt (as evidenced by the odd posting screen symbols). But unless you feel comfortable upgrading the bios I'd hold off until you work with the cdrom a little more. Plus, I guess you'd have to do it by creating a bootable USB stick with the upgrade files on it and that would be adding more problems for someone not familiar with the process.

Virtual drive software would have no affect on a cdrom's booting ability.

Try the cd disks in another computer and see if they boot up. If they do then you can be pretty sure the problem with the laptop is the cdrom.

Report •

June 20, 2012 at 05:35:28
"What is the difference between a netbook, a notebook, and a laptop?"

The difference between a laptop & notebook has blurred over the years. It used to be a laptop was larger & more of a desktop replacement while notebooks were a bit smaller, lighter & more portable. The terms are pretty much interchangeable these days.

A netbook is a much smaller, lower power version of a notebook. As it's name implies, it was designed with interNET surfing in mind. It usually has a much smaller screen, low power/low performance processor (such as Intel's Atom), minimal RAM, small HDD, no optical drive, & runs Linux or a stripped down version of Windows.

"this Bios that I have is crap (very very limited)"

Of course it is, it's a laptop. The BIOS is deliberately minimal to prevent too much user tampering. This cuts down on the number of support calls due to users mucking around with settings they have no clue about. Updating the BIOS isn't going to magically add additional settings.

As for problems with UBCD, you simply boot off the disc, wait for the menu to come up, then use the arrows keys to choose which program you want to run. Highlight your choice & press the Enter key, then wait. You don't have to select any of the boot options you listed - just wait & the program will eventually load.

Report •

June 20, 2012 at 18:57:04
DAVEINCAPS, my cyberbuddy friend, how's ya?
I tested the XP disk on another computer and its autoboot runs just fine. Looks like the CD is okay.

So far, this is what I have done to try and solve the problem, inbetween turning it off and then back on again:

--I ran a successful scan disk: chkdsk /f; 0 KB of bad sectors
--chkdsk /r test: no errors in file system, no problems found
--I have taken out the rechargable battery
--I have unplugged the power cord and pressed the power button for 10 second, then waited 30 seconds
--I have went into the bios and switched the setting to "restore to default"
--I put the rechargable battery back in
--I have went into the bios and switched the boot order to 1: boot from CD first
--With no CD in the the CD tray
--Without the CD tray in the computer
--I reseated the CD tray
--I took out the hd and reseated it
--Attached it as a slave to another computer and formatted it
--I added the startup disk system files to the hd
--With XP in the CD tray
--With Knoppix in the CD tray
--With Fedora in the CD tray

*NOTE: There is no CMOS battery, so taking out the rechargable battery is equivolent to taking out the CMOS battery and putting it back in.

>There were no errors during the chkdsk /f, and it indicated that 0 KB are in bad sectors... I also ran a chkdsk /r test.

Good to hear from you riider,
Its kind of confusing to have the same name notebook and laptop, and to be same thing. But now I know that a netbook is something that I definitely do not want.
riider, guess I'm used to the Bios in a desktop, as you can see this Laptop Bios business is really shoddy. And in this case, with a laptop, the bios is THE most limited that it can be. Just sort of a shocker and all -- being used to the full bios in a desktop, you understand. And didn't know the technical part about how they "purposely" limited in a laptop. Almost sounds like kind of a UNuser friendly type of thing to do to someone: is that also why you can't get to a "fresh boot" in the DOS prompt with a laptop? And thanks a lot for telling me about the UBCD, it was very confusing. That helps out a lot.

Ya, I didn't really think that a new Bios would really add much, though "anything" seems like it would be better than what I got. But obviously I knew that the Bios would not have an effect upon the current issue at hand. But it is interesting that you have heard of a corrupt Bios doing something like that. I never knew that you "could" get a corrupt Bios, OR that it would do THAT. Good to know. Thanks for the idea of looking up what the difference would be on the manufacturer's site.

Report •

June 20, 2012 at 21:34:41
If it's still not booting from the cdrom and the cd disk is good (and everything is set right in cmos/bios setup) then there must be a problem with the cdrom. Can you replace it or maybe try an external one--assuming you have a boot-from-USB option?

Report •

June 21, 2012 at 21:58:12
I meant to include you in the last reply. After I submitted the reply, I realized that I had forgotten to talk to you, so this time your at the top of the page. So this is the situation: If I am successfully able to get an OS running, maybe that will help me to be able to run the files from a CD, such as another OS -- the one that I want as the permanent OS. If it is a clean format with nothing on the hd, the computer may incur an error message such as the "A Disk Read Error Occurred. Press CTRL+ALT+DEL to Restart" like it has before something was on the drive. In fact, it seems like the computer has made some progress to the situation where I am now with the "Lupu-501.sfs not found" error message, because the "disk read error" was the only thing that I was getting on the black screen.

How's is going bro? Okay, so this is what I did: the hd was in the linux ext 3 format. Then I formatted the hd to ext 2 and then installed a fresh copy of Puppy. I turned the computer off, and when I rebooted, I made sure that the files were on the hd, and that the install contained the file "Lupu-501.sfs". When I booted the computer to test out this fresh install after a clean hd wipe, the exact same thing happened!!! AND the exact same error message!!! I don't understand what is going on. Do you know anything about Linux, or what I should do in this situation.

I attached a card that has 2 USB jacks. I plugged in an external CD drive. I rebooted the computer. No light came on on the CD drive and the tray did not open: it appears that the CD drive is not getting enough juice. Plan B: I plugged in a USB hub with 2 slots. This device has a plug attached to it plugs into an outlet. I hooked it up with the CD drive attached. This time the light went on and the tray opened. I put XP into the drive. I rebooted. It went directly to Puppy and then the usual error message. I put the Linux OS Knoppex into the external CD drive and rebooted. Again, same thing. The CD drive keeps running intermittantly and continues to run for a few long seconds after the computer is turned off and seems to keep trying to run the CD. Maybe the external drive is not quite getting enough juice -- I don't know. But two external devices are being powered by one plug and the computer. I have tried using the external CD drive on another computer and it does seem to use a lot of juice, as most of time I am unable to use it, with periods of not being able to use it at all. It is a brand new CD external drive and brand new USB hub, relatively speaking, within the last year.

Oh, and DAVE, there is also one thing that I have noticed. And tell me what you think about this/know about this. Some Bios's that are on older computers, and that are only available to them (meaning that you can't upgrade to a newer one) doesn't allow the computer to be able to "see" the USB hub before the boot. However, after the OS is fully loaded, assuming that you have an OS, THEN you are able to "see" the USB (with the same bios from an older computer). I heard that newer bios's on newer computers do not have this limitation!!!

Report •

June 22, 2012 at 05:01:54
You can't boot off an external drive unless USB is a boot option in the BIOS, & of course, the boot order needs to be configured so that USB is listed before the HDD. Older systems (& your laptop is quite old) do NOT support USB booting.

"the hd was in the linux ext 3 format. Then I formatted the hd to ext 2 and then installed a fresh copy of Puppy"

You really need to explain things more clearly. How is it you're able to format when you say you can't boot off any disks? If you're doing it on another system then swapping the HDD back into the laptop, chances are it will not boot or it will lock up due to differences in the hardware configuration. If you've determined the laptop's CD/DVD drive is bad, the obvious solution is to replace the drive.

- Teac: DW-28E (E-43), P/N: 19770850-43, HP P/N: 261741-933
- Teac: DW-224E (-A43), P/N: 1977098A-43, HP P/N: 336431-930
- Toshiba: SD-R2512, HP P/N: 336431-833
- Toshiba: SD-R2512, HP P/N: 361890-833
- TSST: TS-L462, HP P/N: 361890-833

Or maybe it's just time to retire that antique & get something a little more up to date. Here's what $250 will get you:

Report •

June 22, 2012 at 21:21:53
You attached a card that had 2 USB ports? So I guess that was a PCMCIA card? That's not a 'boot froim USB' bios option. I'm not sure what you can boot with other than the cdrom and hard drive. You need to consult the manual if you're not sure.

If there is a 'boot from USB' option and you're using a hub, yeah, maybe it's causing a problem. Does the external cdrom have its own optional power supply?

If you can find a way around a probably-bad cdrom then maybe you can get something installed but otherwise you need to replace it.

Report •

June 23, 2012 at 02:56:53
Hello riider,
Yes, the bios does not have a boot from USB in the boot order selection.

Here's what I'm doing:
1> I take the hd out of the problem computer [computer #1]
2> I place the hd in an external drive case with a USB cord
3> I attach the external drive to the USB port in computer #2
4> I format the hd in the external drive case
5> I detach the USB cord from the computer #2's USB slot
6> I take the hd out of the external drive case and put it back in computer #1
7> I boot computer #1, but with no bootable files on the drive, I recieve the, "A Disk Read Error Occurred":
Apparently you need an OS on a hd so you don't get this error message!

Computer #1: Compaq
Computer #2: Dell

The 2 slot USB card doesn't immediately recognize "immediately" like a plug and play device would. Its not brand new. But on another computer, once the computer is rebooted -- then it sees the device. I don't know, maybe that is the reason. Or it is a bios issue, which I don't think so like you agreed. Or its not getting enough juice... I'm not real familiar with these type of devices. It is called a "Dynex", a "2 port USB 2.0 Card Bus Adapter", "model: DX-UC202". It does have a circular hole in the middle of the two USB slots with a prong sticking up. I have never used this and don't know what it is for. No other information appears on the card. This is how I got it -- just the card.

"Does the external cdrom have its own optional power supply?"

Hmm, interesting, I didn't think that it did, but now that I look, where I hadn't seen before, in the back, there is a 5 volt hole opening. I might be able to get the cord for it but I'm not sure if it can be found. It is my friends device, and so I am not quite sure about the exact details.

riider and DAVEINCAPS,
So this is what I have done since I talked to you:

--Since the hd was in the ext 2 format, it could not be seen by the Windows OS, and was "invisible": I never knew that!!!
--I formatted the hd to NTFS, but failed due to an error?
--I formatted the hd to FAT32
--I put most all of Bart's Computer Repair Tools on the hd, hoping at least one of them (or all) would do something or help
--I booted the computer
--Now I get the "A Disk Read Error Occurred" error message with a black screen again: guess you need an OS or the computer can't boot.
The computer can't read the drive because there are no bootable files on it, meaning, specifically, an OS; other files don't count!!!!!

::Maybe I can install an OS from a flash drive USB stick?
**It has happened before when the "create a virtual drive" program may have disabled my CD drive that when I installed Linux, and then installed Windows from there that my CD drive was enabled and functioned again like it did before. I have read that Compaq is finicky about Windows and favors Linux for some reason, but the information that I saw said that it will not even detect windows [I guess in certain instances], as this seemed to be true before I installed Linux; and that is why Linux has to be installed before Windows. Maybe this is due to the MBR or something, I'm not sure. Do you think the MBR is causing a problem? And if so, how do I fix this? Or does this only apply to situation where there is an interrupted/partial OS install?

Report •

June 23, 2012 at 07:11:50
"Apparently you need an OS on a hd so you don't get this error message!"

Of course! How do you expect to boot off a HDD that has nothing on it? You still haven't explained how you managed to install Puppy? You're pretty much wasting your time if you install the OS on the HDD while it's connected to the Dell, then swap the HDD back to the Compaq, but I think you've found that out on your own. Basically, all the stuff you've done has been a waste of time, but at least you're learning (the hard way). You need to get a CD/DVD drive working in the laptop, then you can install the OS on the HDD while the HDD is installed in the laptop. Otherwise you're just spinning your wheels. So far, they've been spinning for at least 11 days, lol.

Report •

June 24, 2012 at 00:50:29
Hello riider,

"How do you expect to boot off a HDD that has nothing on it?"

This is because, I could ALWAYS get to a DOS prompt OR a menu that can GET me to a DOS prompt with a fresh boot on a desktop. Why do you think I have been asking you how to get to a DOS prompt from a "fresh boot" (with a laptop)?

This is how I installed Puppy:
1> I took the hd out of the Compaq
2> I put the hd in an external hd case with a USB cord
3> I attached the external hd to the second computer, a Dell, via USB slot
4> I put puppy into the CD drive of the second computer
5> I loaded Puppy into RAM on the second computer
6> Inside Puppy, I selected "install"
7> I selected the "install location", the USB external drive
8> I put the hd back in the first computer (the Compaq), the original computer.

Since I have formatted the hd 4 times now, do you think this would make a difference in being able to use a program to "Undelete" my files?

Report •

June 24, 2012 at 07:44:46
"Why do you think I have been asking you how to get to a DOS prompt from a "fresh boot" (with a laptop)?"

You can't get a DOS prompt unless you have DOS installed on the HDD, or you're booting off a bootable CD or floppy that contains DOS. You also need to work on your terminology. I know what "cold boot" & "warm boot" are, but I'm not familar with "fresh boot". And I don't want to keep repeating myself, but you generally can NOT install an OS on one system (Dell), then swap the HDD into another system (Compaq). You have to install the OS while the HDD is installed in the Compaq. Fix or replace the CD/DVD drive on the Compaq so that you can install the OS the "right" way. You should be able to find a multi-bay CD/DVD drive for about $20-30. Here's one on ebay for $16.50:

Report •

June 24, 2012 at 15:48:40
To get to a dos prompt (or command prompt--they both look the same) you have to load an OS from something. No OS loading means no dos prompt. It's like asking how can you drive a car to the store when it has no gas in the tank.

If you want to install an OS on the drive via another computer don't do the actual installation on the other computer. For dos, 9X and ME and maybe linux you SYS the drive with dos system files to make it bootable and then copy the installation files to the drive. Move the drive to the laptop. The drive will boot up and you can run the installation.

Of course you'll still have the problem with the optical drive.

Report •

June 24, 2012 at 22:10:18

Googling is quicker than waiting for an answer....

Report •

June 25, 2012 at 02:15:07
Hey you made it back. Its great to see you.
Thanks for your help!!

I didn't realize that you needed a DOS program to be able to get to the DOS prompt, I just ASSUMED that the DOS program was alread "inside" the computer. But that's the way that they should make "standard" computers, that just like the Bios that is "built in", also have the DOS prompt to be built in. I mean, doesn't this seem like a computer friendly think to do. And who are these people that make these computers? And they call themselves experts? The Purpose of making computers for the public was initially built on the IDEA of being "user friendly". ALL computers should have it. Before computers evolved to message boxes, ALL computers were able to boot into a command prompt so that you could enter computer commands with the computer language, even as far back as some of the first computers, such as the Apple ][ e. You need a place to be able to type in the computer language. It just doesn't make sense to have a computer that you can't even enter computer commands into!!! How could the manufacturer's be so stupid to not include this ability.

I am not familiar with your terminology. So when you are referring to a "cold boot", you mean that the computer has been turned off for hours? And when you are referring to a "warm boot", you mean "to reboot"? My definition of a "fresh boot" means that you have turned the computer off for 30 seconds, such that you are not rebooting.

"you generally can NOT install an OS on one system (Dell), then swap the HDD into another system (Compaq)"

I thought that might be a problem. I knew it was a problem for Windows, but another person that I talked to said that it wouldn't be a problem with Linux. And this is the OS that I did it with. Are you saying that Linux is exactly like Windows in this regard -- that hd swapping between computer models with Linux can casue an error or for the OS to not work?

Wow, DAVEINCAPS, that analogy is a really good one. Analogies really help to explain stuff when you didn't understand it before.

"with dos system files to make it bootable and then copy the installation files to the drive."

That's a great idea. Thanks a lot. That is what I am going to do. I don't have a floppy drive, but I have a start up disk folder saved on CD that I can use to copy to the hd. DAVEINCAPS, you may just have saved the day, AND fixed my computer. DAVEINCAPS, thanks for telling me how to get a DOS prompt. I appreciate that alot. I know it sounds like such a simple thing, but it just somehow slipped right passed me (W95, W98, W98 SE, and ME all had "Startup Disks", but from XP on, "Startup Disks" have been discontinued. And I have ALWAYS known how to install an OS from the DOS/COMMAND prompt, as well as to navigate though it, but now they don't have it anymore and so I am at a loss for words as to how to now go about this process. How could they do this to me: no Startup Disk? How are we supposed to function without that? Ohhh -- is that when the "autoboot" sequence started being put on the OS CDs, around the time of XP and beyond?), because I've always just used a Startup Disk to solve my problems.

I knew that with the Startup Disk, you copied the files onto the hd, and that you needed the Startup Disk for some reason to help you fix the computer, but I thought the "files" that it was saving to the hd were just system files or something so that the computer could understand the computer language commands so that you could type them in. I had ALWAYS thought that the DOS prompt had been "built" into the computer itself like the Bios until today. The DOS prompt SHOULD be built into computers and we should complain to the manufacturers about this issue. I didn't realize that the Startup Disk files were the DOS prompt program? So if all goes right, I'll have DOS now?

Here's what I've done since I've talked to you last:
--I used the "undelete" program
--Apparently, if I am using the program correctly, then the only files that I am able to recover are those before my last format?

*So the "undelete" program is only able to recover files from one format back?

Report •

June 25, 2012 at 15:43:53
Early computers were definitely not user friendly. You had to know your stuff when using them.

As far as booting to dos without a drive; many older motherboards had option ROM slots. I'm sure there were some dos ROM chips that could be installed on them. The original IBM's would boot to BASIC using a ROM chip if you didn't have a bootable drive.

You can install dos, 9X and ME on a drive and move that drive to another computer but it's sometimes a hassle. It's XP and newer OS's that don't allow that.

When moving 9X and ME drives you have to get the new drivers installed which was usually a problem because the cdrom wouldn't be recognized. Another problem with that was occasionally one computer's bios would see the drive differently than the other. Consequently it would look for the boot sector in the wrong place and the result would be the drive wouldn't boot up. That's why it's always best to partition and format the drive in the computer in which it's to be used. But you've already done all that in the other computer.

In order to SYS a drive to make it bootable you generally need to boot the computer with the OS you want copied. So with dos, 9X or ME you use one of those bootdisks. Since those OS's don't recognize external drives, the drive that needs the system files needs to be attached to a regular internal IDE port. Then do a SYS X:, where X: is the drive you want the files on. Once that's done you create a folder on the hard drive and copy the installaiton files to it. For example for 98 you'd copy everything from the WIN98 directory on the cd to the hard drive.

When you delete a file with dos/command prompt it just removes the first letter of the file name. The UNDELETE command I'm familiar with just locates those files with a missing first letter and then asks you what letter to use to reinstate the file. Once a drive has been formatted all the previous file info has been removed and so there's nothing to undelete. All that was with FAT16 partititions. It's more complicated with FAT32.

Report •

June 25, 2012 at 18:38:49
Power: Reactor Core

Engine: Hyperdrive Engines

Speed: Warp 9


Hello DAVEINCAPS, its good to hear from you,

"You can install dos, 9X and ME on a drive and move that drive to another computer..."

I didn't know that. Does this mean that the model of the two computers doesn't matter? So you would be able to switch between a Dell and a Compaq, for example?

"a problem because the cdrom wouldn't be recognized"

Yes, I remember this. This is what the mscdex01 was about?

"those OS's don't recognize external drives..."

I know that older Bios's don't recognize external drives. So your saying that in addition to the Bios, those OS's don't recognize them either? Interesting. I never knew that.

Yes, the "SYS X:" command, used as the command SYS c: for the destination to be drive c:? I have heard of this command and have tried to use it, but with no success. But now, thanks to you of course, I know how to use it: you have to have an OS in the CD drive!!! Wow, I never knew how to do that. Thanks alot. Is that command only applicable for OS's of ME and previous versions? And I didn't exactly know all that this command did, though it did hear that it somehow was used to restore your system. What would be the purpose of using this command? How could it help you? I mean, if you were ABLE to boot/use the CD drive, then why would you "need" to copy over the entire windows directory when an INSTALL would do the "exact" same thing AND complete the process. I doesn't make sense. If you are able to get to a command prompt, and you read the CD, all you have to do is type "setup" and presto alkazam, its done!!!

"Once a drive has been formatted all the previous file info has been removed and so there's nothing to undelete."

Interesting! It may have been a little confusing, because yes, there is ALSO an "undelete" command in the DOS prompt which also has a function. I knew about this command, but have never used it. But it is curious to note that a format destroys it all like the "killdisk" command in Linux. I wonder if the feature of preserving the information on the hd past the point of format has something to do with the Windows OS, but if it does, then this is a nice feature. But if not, then I can see no other explaination. Unless the program that I used has a feature that is also to look BEYOND the DOS prompt "capabilities". But since you are familiar with the "undelete" DOS command as your idea of undelete, then I will instead describe this program to you as a "hd restore/recovery program". With this program, even files that have officially been "deleted" and emptied from the recycle bin, are still on the hd, unless they have been written over by new data in the same location on the hd where the information that has been deleted is. At this point, the deleted files are permanently gone.

And I found out with this "hd restore/recovery program", that its "capabilities" only go so far as to ONE format back, meaning that if I was to format it more than one time, that the files more than two formats back can't be recovered. Maybe there is a better "hd restore/recovery program", but the one that I used has this limitation.

Do you need to load the DOS prompt program into RAM inorder to USE it, like with a floppy, USB, or CD?

Here's what I have done since I talked to you last:

--I copied the ME Startup Disk files onto the hd
--I booted the computer
--I still get the "A Disk Read Error has Occurred" error message
--I am not able to get to the DOS prompt

Report •

June 26, 2012 at 00:26:29
Sounds like the 'disk read error' is because the drive didn't have the necessary system files installed using the SYS command.

The SYS command is only for dos-based OS's--dos, 9X and ME--not NT, 2000, XP, Vista or 7. When you use the SYS command it will transfer the system files of the OS that is currently running so you have to have dos, 9X or ME running--not XP, etc. It copies and the 2 hidden system files--msdos.sys and io.sys to the hard drive to make it bootable. If those files aren't there or are not in the right place the hard drive won't boot up. When it does boot up it leaves you at the c:\> dos prompt.

Its purpose is solely to make a drive bootable to dos. In your particular case you sys the drive, copy the windows installation files to it, move it to the laptop, start up the laptop and do the installation without having a working optical drive on the laptop.

The OS doesn't have to be on a cd--it is whatever is booted up, either from the hard drive, cdrom, floppy bootdisk or external drive.

You gotta be careful using the SYS command because if you SYS the wrong drive--one with a working OS on it--it'll likely not boot into windows after that. It's probably best to temporarily remove the OS drive and swap in the drive you want to SYS. You'd need an adapter to connect a laptop drive to a desktop internal IDE port. Then boot up with a floppy bootdisk or the cd of the OS you want installed to run the SYS command.

The 'not recognizing the cdrom' when moving a hard drive is explained in my # 2 here:

It's not about MSCDEX; that's for dos. It's windows 9x or ME that won't initially see the cdrom when you move it.

Not sure about the undelete stuff you're talking about. Just know there's nothing on the drive at this point for you to recover.

Report •

June 27, 2012 at 16:31:42
In addition to what I have already told you about what the definition is for a "fresh boot", it also means this:
"Fresh Boot": Windows is not already loaded, which can be imperitive for the SUCCESS of some operations that you wish to perform. You can get to the DOS Prompt "before" windows is loaded. Getting to the DOS Prompt "after" Windows is loaded fails you in the completion of imperative tasks. Its kind of like "safe mode", except better, because you don't have to worry about Windows clogging up things for you, or getting in the way. No other programs are loaded. You can do this from a "reboot".

Howdy! How'a you's doin'?
Thanks alot for that description. This is really importaint stuff, and I think this is exactly what I need to fix this thing. Okay, so just to clarify, this is what you meant for me to do right?

NOTE: Both Laptops
1st Computer = possibly bad or disabled CD drive. "A Disk Error Occurred". No OS will load.
2nd Computer = last remaining working computer. No problems.

1> Use my 2nd computer with the 1st computer hd attached USB to an external hard drive case
2> Put ME into the CD drive (2nd computer) and perform "sys f:" command, where f = 1st computer hd
3> Copy ME disk to 1st computer hd
4> At the Dos Prompt, install ME

::So you can't substitue XP for ME in this operation, huh?
::Can this be done WITHOUT a desktop, or is a desktop required for this process?
"using the SYS command "

If you "know" what drive that you are doing, can you do it? Or does it effect things like the MBR or something? So "in" the computer that you do the "sys command" on, it will affect this current computer that you are on. And HOW do you run a computer without the hd that has the OS on it? Strategy: in the Dos Prompt, I'll check what drive that it is in with the "dir" dos prompt command to KNOW for sure which drive is the drive letter for the sys x: command.
"remove the OS drive and swap in the drive you want to SYS"

"MSCDEX; that's for dos"
That's what I'm talking about. It is a Dos command that you do "in" dos. At the dos prompt, if you also have the mscdex system file copied on the hd, if you type "mscdex001 = c:", this will allow for your computer to SEE the cdrom. This is why you needed to enter this command for ME

I have W98 and ME, but both are in storage, and so I don't have access to them right now. Looks like I am going to have to solve this problem without them. So the "sys x:" command can only be used for W98 and ME? This command can only be used on a hd while you are loaded into these OS's and are currently running them, where you booted into them; so while "in" windows (W98 or ME), you have the "target hd" attached and then do the sys x: command, as with two computers?

"temporarily remove the OS drive and swap in the drive you want to SYS"
Besides, I don't know what you meant by "swap the hd's". Because if you take the hd with the running OS on it, "out" of the computer, the computer will shut down, won't be able to run anymore, and be UNABLE to boot. I am confused -- I don't know what you meant by this. ???

I only have XP to work with here, that's why I was trying to get to the Dos Prompt.
Is it possible to get to the Dos Prompt without the 9x, W98, or ME disk; or without currently running these OS's on a second computer?

Here's what I have done since I talked to you last:
--I used "Killdisk"

"Just know there's nothing on the drive at this point for you to recover."
Well there is now. Even an "undelete" program could recover from this!!...

By the way, in that link that you provided, that kind of complicated. Never heard of the Win9x folder -- did you specially make this disk, or is this a normal disk? Why would you ask them if this is the same folder that is in your ME disk? All ME disks are the same right? I know W98 came out with W98 SE, but I've never heard about ME coming out with a second edition...

Report •

June 27, 2012 at 17:46:24
My first recommendation would be to fix/replace the optical drive on the laptop but I guess if you're not gonna do that then next best is to take the OS hard drive out of the desktop, get an adapter that allows you to connect the laptop hard drive to the desktop internal IDE port and then boot up with a 98 or ME floppy bootdisk or perhaps a 98 or ME installation cd. The do the SYS at the dos prompt.

I recommended temporarily removing the OS drive because dos OS's don't see NTFS partitions and consequently drive letters will be different. To prevent any mistakes just remove the XP drive. I recommended installing it internally instead of externally because the 98 and ME bootdisk and 98 cd won't see the external drive (without a custom built disk with dos USB drivers and we're not going to try that). The ME cd might see the external drive. I've never tried it but I kinda doubt it.

As I mentioned above you can't run SYS or transfer dos, 9X or ME system files when running XP (well it's probably possible but let's not introduce more complications) so you gotta boot from one of those OS's.

You don't have to be running 9X or ME GUI to do a SYS; it's a dos command and can be run after booting from a 9X or ME bootdisk or cd.

Last time I checked the adapters were cheap (~ $5) on ebay.

When I said to temporarily swap out the OS drive I didn't mean do that while it's running. But yeah, if you did it would shut down--might wreck the hard drive and/or motherboard as well. Shut it off and remove the power cord first.

On the 98 or ME installation cd one of the folders contains all the files needed for an installation. For 98 that folder is WIN98; for ME (at least on the disk I used) it was WIN9X. The contents of that folder are what you need to copy to the hard drive after the SYS. That is also the folder I mentioned in the link that should be copied prior to moving a working 98 or ME drive to another computer. There are other folders and files on the disk but they don't matter when doing the initial installation.

Ideally, copy the files to a similarly named folder on the hard drive so they're not cluttering up the root directory on the drive.

After using killdisk on the drive you probably have to partition (FDISK) and FORMAT it before doing the sys.

"you can't substitue XP for ME in this operation, huh?"

No, not if I understand what you mean.

"Can this be done WITHOUT a desktop, or is a desktop required for this process?
using the SYS command"

You need a computer that can boot from a floppy or cdrom drive. Apparently the only computer you have that can do that is the desktop.

Report •

June 29, 2012 at 01:51:36
--I only have XP
--I don't have a desktop
--I have 2 laptops
--I have a external hd case with a USB cord
--I have a USB flashdrive with XP on it
--My 2 laptops have a Bios that does not support USB boot

Once I format the hd and partition it, I can put the i386 folder on it. The i386 folder is probably the same as the ME Win9x and the Win98 folder for 98. XP's i386 folder contains the setup files, if that's what your referring to in these folders. There is a plan that I have, that if I copy the XP i386 folder to the hd, and IF I can get to the DOS Prompt, then I can "install" XP. Now all I have to do is figure out how to do that.

Can you get to the DOS Prompt without a CD drive or a Bios that doesn't allow a USB boot?

Report •

June 29, 2012 at 16:18:15
"Can you get to the DOS Prompt without a CD drive or a Bios that doesn't allow a USB boot?"

This is getting pathetic. DOS is an operating system. You can't get to a "DOS prompt" unless you can somehow boot into DOS. Please buy a CD/DVD drive for your laptop so we can finally put this thread to rest.

Report •

June 29, 2012 at 17:27:38
In your above posts you mentioned using a desktop in the present tense as well as installing both 98 and ME and, you know, you're in the ME forum. Now you have no desktop and apparently can only install XP.

I don't know if you can copy the XP installation files to the hard drive and install it that way. I've only done it with 9X and ME. Even if it's possible you still need to make the drive bootable.

You might be able to network the 2 computers together and get something done.

If you pursue one of those options it's probably best to ask in the XP forum.

Or fix the laptop.

Report •

June 30, 2012 at 00:36:53
I didn't realize that I was in the ME forum. I didn't think that it mattered. But in special circumstances like this, I guess I can see how one OS has a COMPLETELY different set of parameters than another for certain options, and so in this case, it can matter. I forgot that I had posted this in the ME forum. Okay, I'll be done with the thread, but before I go, I just wanted to know 1 thing:

"IF" it was possible to boot [Laptop] into the DOS Prompt without a floppy drive, a CD drive, or a Bios that doesn't support USB boot?
NOTE: [I can copy the DOS Prompt program onto the hd with the second computer]

Yes, you are quite correct. This subject was an issue that I had with a computer some years back, and I never figured out why it had happened, or, if I managed to dig out its hd or saved CD's of info, that any of it would be recoverable. I have W95, W98, and ME, and was running them as the OS at the time; however, these disks are in storage and I am not able to get them at this time. This is something that I needed to know. At the beginning of this post, I had initially "intended" to only talk about this specific idea, and then it happened --

My second computer crashed!
Black screen!!
It would not boot!!!
Then it only fully loaded into windows after 3-5 boots
My CD drive seemed to be "disabled"; sometime after running the "create a virtual drive program", maybe before the Blackout
I tried to fix this with a "format", but realize I should have used a "re-install"
Hence the "A Disk Read Error Has Occurred"
And my computer has been down for the count for two full weeks in a row

The very LAST thing that I was trying to figure out is "how" to run the DOS Prompt, AND, if it is possible to run it with the hardware limitations of this type, or rather, could it be run without any help or loading from any other hardware devices once it was saved onto the hd.

::In other words,
Can the DOS Prompt program be run [Laptop] from the hd without any hardware [drives, USB Ports]?

Report •

June 30, 2012 at 05:34:24
"Can the DOS Prompt program be run [Laptop] from the hd without any hardware [drives, USB Ports]?"

Why is this so difficult to understand? DOS is an operating system. You can't get to a "DOS prompt" unless you have DOS installed or unless you have some form of it on a bootable floppy or bootable disc AND you have the ability to boot from it !

And why do you refuse to spend the $20 to buy a CD/DVD drive? It's been almost 3 weeks since the start of this thread & so far you haven't accomplished squat. If money is an issue, you could have picked up $20 worth of cans from along side of the road by now.

Report •

June 30, 2012 at 23:56:37
Thanks for putting up with me. I just needed to clear up a few last details. I am ending this thread.
A friend is someone who sticks by you until the end, "fri + end". And so I can truely say that you are my friend.
I am going to try out a last few ideas.
If all else fails, I WILL buy a CD drive, which could fix it

I appreciate your patience, you are very kind.
I have a major crisis, you understand.
I call you my friend, till the end
Thank you for being my friend
I hope you are not upset with me/ME

As the last few words:
My desktop was fried in a power surge.
It was a 2.4 Gigahurtz. Ouch, that hurts.
You got to feel my pain.

My final words:
This Problem is Not Solved
There is Still a Problem
My Computer is Still Crashed
Right Now, All I See is A Black Screen

Report •

July 1, 2012 at 13:53:14
Best thing is to take it to a Computer Tech....

Googling is quicker than waiting for an answer....

Report •

July 1, 2012 at 21:03:59
Captain, we are recieving a distress call from a Klingon Warship. What are your orders? Set us on course with that Warship. After traveling 40 lightyears of distance, we neared the ship. Only burning wreckage remained.

Stardate 3122,
This is the Captain's Log Supplimental. Captain's Log Stardate 3122, we intercepted a distress call from a Klingon Warship. When we arrived, there was nothing left of the ship, or of what had done this. Apparently, the Klingons had tried to be friendly, so their danger must have been great, to provoke them to goto such lengths of friendship. The Klingons didn't appear to be hostile, but didn't mention anything about what the problem was. Either they couldn't figure it out themselves, or they didn't know. We tried to save their ship, and to help negotiations between our two races, but have failed in our mission. We had arrived too late!

Problem 1: Corrupted Files

Problem 2: Probably the CD Drive

Ship Status: Crashed
Engines: Disabled CD Drive
Damage: Black Screen

Captain Kirk
USS Enterprise

Report •

July 2, 2012 at 06:24:07
Sorry, I accidentally double posted when doing an edit. Please see below.

Report •

July 2, 2012 at 06:26:00
Your Star Trek references are not in the least bit cute or funny. Any one of us who have tried to help know exactly what the problem is - you have no idea what you're doing & you're too cheap or too stubburn to replace the broken CD/DVD drive in your laptop.

I suggest you start over from scratch. Post a new question & put it in the correct forum. And if/when you do, make sure to list the complete system specs or at least the make/model of the laptop you're working with immediately. Don't wait until the 13th response! And no one cares about your old desktop system that died, it has nothing to do with your current problem - all that mentioning it does is muddy up the already murky waters. Keep your comments & questions focused on the system you're working with & nothing more. And if you want to be taken seriously, please stop with the stupid Star Trek references.

Report •

July 2, 2012 at 08:38:31

Above is new post, do not know if same machine, whether or not O/S installed, no full specs listed and still talking gibberish........

Googling is quicker than waiting for an answer....

Report •

July 2, 2012 at 17:54:53
Dear riider,
This thread has ended. Problem has been solved, as way of "this is the best answer", and so my last star trek post was going to be the thread's last post. I didn't think anyone was going to keep replying to this thread. Even you said that you didn't want to help me anymore -- or couldn't (due to your willingness, or lack of hardware, as the issue). Though I get the impression that you do want to help me, its just that you want me to get the new hardware, which I may end up doing before long.

So if I get a new CD Drive because I couldn't solve this problem any other way, and this new hardware does not solve the problem, should I private message you sometime in the future?

And by the way, I just want to thank you for all that you done for me, and for all the advice that you gave me. Thank you riider.


Your Cyberfriend

Captain Kirk

Report •

July 3, 2012 at 11:30:26
Click here.

This machine has XP already installed which seems to be what you are after.


Report •

July 4, 2012 at 20:08:28

Wow, likelystory, that link that you sent me was good deal. If it hadn't already sold, I would have been tempted to get it -- I think I would have.

Thanks for the info: didn't know there were such good prices on e bay!!
I'll have to look there more often...

Report •

July 5, 2012 at 08:20:39
"that link that you sent me was good deal"

Really? Did you read the description? No HDD, no optical drive, no wireless, no battery, no AC adapter. Why would you even consider spending $45 + shipping for a useless piece of crap when all you need is an optical drive & your problems will be solved?

Report •

July 5, 2012 at 23:37:39

Thanks for looking out for me: I did not read the description. Man, that computer is bare bones. It wouldn't do me any good. It would just be more trouble than it was worth. And definitely would not help me in my present situation.

In fact, all that it would do would be just to leave me with two computers that are next to not functional.

So I guess it really wasn't that great of a deal. I'll have to remember to always read the description on these items!!!

Guess I'll just start with the CD Drive for now if I can't fix it. I already have 2 computers and so I don't really need 3, unless its a desktop. But I am going to wait on the desktop for a while.

I really like the features on a desktop, they are so much easier to use, and would have gotten me out of this predictament that I'm in now. And you can upgrade them. I'm starting to realize how limited and almost useless that laptops are, especially when you get in tight situations like this that I'm in now.

In the future, my main computer WILL be a desktop. I am going to try for a 3 Gig or above, get a decent video card of at least 125-256 MB RAM, and upgrade the RAM to at least 2 Gigs, but hopefully 4, if I can pull it off. I don't really care about the hd since I have LOTS of these [Desktop only]. I would like to get a dual core or a quad core, but probably wont because they are a lot more expensive, so I'll just settle for the regular processor and the "upgrades".

Don't worry riider, I'm only a couple days away from getting a CD Drive. I was just hoping that I could fix it. I was trying to see if I was an computer expert yet.


Your Friend

Captain Kirk

Report •

July 6, 2012 at 04:15:42
"I was an computer expert yet" only in your wildest dreams !!!

NEW PC Tower without Operating System:

Report •

Report •

July 6, 2012 at 14:48:07
So you don't know anything about whether its possible to install DOS on a Dell and then run it internally in a Compaq?

Do you know how to correctly configure the Plop program?

A computer expert would know these things...

Nice link. Might be able to use it. I'll check it out

Report •

July 6, 2012 at 15:21:04
'Plop program', sounds something a future toilet would use.

I am a hardware guy not a software guy but i try to help.

Report •

July 6, 2012 at 17:41:07
Please see response # 16:

Report •

July 8, 2012 at 02:53:57
Dear riider,
I am completely speachless. I am at a loss for words. I don't know what to say. And, I am frankly surprised. This is one of THE best responses that I have ever got on ANY forum. Not only is it informative, it also has a definitive logic to the specific sequential order that is needed for completion.

But I must say, your high intellect has come just in time, for I have officially just ran out of ideas, unless you count rereading the instructions for the Plop program and retesting this program and the DOS one that I have again.

Here's what I have done since I talked to you last:

--I got a power cord for my Dual USB Card
--I tested the Dual USB Card on the Dell [the good working computer], hooked to my external CD Drive, and it works! Without the power cord, it didn't detect before!!
--I installed DOS on the Compaq hd internally in the Dell, from the DOS boot CD. I installed it twice, but it still failed to run. It also wanted to install the Linux package with a "yes" or "no" do you wish to proceed, and I couldn't cancel it with a "no", as I was returned to the same menu asking me "yes" or "no". When I reboot, the DOS boot CD was still in the CD Drive and loaded with autoboot, so I chose boot with harddisk [which means hd right?], and froze [its possible that I should have waited a REALLY long time for it to complete, though it showed no progress]. When I restarted it again with and without the CD, now it returns a black screen with a blinking cursor about 10 lines down. My DOS boot disk failed. Note: this is not the one you suggested.
--I took the Compaq hd from the Dell and put it back in the Compaq. When booted, it returned a black screen with a blinking cursor.
--I plugged in the Dual USB Card with the external CD Drive attached, into the Compaq. The external CD Drive is not detected. Conclusion: I think the Dual USB Card needs "drivers" to BE detected, and without an OS, the computer can't read it -- how unfortunate; would have had it. So, so, close...
--I popped the Compaq hd back in the Dell and installed Windows on it. So I know that the XP CD is good, and that there is nothing wrong with it. I'm starting to narrow down the possibilities now with deductive reasoning logic. And just in the off chance of some fluke or other, I return the hd back to the Compaq and test all of my autoboot CDs with the seated CD Drive AND the external CD Drive.
--I try my luck, and since both devices [the Dual USB Card and the external CD Drive] both use a 5 DC volt, and have the same type of connector, I switch the power cord to the external CD Drive with a 4 USB hub and take out the the Dual USB Card, but the plug doesn't fit all the way in and appears to still only be getting minimal power, as the CD Drive keeps spinning and sounding like its still trying to load. No luck!!!

riider, I cannot begin to tell you how much your respose means to me. Compared to your previous responses, this looks like it is the awakening of your soul, of your spirit. This says something more than just about how to fix my computer. It says something about you. You have proven that you have character. This response indicates that your intellect is higher than most people and that you are not a 15 year old kid. Your mature attitude shows the signs of kindness. And you obviously have to have great patience to put up with me.

And I'm sure this is the right answer riider -- that it will fix my computer. So even if I sign off of this forum for a while, I just want you to know riider, that I will always value you as my friend when I return to this forum again some time in the future. But my computer isn't fixed, so I'll keep you posted on my progress. It was nice talking to all of you computer guys and it was fun to have a bunch of cyberbuddies. I did not mean to upset anybody, and was authentically trying to be friends with people if I could.

I know I may have sounded stupid at times because I didn't know things and it could have been done another way a whole lot easier, but I wanted to learn. I wanted to learn how to do things that I've never done before, and to test out new ideas instead of doing things a certain way that I try things all the time. I wanted to bounce ideas off of people. I wanted to learn things. And I liked having cyberfriends to talk to. So you can call me whatever you want. But I thirst for knowledge like a parched man crawling through the desert. And I enjoy chatting in the company of people who have a higher than average IQ like me, and who like computers. Do not hold this against me.

Jolicloud, you are my friend.
riider, you are my friend.

Captain Kirk

Report •

July 10, 2012 at 10:18:47
"riider, you are my friend"

No, I am not. I'm a helper in a forum. End of story.

Report •

July 11, 2012 at 00:28:41
Hold tight. I WILL choose you as the best answer.
I have not fixed it yet. I ran into another problem.

In the process of installing DOS 7.1 from the CD, I must have installed it wrong, and it wrote to the MBR. When I boot now, it says "i/o error the wrong disk is inserted" "invalid system disk" or something. So I installed it a second time. Same thing.

I wanted to write "over" the MBR, so I installed linux puppy on the hd, but that didn't seem to erase the DOS mbr. So I took it OUT of the Dell and put the Dell hd back in the Dell. I tried to find my Killdisk program to erase the MBR [what a pain]. I could not find it on the CD that I thought that I had saved it on. I looked on my hd twice, throughly. Nothing, nowhere. Where did it go? So I went online and tried to retrieve it there. Now when I downloaded it, I tried 5 times on different links and in different tabs, and ALL of them did not complete the install, and gave me the error message of "invalid permission".

I "was" able to download the DOS killdisk, but it seems to be a folder of files, including an exe, so I don't want to try to use it while the good hd is in the computer just in case it performs the operation. In which case I'd have TWO dead computers!! No exactly the best thing. So I hooked up the USB cord and connected the Compaq hd in the external hd case, but Plop was not detecting it. I followed the Plop tutorial and it is not doing what it is supposed to. I haven't figure out how to configure it correctly yet. The program is not functioning like it does in the tutorial, so I may have messed up the configuration somehow by trying every single option to get it to work and trying it manually. It looks like I may have to uninstall and completely delete all of the Plop files and then try again. Otherwise, I really don't know what I am doing wrong!! I also double checked the bootable program on the USB and tries two different programs: DOS to USB and Linux Puppy. No success.
And I remember that the Bios does not allow you to boot with the USB.

I put the Killdisk Program Disk into the CD Drive [Dell, Good Computer]. When the program booted, it did not "detect" the USB Compaq hd. So it looks like I'm going to have to take out the Dell hd and put in the Compaq hd again. And then try AGAIN.

But now I just found the 6 XP Startup diskette images. And I don't know how to proceed from here, as I don't have a floppy drive. I wonder if you can save them on a single CD and simulate the same effect. Or, I could put all of the files into one folder and copy them to the empty hd and hope for the best... And then there is also the 6 XP Startup Disks, which are different files. They are exes. Maybe I should copy these onto a CD and try with this... So I still undecided as to which is better or what will work at this point, the Startup Disk/ettes on 1 CD or the Killdisk Program Disk

So, as you can see, this process will take a little longer to complete!!!


An Acquaintance

Report •

July 11, 2012 at 13:38:34
"I wanted to write "over" the MBR, so I installed linux puppy on the hd, but that didn't seem to erase the DOS mbr"

Why do you do such stupid things? Where did I or anyone else tell you to use Puppy or Killdisk? You obviously have no idea what you're doing. Why are you so obsessed with the MBR & why would you think Puppy would fix it? To fix the MBR, you simply run FDISK /MBR.

I gave you a step-by-step explanation on how to install XP. I provided the links to download DOS & to download the burning program you need to burn the DOS ISO to a CD. I even provided a step-by-step DOS command explanation to get the XP installation started. And I dumbed it down as much as I possibly could. If you can't follow simple instructions, maybe you should just throw all your computer stuff in the trash & watch TV instead, or is the remote to complicated for you?

4 weeks & over 100 responses (all threads combined) & you're no better off today than you were on day one. It's time to throw in the towel. Maybe someone else will pick up the ball & play games with you, but I'm finished.

Report •

July 11, 2012 at 14:57:23
Rider, it is not 4 weeks, if you check posting history it is nearly a year since he first posted here, that is why I gave up, and it appears everyone except your good self...

Googling is quicker than waiting for an answer....

Report •

July 11, 2012 at 17:38:41
(Oh my, I feel the love is gone.)

Captain, your actions of late appear to have a non-logical even random purpose. You head the ship in one direction and then for no reason abruptly alter course leaving us all confused. I feel we must request reassignment to another vessel before you recklessly take us into Klingon space.

Report •

July 11, 2012 at 21:00:37
Fdisk. That's a good idea. I was going to do Killdisk, but that is a 13 hour process, so it will take all day. I didn't know that Fdisk erased the MBR. That's good to know. Your way was certainly faster than mine.

I have to erase the MBR because the DOS OS was installed incorrectly and did not return a command prompt after boot like it was supposed to. What happened was, was that the first time that I installed DOS 7.1 from the CD, I accidently installed only the DOS commands, selected "yes" to add the mscdex.exe and smart drive. So I installed it a second time. This time, I selected the minimal install option and clicked the also install "Add-Ons". The "Add-Ons" included things like a sound driver, a video driver, mcaffee, and several other things.

After the install, now that I boot with CD, it still goes to the autoboot menu with the selection options of boot from hd, install, and two other options. When I take the disk out and boot, an error message appears on the screen. "i/o error wrong disk inserted" or something. But does not return a Command Prompt. If I press any key, it keeps repeating this same error message.

So obviously I installed it wrong or it is a corrupt file/disk. Therefore, I formatted the hd. I now booted again. I still got the same "i/o error wrong disk inserted" error message. So if the hd is formatted, how could this still be there? There was no disk in the drive... It must be the MBR. So I installed Puppy to try to erase the MBR, because this must have been what has been giving me the trouble.



Report •

July 13, 2012 at 20:01:43
Dear riider,

As I told you, "you have probably solved the problem."
I can fix my computer from here without your help. You got me past the crucial sticking point where I could not climb out of by myself, and for that, I am very thankful.

And as I told you before, "I am just making conversation".
You know, someone to chat with. And talk about computer stuff. Just thought that you might want to conversate.

Any additional advice would just help the process go quicker, but is not essential to the completion of this project.
Or if you want to talk about any other computer subject, that is great too, but I don't want you to feel like I NEED your help at this point. Such that if you talk to me, you don't have to feel like you need to, but are doing so because its fun to chat about computers.

Anyways, if you want to chat and talk about computers...


A Person You Know

Report •

March 2, 2015 at 00:27:38
Is best not to install 2 different OS in laptop. If you would like to get a new laptop can get from or

message edited by IThelpdesk

Report •

Ask Question