Solved Windows 95 CD-ROM drive problem

Ibm / 2162-s3c
October 3, 2015 at 19:24:39
Specs: Windows 95, 233 MHz
I have a Windows 95 computer that I still use to play old games. It's an IBM Aptiva 2162-S3C. It's one of those with that media console that has the CD-ROM and floppy drive separate from the tower.

The problem I'm having is that the CD drive is only sporadically reading CDs now. It shows up in device manager as working properly. But when I put a CD in, it spins the CD for like 3 seconds, then just stops/"gives up". And then I have to eject and re-insert the disc usually 20 times or more before it'll finally read the CD properly.

Did some previous Googling on this. People suggested the laser lens might be dirty. I tried multiple brands of CD laser lens cleaning discs (the ones with the little brushes on the underside of the disc). I don't think that solved the problem...the drive wouldn't even read the CD cleaning disc! (It finally read it after 23-something retries.) The drive still had problems reading CDs after putting the CD cleaning CD in it.

I'm now faced with the possibility that I simply have a failed CD-ROM drive. Does anyone have any other suggestions?

See More: Windows 95 CD-ROM drive problem

October 3, 2015 at 20:17:22
✔ Best Answer
Try re-seating the data cable a few times.

Report •

October 3, 2015 at 20:45:54
Other than the suggestion that OtheHill made, there's little that could be done other than replacing the drive. Over time, the laser in an optical drive will eventually fail, and with a system that old, it probably is the case. Replacing the drive may or may not be easy---depending on it's accessibility and whether or not it is a proprietary type.

"Channeling the spirit of jboy..."

message edited by T-R-A

Report •

October 4, 2015 at 11:50:01
I've never come across a unit that had those drives separate from the computer case but the first few google hits here:

have some breakdown diagrams. It's probably at least a 16x so isn't likely to be a proprietary drive so you could replace it with any IDE/atapi drive.

It's kind of amazing it's lasted nearly 20 years.

Report •

Related Solutions

October 6, 2015 at 00:46:38
Thanks for the media console diagrams, DAVEINCAPS. However, I think Othehill's suggestion fixed the problem! I opened up the tower and reseated the data cable a few times, and that must've fixed it. Every CD I've put in...the drive has read the disc on the first or second try. MUCH BETTER than before when it would take 20-30 retries.

Thank you for everyone's help!

Report •

Ask Question