why can't i access the Internet with Windows 98se

November 1, 2015 at 01:09:35
Specs: Windows 98se
My laptop connects to my router via a Belkin card but try as i may, i cannot connect to the internet. I can only assume that some setting need to be changed ?

See More: why cant i access the Internet with Windows 98se

Report •

November 1, 2015 at 01:30:55
What browser and version are you using? It is likely so far behind the times that it can't understand the code being fed to it. Try removing your home page, use blank instead. Then try to access as stripped down a website as you can find. I was able to access http://www.belarc.com/ using Netscape Navigator 3.0 Gold on a Windows 95 machine and apart from some java script errors which I just told it to ignore the page appeared.

Well, I think it was Netscape anyway, the machine I used also has Internet Explorer on it, not sure what version that was.

message edited by ISAmad

Report •

November 1, 2015 at 01:58:39
I am using Firefox 2.0 which is supposed to be suitable for 98/ME. I will try your suggestion and report back.
Thanks for responding

Report •

November 1, 2015 at 02:20:10
Hi Again

I followed your advice and installed Netscape Gold but I get the message: Netscape is unable to locate the server (home,netscape.com ) The server does not have a DNS entry?

Any ideas

Report •

Related Solutions

November 1, 2015 at 06:22:53
Are you sure your system is connected to the internet? Did you load the drivers for the Belkin device & does it show that it's connected?

The most modern browser that will work on the outdated Win9x OS is K-Meleon 1.5.4. There is also a beta version 1.6.0. After that, K-Meleon changed their numbering system. Version 74 & above is for XP & newer Windows versions.


Report •

November 1, 2015 at 19:51:45
Sorry, I didn't mean to say you should use Netscape specifically, not that it won't work. I just meant to suggest you limit your surfing to whatever your browser can handle. That Netscape site is no longer, it was the default page after installing the browser. I don't think it not loading has anything to do with DNS. It would direct you to AOL if the browser could load it.

I have never heard of K-Meleon, but if riider says its more capable and compatible then why not give it a try.

Do you know if your router is your DHCP server and providing you your DNS IP address? If you can connect with other computers on the same network, this is probably fine.

If you are unsure about your connection, try pinging (ping website) out from the command prompt (run command or cmd) and see what you get back. Ping yahoo.com for example, that should reply.

If it can't find that, then the settings on the PC may not be right. Check the IP configuration of the PC. Enter "winipcfg" or "ipconfig /all" at the command prompt and see what it says there (one or the other commands may not work). Compare those settings against another computer on the network. Specifically your subnet address as determined by your IP address and subnet mask. Change it if necessary.

If winipcfg doesn't do anything on windows 98, you will probably have to go into the windows control panel to change those settings.

If none of that works, it may be that your PC was given a static address and is not setup to get its address from DHCP. Or it maybe that your router has MAC address filtering enabled. Or any of a number of other things I'm sure.

Let us know how it goes.

Report •

November 1, 2015 at 20:34:25
Yeah with 98 sometimes it's easiest to connect through an ISP like AOL. For most high speed connections it should be free. That assumes of course that you're not having a driver problem.

Report •

November 6, 2015 at 09:03:15
Hi All

Well my Belkin pcimia wifi card shows up in device manager ok and I downloaded the correct driver and utility from the Belkin site. The utility locates my router and the usual request for the passcode appears, and when this is done, the utility shows its connected and it has a very good signal.

When I set my network settings to locate the ip address in auto, it does so and Windows builds a driver base then asks to be rebooted. On start up I get a box showing a request for user authentification ie:
User Name

I have entered my ISP details but it rejects the info, so what am I doing wrong!!!!

Please help before my laptop goes on the firework bonfire

Report •

November 6, 2015 at 19:28:48
What ISP would that be?

When I ran 98 (and used a dial up modem) it was AOL that made the connection. I didn't have to fiddle with network settings. Of course I never tried to connect via wifi so maybe some extra steps are needed but I still think you should try letting the ISP do all the work.

Report •

November 7, 2015 at 16:37:36
I had assumed this was a typical home computer. Are you trying to connect to a domain?


Report •

Ask Question