SOLVED - Insert Bootable Media - No Valid FAT

February 1, 2011 at 11:41:31
Specs: Windows 95/98, Old/Small!
Okay, this is a reply to a very old thread that has been locked. I work repairing very old industrial electronics and use old PCs with old programs, most only compatible with Windows 98, requiring serial ports, floppy disks and other such ancient technology.

I had some very important programs on a Gateway 2000 P5/75 PC that has a WD Caviar 2850 hard drive, running W98. One day I went to use it and it came up with a pre-boot screen saying " please insert bootable media from floppy". I then decided the hard drive was toast, and replaced it. After installing the replacement and loading W98 on it, I was lamenting the fact that I would now have to reload and in some cases recreate some valuable programs for my test system. I got to looking around for solutions and found an old one on this forum.

I started with the W98 boot disk and saw that it could write the temp SYS files to my old drive, so had hope. It also told me that the "Drive C does not contain a valid Fat or Fat32 partition".

So, searching this forum, I found a VERY old post from 2001 about someone using W95 (!) and similar circumstances. One reply told how the Master Boot Record is a very small program on the hard drive and it may have gotten corrupt.

With the computer booted from the boot disk, type the following and reboot:


When I did so, the hard drive came back to Scandisk and was restored. I was so happy about this I decided to share with others who may be struggling with ancient technology as I am.

See More: SOLVED - Insert Bootable Media - No Valid FAT

Report •

February 11, 2011 at 14:14:58
You should keep copies of all data you want to retain. You were lucky this time. I am not sure why what you did worked. Perhaps the fdisk potion of that command was ignored?

Report •
Related Solutions

Ask Question