application error SHGetFolderPathA

Genuineintel / X86 family 6 model 8 step...
January 16, 2009 at 14:20:15
Specs: Windows 98SE 4.10.2222A, 256.0MB RAM
I get the following application error on windows startup: The procedure SHGetFolderPathA could not be located in the DLL SHELL32.dll.

How do I fix this? I've already downloaded patches from ms Q313829.

See More: application error SHGetFolderPathA

Report •

January 16, 2009 at 14:59:43
Did you just install some software? If so, what was it?


Report •

January 16, 2009 at 17:18:47
Thanks for your response. I did update Norton Symantec to 2005, but I believe I was getting the error message earlier. I also removed AVG antivirus (free version). I also upgraded Spybot S&D (still free version). I may have done some other stuff!

Report •

January 16, 2009 at 20:25:18
So you ran Q313829 and it installed OK?

Open the windows\system folder, right click on SHELL32.DLL, choose 'properties', then 'version'. What does it say?

What version of IE are you running?

Report •

Related Solutions

January 17, 2009 at 12:09:12
Q313829 installed ok.

SHELL32.DLL is version 4.72.3812.600

IE is 6.0.2800.11061C.

Thanks for your help! (I'm thinking of buying a mac.)

Report •

January 17, 2009 at 23:49:39
Those are the versions I have on my 98 and may be the most recent for 98.

You might run MSCONFIG--STARTUP and, one by one, disable the loading of software you've added. That way you may be able to figure out where the error is coming from.

Report •

January 18, 2009 at 12:37:40
Thanks, I've been going through the microsoft "How to perform Clean-Boot Troubleshooting for win98 and tried a few things. But when I get to the troubleshooting example step 4 re: config.sys tab, it says "click to clear the check boxes for the first half of the lines in the list." There is only one check box. Two of the lines are the same: "rem....MTMATAPI CD-ROM..." Next line is "remDEVICE=C:\MTMCDAISYS /D:MTMIDE01" Next line is [COMMON]. As you move up and down the list, the order changes. Any ideas, as this seems ambiguous?

I've also tried unchecking some of the startup stuff, but then when I went back to "normal" startup they of course came back on in startup. I'm also concerned about unchecking something that may be essential for loading windows. Is there a list of essential startup programs for windows? Dumb question, I'm sure.

Report •

January 18, 2009 at 14:29:20
The config.sys stuff won't matter. The lines you were asking about had to do with dos support for the cdrom. Those lines appear to be REM'd out anyway, which means they're not loading.

There's nothing you can uncheck in MSCONFIG--STARTUP that will prevent windows from loading. The default stuff is SCANREGISTRY, TASKMONITOR, SYSTEMTRAY, the 2 LOADPOWERPROFILE and probably SCHEDULINGAGENT. You can probably leave those checked as they shouldn't be the problem but again, it won't hurt to uncheck them temporarily.

Report •

January 18, 2009 at 16:47:04
Wow! Great advice! I unchecked almost everything in startup, rebooted. I found I had caused a problem with Norton Symantec security 2005 by unchecking startup symantec programs (got an invalid page fault in NMAIN when I tried to open my security from the desktop). I went back to MSCONFIG-STARTUP and rechecked the symantec stuff. I now have security back and the original application error problem is gone, or seems to be so far.

Thanks a bunch.

Report •

January 18, 2009 at 17:00:23
You're welcome. I hope that cures it.

Report •

Ask Question