WSUS doesn't download updates

November 25, 2015 at 00:34:05
Specs: Windows 8.1 Pro, i5-2320/12Gb
I have had problems with Windows Update Standalone Installer in Windows 8.1, so I hoped WSUS 10.2.1 would solve the issue. First few runs - "w63 glb" error after a few seconds when using my PC desktop as target. Switched to USB as target; ran for 30 seconds, got "success" message. When I opened the installer, nothing I had chosen had downloaded and boxes were grayed out.

There was an ExcludeList.txt, which listed 30 or so of the 70 updates I need to install. Tried twice; same result. Need to update is reaching critical mass.

Thanks.


See More: WSUS doesnt download updates

Report •

#1
November 25, 2015 at 02:14:45
1: Go to Administrative Tools/Services, and stop the Windows Update service.

2: Then go to the folder C:\Windows\SoftwareDistribution and delete ALL of the files and folders.

3: Then go back to Services and restart the Windows Update service which will recreate ALL of those folders again.

4: Then manually run the Update Service and everything should work. If you don't know how to manually start updates, reboot & Auto Updates should kick in.

Report •

#2
November 25, 2015 at 14:00:58
Thanks - I will try it and report back. FYI - I have been manually downloading and installing the updates for the last few months, due to multiple "permission denied" errors.

Report •

#3
November 25, 2015 at 16:20:03
"due to multiple "permission denied" errors"
That is often due to malware.

After doing as per my post #1.

Here are the next 2 steps, more steps will be needed, after I see the results of these logs.

Run them in this order.

Step 1: Run AdwCleaner
http://www.softpedia.com/get/Antivi...
http://www.raymond.cc/blog/adwclean...
http://www.bleepingcomputer.com/dow...
Author's site
http://general-changelog-team.fr/en...
Tutorial
http://general-changelog-team.fr/en...
Close all open programs and internet browsers.
Double click on AdwCleaner.exe to run the tool.
Click Scan
In the results tabs, uncheck anything you don't want to remove.
Click on Cleaning.
Confirm each time with Ok.
Your computer will be rebooted automatically. A text file will open after the restart.
Please Copy & Paste the contents of that logfile with your next answer.
You can find the logfile at C:\AdwCleaner[S1].txt as well.
http://i.imgur.com/r3PoAEG.gif

Step 2: Run Junkware Removal Tool
http://www.softpedia.com/get/Securi...
http://www.bleepingcomputer.com/dow...
http://thisisudax.org/
http://thisisudax.blogspot.com.au/2...
Malwarebytes Acquires Junkware Removal Tool
https://blog.malwarebytes.org/news/...
Download Junkware Removal Tool onto your Desktop. If your default download location is not the Desktop, drag it out of it's location onto the Desktop.
Warning! Once the scan is complete JRT will shut down your browser with NO warning.
Shut down your protection software now to avoid potential conflicts.
Temporarily disable your antivirus and any antispyware real time protection before performing a scan.
Click this link to see a list of security programs that should be disabled and how to disable them.
http://www.bleepingcomputer.com/for...
http://www.techsupportforum.com/for...
Run the tool by double-clicking it. If you are using Windows Vista or Windows 7/8, right-click JRT and select Run as Administrator.
The tool will open and start scanning your system.
Please be patient as this can take a while to complete depending on your system's specifications.
On completion, a log (JRT.txt) is saved onto your Desktop and will automatically open.
Copy and Paste the contents of the JRT.txt log please.

message edited by Johnw


Report •

Related Solutions

#4
November 26, 2015 at 22:37:21
I can install and extract AdwCleaner and get the scan page. Then I get two error messages: "C;\Users|[myPC]\AppData\Local\Temp\sqlite3.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the same installation media or contact your system administrator or the software vendor for support. Error status 0x0000022" and then "SQqLite3.dll cannot be loaded.".

I have downloaded it twice - once on PC, once on USB - from two different sites = same result.

message edited by Bapper1


Report •

#5
November 27, 2015 at 00:45:56
Have you tried everything in the tutorial?

Have you right clicked on it & clicked on > Run as administrator?

message edited by Johnw


Report •

Ask Question