Windows 8.1 - 0x800F0922 Net Framework 4.5.2 Error URGENT

July 6, 2018 at 07:54:22
Specs: Windows 8
Hi all,

I have an issue installing any (Windows) updates to my PC they always fail along with any other legitimate software requiring the Net Framework 4.5.2 update.
I have tried, disabling the Net. Frame work advanced for 4.5 .. nothing happened.

Have tried the DISM.exe scanhealth / restorehealth - nothing happened

Disabled Antivirus, Windows Presentation Foundation DTS and SCP DS3 (used for a PS3 controller) and tried again.. still the same error code.
Have also used the Online/Offline installer for the above mentioned 4.5.2 Framework with still the same results
Windows update at the moment downloads but always FAILS to install any update.... I do not know what do do.

Here is my error log file
OS Version = 6.3.9600, SP = 0.0, Platform 2
OS Description = Future OS - x64
MSI = xxxxxxxxx
Windows servicing = 6.3.9600.16384
CommandLine = C:\9b41a3f9356e8a469a6ad690\\Setup.exe /x86 /x64 /redist
TimeZone = xxxxxxxxxxxxxxxxxx
Initial LCID = 3081
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft .NET Framework 4.5.2 Setup
Package Version = 4.5.51209
User Experience Data Collection Policy: Disabled
Number of applicable items: 6
RmShutdown failed with error: 351
RmShutdown failed with error: 351
Exe (C:\9b41a3f9356e8a469a6ad690\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
Exe (C:\9b41a3f9356e8a469a6ad690\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
Exe (C:\9b41a3f9356e8a469a6ad690\x64-Windows8.1-KB2934520-x64.msu) failed with 0x800f0922 - (null).
Exe Log File: CBS.log

Final Result: Installation failed with error code: (0x800F0922) (Elapsed time: 0 00:04:10).

Please any help would be greatly appreciated


See More: Windows 8.1 - 0x800F0922 Net Framework 4.5.2 Error URGENT

Reply ↓  Report •

#1
July 6, 2018 at 09:43:43
Not one I've run into personally but if you Google up the error code 0x800F0922 there are a few hits which might help, such as:
https://www.easeus.com/backup-utili...

You could also try discharging the motherboard components by unplugging the power, also removing the main battery if a laptop, then holding the power button down for 20 seconds before powering up again.

Have you tried the update trouble shooter (See Troubleshooting in Control Panel)?

A virus is possible so you could run these two freebies which often find what others miss:
AdwCleaner:
https://www.malwarebytes.com/adwcle...
Download and "Save" the file somewhere. Go to the saved file then double click it to run the program. Run the "Scan", followed by the "Clean & Repair".

MalwareBytes:
https://www.malwarebytes.org/
(use the "Free Download" button rather than the "Buy Now" button).
After the install go to "Settings > Protection". Under Scan Options move the "Scan for rootkits" slider over to On and Run the Threat Scan. Quarantine anything it finds.

Always pop back and let us know the outcome - thanks

message edited by Derek


Reply ↓  Report •

#2
July 6, 2018 at 12:15:36
Please do not double post - continue on this one now it has had one response.

Always pop back and let us know the outcome - thanks


Reply ↓  Report •

#3
July 7, 2018 at 07:24:47
Try deleting or renaming the SoftwareDistribution folder, then run Windows Update. It will likely take several minutes so be patient.
https://www.thewindowsclub.com/soft...

Reply ↓  Report •

Related Solutions

#4
July 20, 2018 at 13:31:57
If this was urgent then why didn't you even bother to pop back about what we suggested?

message edited by Derek


Reply ↓  Report •

Ask Question