Solved WiFi not Working after Windows 8.1 Upgrade

November 15, 2013 at 11:18:58
Specs: Windows 8.1, 4GB
Hello I am having a huge problem with my computers wifi.

So I bought a new computer sometime ago with Windows 8 installed as its main OS and the
computer has built in wifi and as you may know Windows 8.1 is offered as a free upgrade to Windows 8 owners so I happily upgraded.

How ever my Wifi that is built in the computer is not working properlyso I am using my old computers Belking USB adaptor for the time being.

I checked the networks that are available and my built in wifi is not on that list only Ethernet and my Belkin Wifi or is named on my computer "WIFI2"


So I checked to see my devices and under Network Adapters it has:
-Belkin USB Wireless Adaptor
-Realtek PCIe GBE Family Controller
-Realtek RTL8188E Wireless LAN 802.11n PCI-E NIC ""PROBLME NETWORK""


I tried to enable it it does work but in a few seconds the device window will flash and than it will show a yellow Exclamation Mark like if there is some sort of problem.

What is going on?


See More: WiFi not Working after Windows 8.1 Upgrade

Report •

#1
November 16, 2013 at 02:46:07
✔ Best Answer
Try downloading & installing the latest wireless driver from your laptop maker's website.

Remove the external Belkin wifi adapter before you install the driver for the internal Realtek wireless adapter. Leave the Belkin one unplugged when you attempt to use the Realtek one. Windows cannot deal with two wireless adapters at the same time on the same computer.


Report •
Related Solutions


Ask Question