Solved Problem accessing a Maxtor II drive using Windows 8.1

November 14, 2013 at 14:08:03
Specs: Windows 8.1
My Maxtor II hard drive worked OK on both XP and Vista. The Vista laptop has expired and I now have Windows 8.1 on a Toshiba laptop.

The software seems to load OK. The laptop does not recognise or let me access the drive when connected, although it appears under Device Manager. The hard drive has a password and it has been suggested this is the reason I can't now access it - does this mean I must remove the password using another computer?

Is there some other known reason why I have a problem?

Under the Main Menu none of the 3 functions lets me view the information on the drive.


See More: Problem accessing a Maxtor II drive using Windows 8.1

Report •

#1
November 14, 2013 at 20:50:22
your post is a bit confusing...are you saying you acquired a win 8 laptop and don't know the HD password?

HELP in posting on Computing.net plus free progs and instructions


Report •

#2
November 15, 2013 at 09:54:20
✔ Best Answer
I'm assuming that you have an external drive with password protected backup software that no longer works properly with Windows 8.1.

If that is the case then most likely you need a new software package that runs on Win 8.1. and yes, you might well need to clear the password using a computer running an earlier version of Windows in order to see the content. If you manage to access the data then best temporarily copy it off somewhere until you find a solution to your backup software situation. If it cannot handle the password on Win 8.1 then it might not be able to handle backing up either.

Always pop back and let us know the outcome - thanks


Report •
Related Solutions


Ask Question