Solved Optical Drive Disappears in Win 8

Custom / CUSTOM
December 25, 2012 at 09:16:13
Specs: Windows 7 Ultimate x64, 2.793 GHz / 2047 MB

I just installed Windows 8 on my desktop computer and then upgraded with the Pro Feature Pack and 2 days after installing it my optical drive disappeared from the Computer and also from the Device Manager, I thought somthing must be wrong with the drive or the IDE cable so I checked in the BIOS to see if it was being detected and it was appearing in the BIOS and then I inserted the Windows 8 bootable DVD setting the drive to first boot and it worked. Then I looked for a fix online and found one which said to install a software called Roxio UDF Reader and reboot and it worked but after 2 days the drive again disappeared. I uninstalled the UDF Reader and then rebooted after the uninstall so that I could reinstall but when I rebooted the drive was back. Again after 2 days it disappeared and then after a windows update it came back and now its gone again. It seems that if I install something and reboot the drive appears and then after 1 or 2 days it disappears. I searched online and someother people also have the issue but no one knows the proper solution.

Is a Windows 8 bug or something?

Please help me out.

Tek Ideas Unlimited

See More: Optical Drive Disappears in Win 8

Report •

December 28, 2012 at 01:21:28
✔ Best Answer
Roxio UDF Reader is required only for reading certain types of discs, not for fixing a CD drive which has "disappeared", so I don't think it did anything to fix the problem, it was just a coincidence that the drive came back and disappeared again.

It's more likely the drive is not entirely Windows 8 compatible if it works outside of Windows okay (eg booting from it), and that's why it's disappearing when Windows is running.

One possible fix (probably the only one) is to fit a new CD/DVD drive, preferably one which states "Windows 8 compatible" on the packaging or product description.

Report •

December 28, 2012 at 15:10:09
Its working now. The device is compatible it was a Windows 8 Bug. A windows update solved the problem.

Tek Ideas Unlimited

Report •
Related Solutions

Ask Question