Solved Deleting U3 System From Flashdrive

Custom / N/A
February 6, 2014 at 14:17:50
Specs: Windows 8.1 64 Bit, AMD FX-8350 8 Core @ 4.0 GHz w/ 2x4 DDR3-1600
Hey Everyone,

I just attempted to format a 2 GB Cruzer Flash Drive. Anyway, it came prepackaged with a program called U3, that apparently is supposed to load programs when I insert the drive into a computer.

http://www.shouldiremoveit.com/U3La...

It has gotten kind of annoying, and it loads a setup application every time I insert it or boot the computer. I tried getting rid of it by formatting the drive, but it didn't erase U3. I also tried just deleting everything in CMD by typing 'del F:\ "."', but that didn't do it either. It treats the application as if it is a separate CDFS drive, and I have no idea how to get rid of it.

Once, while I had it in a computer running XP, I saw a file called 'System" that was sort of grayed out, like it was hidden.

Oddly enough, CMD won't let me change the directory to F:\. It doesn't give any errors, just doesn't do anything when I type 'cd F:\'. Also, when I type 'dir F:\' it doesn't show anything either.


See More: Deleting U3 System From Flashdrive

Report •

#1
February 6, 2014 at 14:51:59
Use Sandisk's own U3 removal tool:

http://u3.sandisk.com/launchpadremo...


Report •

#2
February 6, 2014 at 14:59:52
✔ Best Answer
Actually just figured out another way:

My Computer > Right-click on Disc > Properties > Hardware > SanDisk U3 (Type: CD/DVD ROM) > Properties > Driver > Uninstall

I really don't know what 'Driver' I uninstalled, and I hope it wasn't important, but it got rid of the U3 Disc. So far my actual DVD drive is still working, so I think everything is ok.


Report •

#3
February 6, 2014 at 15:40:25
Use Sandisk's own U3 removal tool:

Nice googling Peet100

"Actually just figured out another way:"

Great detail NT56erbx.


Report •

Related Solutions

#4
February 6, 2014 at 18:42:50
Anyway... Yeah, tried using the uninstaller (it came with the software in a zip on the drive) but it would just give me an error saying 'Disk is not ready!'. And yes, I tried moving it to the HDD and running it from there, still wouldn't work.

#3
If you're wondering how I figured it out, just screwed around in the Properties menus for a while...don't have to be rude about it :P

EDIT:
After a little more meddling, realized why I could see the hidden 'System' folder on XP, you can actually do this with all windows, in file explorer just click File Menu > View> Hidden Items and check the box.

message edited by NT56erbx


Report •

Ask Question