Solved Can't access data on laptop HDD, Can't take Ownership

Dell Dell latitude e6420 14 led notebook...
January 3, 2014 at 03:39:02
Specs: Windows 8, Core i7 2670M
My sister had problems with her laptop and she took her computer to some random shop while she was out of town. When she got it back it wouldn't boot. They told her it must be a virus, and that they could fix it for a fee. She got pissed and left. She brought it home to me. It won't even boot to Safe Mode, just hangs on a black screen after Safe Mode is selected. So I pulled the drive, planning to just Dock it, backup her personal files, and reformat it. The problem is... The drive is inaccessible in Windows. I cannot take ownership. I have tried many times. If you try to access the drive, you get the "G:\ is not accessible. Access is denied" Error message. So, I went into Properties, Security Tab, and clicked Advanced. Then, next to Owner, (No owner currently shows, it just says "Unable to display current Owner"), I click on Change, and in the "Enter the object name to select" box, I normally type my Username, click "Check Names" and the box populates with my user, I click ok, select to apply to all subfolders, apply, wait for permissions to apply and Voiala!! EXCEPT, in this instance, nothing shows up when I click "Check Names". I get the error message: "An object (User, Group or Built-in security principal) with the following name cannot be found:"

What do I need to do?? She had thousands of pictures on this HDD of my nephew we need to save. How can I transfer ownership and save the data?

I am doing this on my HP Pavilion DV7-6199US Laptop, usinga Thermaltake BlackX HDD Dock. I am on Windows 8 64Bit, and the drive I am trying to change permissions on is a Windows 7 drive.


See More: Cant access data on laptop HDD, Cant take Ownership

Report •

#1
Report •

#2
Report •

#3
January 3, 2014 at 11:24:49
✔ Best Answer
If all else fails see if you can boot from a Live Linux CD, assuming your laptop has a CD drive. This will allow you to look into the HD (although it doesn't actually use it). If your files are there they can be copied onto a flash drive.

Note that you will probably have to put the CD drive ahead of the HD in BIOS and disable Safe Boot.

Always pop back and let us know the outcome - thanks

message edited by Derek


Report •
Related Solutions


Ask Question