Windows 7 System Restore Doesn't Work

Acer / Aspire 5670
September 13, 2010 at 19:12:45
Specs: Microsoft Windows 7 Ultimate, 1.667 GHz / 2046 MB
Every time I leave my computer on, inactive, for a long time it freezes so I am forced to turn the power off. But when I try to start it up again Windows loads up until the point where it says: "Welcome" and just freezes. I started the system repair disk, and when I choose "Recover" a list of restore points appears just fine. It's until the system restore its done running that it gives me a message saying:"System Restore failed to extract the original copy of the directory from the restore point.
Source %SystemRoot%\registrarion
Destination: ComPlusStaging"

I have tried several different restore points but I get the same result. I've also tried to use System Image but every time I try to make an image it also fails! I have ran my antivirus software several times and nothing. I can, however, run my computer in safe mode. And running the "last know configuration that worked" also worked. But it's the inability to create any safety nets that I am concerned about. Any light you can shed on this I would greatly appreciate it. Thank you.
PS.
I don't have the installation CD


See More: Windows 7 System Restore Doesnt Work

Report •

#1
September 15, 2010 at 15:53:30
This honestly sounds like a bug within your current Windows 7 installation. If its throwing out that error while trying to do a restore then it sounds like Windows 7 has corruptions in it, in more than one spot.

What I would do is either format the hard drive and use the system restore CD to re-install the operating system, or.. if you have data on it you need to keep, purchase a new hard drive and install it on there.


Report •

#2
September 15, 2010 at 23:16:27
you may just need to run a full disk check and check for bad sectors etc etc, if you can get into your system, do that.
if it happens after been in hibernation or sleep, it may also a driver issue.or one of your devices may have trouble with sleep mode check all your power management options on each device.
if all this fails
then try a save all files etc and do a full format and reinstall.

i hate computers!
but cant help myself....


Report •
Related Solutions


Ask Question